none
Erreur pour n'importe quelles Webparts "Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))" RRS feed

  • Question

  • Bonjour, j'ai un assez gros probleme avec l'ajout de webpart ... Des que je veux inserer n'importe quelle webpart, j'ai un message d'erreur ..soit il dit que la liste est peut etre masqué soit ilme sors une erreur du type: Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))"

     

     

    Voila mon log sharepoint :

     

    Unknown SPRequest error occurred. More information: 0x80020009 
    Failed to add webpart http%253A%252F%252Flthomas%252F%255Fcatalogs%252Fwp%252FWPC%252Edwp;WPC.  Exception Microsoft.SharePoint.SPException: Une exception s'est produite. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)) ---> System.Runtime.InteropServices.COMException (0x80020009): Une exception s'est produite. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))     at Microsoft.SharePoint.Library.SPRequestInternalClass.AddWebPart(String bstrWebUrl, Boolean fAllUsers, String bstrID, String bstrWebPartTypeID, Boolean fIsIncluded, Byte bFrameState, String bstrZoneID, Int32 lPartOrder, Byte[]& ppsaAllUsersProperties, Byte[]& ppsaPerUserProperties, String[]& ppsaLinks)     at Microsoft.SharePoint.Library.SPRequest.AddWebPart(String bstrWebUrl, Boolean fAll... 
    ...Users, String bstrID, String bstrWebPartTypeID, Boolean fIsIncluded, Byte bFrameState, String bstrZoneID, Int32 lPartOrder, Byte[]& ppsaAllUsersProperties, Byte[]& ppsaPerUserProperties, String[]& ppsaLinks)     --- End of inner exception stack trace ---     at Microsoft.SharePoint.Library.SPRequest.AddWebPart(String bstrWebUrl, Boolean fAllUsers, String bstrID, String bstrWebPartTypeID, Boolean fIsIncluded, Byte bFrameState, String bstrZoneID, Int32 lPartOrder, Byte[]& ppsaAllUsersProperties, Byte[]& ppsaPerUserProperties, String[]& ppsaLinks)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.AddWebPartToStore(WebPart webPart, Int32 viewId, String viewGuid)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.AddWebPartInternal(SPSupersetWebPart superset, Boolean throwIfLocke... 
    ...d)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.AddWebPartInternal(SPSupersetWebPart superset)     at Microsoft.SharePoint.WebPartPages.WebPartQuickAdd.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) 

     

     

    Merci pour votre aide...

    vendredi 8 février 2008 10:57

Toutes les réponses

  • Est ce que ça se produit uniquement avec votre Webpart WPC ou bien vous constater le problème avec d'autres WebParts ?

     

    Sous quelle version de SharePoint êtes vous ?

    vendredi 8 février 2008 10:59
    Modérateur
  • Ma version de sharepoint est WSS . Cette erreur est présente des que je veux rajouter une webpart ( pour toutes les webparts)...

    Autre chose : Je viens de faire un test , j'ai changé la masterPage en utilisant la default.masteret la il n'y a pas de problème , je peux ajouter etc... Donc le problème viendrai de ma masterPage ... mais Où l'erreur peut elle bien provenir ..?!?

     

    Aussi , si j'ajoute la master page ou la modifie avec default.master ca marche et ensuite si je change la masterpage avec la mienne je peux voir les webparts .. La modification ou ajout de webpart ne fonctionne pas avec ma masterpage mais la visualisation oui.

    vendredi 8 février 2008 12:24
  • Personne n'aurai une idée à propos de mon problème .. Ou est ce que je peux avoir plus d'info pour savoir ou pourrait se situer le problème ??? d'autres logs etc...

     

    Merci d'avance..

    lundi 25 février 2008 15:55