none
Désactivation d'un champ lors de la création d'un élément de liste RRS feed

  • Discussion générale

  • Bonjour,

    Je dispose d'une custom list dans laquelle deux des champs auront toujours la même valeur. Ces deux champs sont des liens et les utilisateurs doivent pouvoir cliquer dessus.
    Comme la valeur sera toujours la même, j'aimerais que l'utilisateur n'ait pas à la rentrer lorsqu'il créé un nouvel élément : j'ai donc pensé à un calculated field de type ="monURL". Cela fonctionne mais mon URL est rendue sous forme de texte, donc pas cliquable.
    La deuxième solution est un eventHandler sur le itemAdded : je force les champs en question et quelque soit le contenu, il sera remplacé par ce qui est contenu dans mon eventHandler. Solution pas top, l'utilisateur rentre des données qui sont ensuite écrasées.

    Existe t-il une solution permettant de griser ces champs pour qu'ils soient inaccessibles à l'utilisateur ?

    Cordialement,

    --
    Ange-Pierre
    • Déplacé Gokan OzcifciMVP jeudi 11 octobre 2012 13:21 Question Développement (Origine :Sharepoint 2010, 2007 et versions antérieures pour les professionnels IT)
    • Type modifié Gokan OzcifciMVP vendredi 19 octobre 2012 11:25
    jeudi 4 octobre 2012 13:49

Toutes les réponses

  • Bonjour,

    Pourquoi ne pas utiliser l'event receveir, et masquer le champs en question dans l'editform et la newform (utilisation  des paramètres ShowInNewForm et ShowInEditForm dans la définition de liste) :

      <FieldRef ID="{38311E7D-117C-4D59-A629-14E91571221E}" Name="Lien" DisplayName="Lien" Required="FALSE" ShowInNewForm="FALSE" ShowInEditForm="FALSE" />
    NicoBzh


    jeudi 4 octobre 2012 15:32
  • Bonjour,

    Si votre questions est lié à du DEV, prière de le poser sur le forum adéquate: http://social.technet.microsoft.com/Forums/fr-FR/sharepointfr/threads

    Merci pour votre collaboration.

    Cordialement,

    Gokan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 4 octobre 2012 17:02
  • Effectivement je me suis loupé sur le forum (mauvais raccourci). Si un admin passe par là et qu'il a le temps de déplacer ce post vers la section appropriée, je l'en remercie d'avance.
    vendredi 5 octobre 2012 13:18
  • Bonjour,

    Nous changeons le type de votre question à « Discussion générale » parce que vous n’êtes pas revenu avec les informations sollicitées. Si vous avez plus de temps pour réexaminer la question et fournir plus d'informations, n'hésitez pas à modifier le type du thread à « Question ». Si le problème est résolu, s’il vous plaît partagez la solution avec nous afin que la réponse puisse être trouvée et utilisée par d'autres membres de la communauté ayant des questions similaires.

    Merci !

    Cordialement,


    Gokan Ozcifci
    SharePoint Community Expert

    vendredi 19 octobre 2012 11:25