none
Changer la couleur des accolades

Toutes les réponses

  • Bonjour Pascal,

    Avez-vous coché "Mettre les délimiteurs en surbrillance automatiquement" dans Options -> Éditeur de texte ? 
    Avez-vous détecté ce problème avant la mise à jour Update 2 ?
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 14 juin 2016 12:48
    Modérateur
  • Bonjour Teodora,

    Oui, cette option est bien cochée par défaut.

    Ce problème était déjà présent depuis le début de la version Visual studio community 2015.

    Merci de votre aide.

    Bien cordialement.

    Pascal


    pascal

    mardi 14 juin 2016 15:05
  • Bonjour cilou14,

    les accolade sont dans "ponctuation"

    Outils > Options > Polices et couleurs > Ponctuations

    Seulement, ça va aussi changer la couleur des parenthèses par exemple.


    Cordialement
    mardi 14 juin 2016 15:19
  • Re bonjour Teodora,

    Merci pour l'info, mais l'option dans la rubrique "ponctuation" ne m'intéresse pas.

    Je veux changer la couleur des 2 accolades d'un bloc seulement quand le curseur est devant l'accolade fermant, comme l'image ci-dessous.

    Cordialement


    pascal

    mardi 14 juin 2016 17:37
  • Bonjour,

    Options > Environment > Fonts and Colors et choisissez Brace Matching dans Display items. Ensuite, indiquez la couleur désirée.

    samedi 18 juin 2016 05:09
  • bonjour,

    Merci pour votre réponse, mais ça ne fonctionne pas.

    Je pense qu'il y a un bug sur la version, Visual studio community 2015 upload 2. Car dans une version antérieure (2013) ça fonctionnais.

    Cordialement


    pascal

    samedi 18 juin 2016 15:29
  • Et pourtant ça fonctionne comme je l'ai indiqué. Voyez ce printscreen après avoir changé la couleur de Item Background à rouge

    samedi 18 juin 2016 15:57
  • Bonsoir,

    A priori, je crois que vous utilisez pas la même version que moi. Voici une capture des options que je modifie,  sans aucun effet :


    pascal

    samedi 18 juin 2016 20:57
  • Bonjour cilou14,

    Tentez une réparation de Visual Studio si vraiment ce problème vous gène.

    Cordialement

    dimanche 19 juin 2016 06:43
  • Bonjour,

    Il semble qu'il y avait un bug avec cette option dans les premières versions de VS2015 : bug. Mais ce serait corrigé. Avez-vous installé les dernières mises à jour ?

    dimanche 19 juin 2016 07:02
  • Bonjour,

    Oui, j'ai bien installé la dernière version de "Visual studio community 2015 upload 2".

    Pour info : j'ai installé Visual studio community 2015 sur plusieur PC, et j'ai toujours le même problème.

    Comment on réalise une réparation de Visual Studio ?

    Cordialement.


    pascal

    dimanche 19 juin 2016 09:33
  • j'ai exactement le même problème... quelqu'un a t'il réussi à avoir une version deboguée ? Je vais tenter une mise à jour mais franchement c'est pénible comme bug...

    

    mardi 30 octobre 2018 15:14