Add STS Reference with WIF


  • Hi,

    Using VS2010 and WIF.

    When I log in as administrator, I get "Add STS Reference" on the context menu for the site. When logged in to the machine as any other user (inclduing members of the administrator group), the option is just simply not there. Any ideas why?

    I saw  Rodrigo Gomez Indellicati  suggested this command which I tried and it doesn't work...

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv /ResetAddin Microsoft.IdentityModel.Tools.VS.VSAddin.FederationAddin

    ...the command returns successfully but the option to add an STS reference is still missing in VS2010 - even after a reboot.


    Curiouser and curiouser

    jeudi 7 avril 2011 15:46


  • It seems if you add WIF from the admin account - you get this behaviour.


    I re-installed from admin - same thing.

    re-installed from a different user account and all worked fine - for all accounts on the machine.

    Curiouser and curiouser..

    jeudi 7 avril 2011 22:05

Toutes les réponses