none
Deploiement ClickOnce / VB 2008 sous Apache RRS feed

  • Question

  • Bonjour,

    J'essaye de déployer une application sous VB Express 2008 via ClickOnce sur un serveur apache en utilisant le protocole FTP.

    Je rencontre l'erreur suivante :
    Citation:
    Erreur 5 Échec lors de la connexion à 'ftp://ftp.monsite.com/', accompagné de l'erreur suivante*: Impossible de créer le site Web 'ftp://ftp.monsite.com/'. Les composants nécessaires à la communication avec les extensions serveur FrontPage ne sont pas installés.
    J'ai mis dans le fichier .htaccess du répertoire de destination FTP les paramètres suivants :
    Citation:
    # Microsoft ClickOnce
    AddType application/x-ms-application application
    AddType application/x-ms-manifest manifest
    AddType application/octet-stream deploy
    Rem : Je me connecte sans Pb via FF sous ftp://ftp.monsite.com

    Quelqu'un a t-il une idée du problème ?

    Merci de votre aide.

    Cordialement,
    mercredi 7 avril 2010 07:47

Réponses

  • Bonjour,

    J'utilise une configuration similaire : serveur web sous Apache, et FTP sous FileZilla.

    Dans "Emplacement du dossier de publication" clique sur les points de suspension pour afficher la fenêtre "Ouvrir le site web". Sélectionne "Site FTP".

    Dans "Serveur" tape le nom de ton serveur sans "ftp://", saisi le nom de ton dossier de destination, décoche la case "connexion anonyme" et saisi tes identifiants FTP.

    Attention au nom de dossier de destination : si tu as sous Apache c'est très probablement que ton serveur tourne sous Linux. Les majuscules/minuscules sont donc prises en compte.

    Curieusement lorsque tu vas publier ton appli, VB réaffiche une fenêtre de connection proposant de nouveau une connection anonyme. Pense à décocher cette option, et à ressaisir tes identifiants.

    Si ça ne fonctionne pas tu peux aussi publier ton appli dans un dossier en local, et l'uploader avec ton client FTP. Ca fait une manip de plus, mais ça peut être plus simple si tu n'as pas la main sur le serveur.

    Cordialement,

    Pascal

    lundi 12 avril 2010 08:18

Toutes les réponses

  • Bonjour,

     

    J’ai trouvé un problème similaire : http://social.msdn.microsoft.com/Forums/en/winformssetup/thread/fa09fa69-e0b4-4970-981e-69175c5764ea

     

    Essayez de mettre l’url d’installation comme http:// et garder ftp seulement pour la publication. Vous pouvez aussi installer les extensions FrontPage Server, car je vois que votre message d’erreur signale que ces composants manquent :

    http://support.microsoft.com/default.aspx/kb/156842?p=1

     

     

    Cordialement,

    Alex


    Appel à contribution ! http://social.msdn.microsoft.com/Forums/fr-FR/vbasicfr/thread/ff4910bf-dca4-4664-b01e-b58bd860a643
    jeudi 8 avril 2010 10:09
  • Merci de ces informations.

     

    Mais hélas sans succés j'ai beau positionner dans :

    Emplacement du dossier de publication : ftp://ftp.monsite.com/monAppli/

    URL du dossier d'installation : http://monsite.com/monAppli/

     

    Toujours la meme erreur.

    Et je ne peux pas installer les extensions FrontPage Server car je suis sur un serveur mutualisé.


    vendredi 9 avril 2010 07:11
  • Bonjour,

    J'utilise une configuration similaire : serveur web sous Apache, et FTP sous FileZilla.

    Dans "Emplacement du dossier de publication" clique sur les points de suspension pour afficher la fenêtre "Ouvrir le site web". Sélectionne "Site FTP".

    Dans "Serveur" tape le nom de ton serveur sans "ftp://", saisi le nom de ton dossier de destination, décoche la case "connexion anonyme" et saisi tes identifiants FTP.

    Attention au nom de dossier de destination : si tu as sous Apache c'est très probablement que ton serveur tourne sous Linux. Les majuscules/minuscules sont donc prises en compte.

    Curieusement lorsque tu vas publier ton appli, VB réaffiche une fenêtre de connection proposant de nouveau une connection anonyme. Pense à décocher cette option, et à ressaisir tes identifiants.

    Si ça ne fonctionne pas tu peux aussi publier ton appli dans un dossier en local, et l'uploader avec ton client FTP. Ca fait une manip de plus, mais ça peut être plus simple si tu n'as pas la main sur le serveur.

    Cordialement,

    Pascal

    lundi 12 avril 2010 08:18
  • Bonjour,

     

    Tu as du désinstaller le webdesignercore. (cf http://support.microsoft.com/kb/945358/fr)

    En prenant l'exécutable dispo sur le cd d'install dans <var>X:</var> \WCU\WebDesignerCore (il n'y a qu'un fichier dans le dossier), tout devrait rentrer dans l'ordre.

    Voilà, j'espère que cette réponse tardive sera utile à quelqu'un.

     

    E. Colin

    jeudi 4 novembre 2010 11:43
  • Upload manuellement les fichiers de ton appli (contenus dans le dossier publish de ton projet) dans ton dossier distant avec filezilla puis tu dois mettre dans le dossier de ton application un fichier .htaccess contenant ceci :

    AddType application/manifest .manifest
    AddType application/xaml+xml .xaml
    AddType application/x-ms-application .application
    AddType application/x-ms-xbap .xbap
    AddType application/octet-stream .deploy

    à la place de

    # Microsoft ClickOnce
    AddType application/x-ms-application application
    AddType application/x-ms-manifest manifest
    AddType application/octet-stream deploy

    http://www.scalpa.info
    jeudi 4 novembre 2010 18:29