none
[WSS] [Connexion site nom serveur / IP] RRS feed

  • Question

  • Bonjour,

    Je dispose de sites sous WSS. Je viens de me rendre compte qu'il existe des différences de fonctionnement ou de rendu selon que l'on lance le site via le nom du serveur ou via son adresse IP !!!

    Si je saisis : http:\\swss:90 : il est noté près du nom "Bienvenue...", le chargement d'un fichier word se fait automatiquement...
    Si je saisis : http:\\10.0.0.10:90 : il est noté près du nom "Welcome...", le chargement d'un fichier word nécessaite une saisie du login mot de passe...

    Quelqu'un peut il m'expliquer cette différence ?

    Pour info, les sites utilisent l'AD.

    Merci d'avance

    Eric
    lundi 11 janvier 2010 16:59

Réponses

  • Bonjour,

    En conclusion, voici la solution

    - Il faut indiquer les mappages par défaut et intranet des URL public au sein de l'administration de sharepoint
    - Il faut revoir les options de IE : outils, Option internet, sécurité (site intranet et site de confiance)

    Concernant, l'authentification demandée lors de la consultation d'un document stocké dans la gestion documentaire, il s'agit d'un problème d'environnement : j'accède au site sharepoint d'une machine qui se trouve dans un autre domaine, d'où l'authentification systèmatique.

    A bientôt

    Eric
    • Marqué comme réponse Mix59 jeudi 21 janvier 2010 13:57
    jeudi 21 janvier 2010 13:57

Toutes les réponses

  • Je ne serais pas expliquer ce changement de Bienvenue en Welcome mais dans une archi avec AD+DNS tu peux configurer les adresses des zones dans l'administration centrale de SharePoint:

      Administration centrale > Opérations > Mappages des accès de substitution > Modifier les URL des zones publiques
    lundi 11 janvier 2010 18:17
  • Merci pour ce début de piste.

    J'ai donc déclaré http://swss:90 en zone default et http://10.0.0.10:90 en zone intranet.
    Je n'ai plus de différence de langue ce qui est un bon point ;-))
    Ne reste plus que la demande du login / mot de passe pour l'ouverture d'un doc word lorsque l'on utilise http://10.0.0.10:90
    mardi 12 janvier 2010 10:07
  • Bonjour,

    Je pense qu'il s'agit de paramètres de sécurité coté navigateur.
    Pour que l'authentification windows soit faite sans prompt, il faut utiliser le nom du serveur pour l'url et que celui-ci fasse partie du domaine  (comme pour http://swss:90), OU que l'adresse du serveur soit configurée dans les sites de confiances.

    Dans IE : options internet, sécurité, intranet local, sites, ajoutez l'url de votre site SharePoint.

    Est-ce que cela résoud le problème ?

    Une solution plus propre est de mapper un vrai nom de domaine et d'utiliser le port 80. Si votre domaine est toto.net, dans l'administration du DNS vous pourriez mapper sharepoint.toto.net sur http://10.0.0.10 . Il faudrait là encore modifier les alternate access mappings. 
    IE identifierait alors que le site fait partie du domaine et passerait l'authentification windows sans manipulation supplémentaire lorsqu'un utilisateur accederait à
    http://sharepoint.toto.net.


    http://blogs.developpeur.org/anouvel
    Merci de valider les réponses qui correspondent à votre problème afin qu'il apparaisse comme résolu.
    • Proposé comme réponse Arnault Nouvel mercredi 13 janvier 2010 07:21
    • Marqué comme réponse Mix59 jeudi 21 janvier 2010 13:53
    • Non marqué comme réponse Mix59 jeudi 21 janvier 2010 13:57
    mercredi 13 janvier 2010 07:21
  • Bonjour,

    En conclusion, voici la solution

    - Il faut indiquer les mappages par défaut et intranet des URL public au sein de l'administration de sharepoint
    - Il faut revoir les options de IE : outils, Option internet, sécurité (site intranet et site de confiance)

    Concernant, l'authentification demandée lors de la consultation d'un document stocké dans la gestion documentaire, il s'agit d'un problème d'environnement : j'accède au site sharepoint d'une machine qui se trouve dans un autre domaine, d'où l'authentification systèmatique.

    A bientôt

    Eric
    • Marqué comme réponse Mix59 jeudi 21 janvier 2010 13:57
    jeudi 21 janvier 2010 13:57
  • J'ai le même cas de figure : un http://intra  redirigé grâce aux mappages sur http://www.monsite.com   (déposé)
    J'ai revu la config en interne : Options Sécurité IE, site intranet et site de confiance.

    Tout fonctionne bien sauf que l'authentification persiste sur chaque document ouvert dans la gestion documentaire quand je passe par www.monsite.com. J'ai bien pensé à utiliser mon serveur DNS mais le domaine est local.

    Si votre domaine est toto.net, dans l'administration du DNS vous pourriez mapper sharepoint.toto.net sur http://10.0.0.10 .
    Mon domaine est domaine.local et je voudrais rediriger monsite.com sur le sharepoint du serveur : intra.domaine.local.

    En fait, je cherche à configurer le serveur DNS (Windows 2003) pour faire le lien entre www.monsite.com et le nom (ou l'IP pour être plus précis) de mon serveur. Et là, je sèche.
    mardi 2 février 2010 14:00