none
[SharePoint 2013] - Créer des alertes SharePoint Alerts pour des Groupes AD RRS feed

  • Question

  • Bonjour.

    J'essaie d'ajouter une alerte pour un groupe AD sur une bibliothèque de documents. Lorsque j'arrive dans le picker pour saisir le groupe de sécurité AD, je n'arrive pas à la trouver. Le picker me dit qu'il ne trouve pas cet élément.

    Ce groupe AD est Universel et Groupe de sécurité dans l'AD. J'ai également essayé de créer une liste de distribution dans Exchange basée sur mon groupe AD. Même constat. J'arrive quand même à trouver mes utilisateurs AD.

    Dans ma ferme j'ai 2 serveurs : 1 SharePoint Server 2013 Standard, 1 sql Server 2008R2. J'ai un AD en 2008 et Exchange 2010. Le service de profils utilisateurs n'est pas déployé, on a seulement déployé les métadonnées gérées et la recherche.

    Voyez-vous d'où mon problème pourrait venir ?

    Merci !

    mardi 16 juillet 2013 15:19

Réponses

  • Bonjour,

    A titre d'information, les alertes sous Sharepoint ne fonctionnent pas sur des groupes de Sécurité AD, par contre elles fonctionnent sur des groupes de distribution. Il s'agit d'une limite du produit.

    Pour faire une liste de distribution mail, vous pouvez faire un groupe Sharepoint qui contient des utilisateurs.

    Bon courage


    Thierry Buisson

    lundi 22 juillet 2013 09:40
    Modérateur

Toutes les réponses

  • Si le domaine ressource (tes serveurs) n'a pas d'approbation sur le domaine user, il faut pour les voir déclarer une chaine + login/mdp. A l'époque c'était stsadm -o seaachadforests.

    Sinon, je ne vois pas.


    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2013)

    mercredi 17 juillet 2013 08:13
  • Bonjour,

    As tu un seul Domaine/Forêt ou plusieurs ?

    As tu essayé de rebooter tes serveurs et de rouler le configuration Wizard ensuite ?

    Merci

    mercredi 17 juillet 2013 16:37
  • Bonjour,

    tu peux aussi regarder ces liens

    • http://www.c-sharpcorner.com/Blogs/11061/configure-people-picker-in-sharepoint-2013-2010-sharepoi.aspx
    • http://mossnwss.blogspot.be/2012/10/configure-people-picker-in-sharepoint.html
    • http://qandasys.info/sharepoint-2013-ad-users-not-found-on-peopleuser-picker-but-they-shows-up-only-in-central-admin-site/

    Courage!

    Gokan


    My Technical Blog on Wordpress

    mercredi 17 juillet 2013 16:38
  • Merci pour vos réponses. 

    J'ai bien 1 seul AD, 1 foret, 1 domaine avec 2 OU => SharePoint et une autre.

    Redémarrage ne fait rien, wizard non plus. Je précise à nouveau que je n'ai pas de service de profils utilisateurs (UserProfile) et que mon client ne souhaite pas le déployer.

    J'ai constaté le même comportement sur deux autres fermes chez des clients... bug ? changement fonctionnel ?

    merci de votre aide !

    jeudi 18 juillet 2013 10:01
  • Une question subsidière: "J'essaie d'ajouter une alerte pour un groupe AD sur une bibliothèque de documents. " -> Le people picker, fonctionne t'il dans des autres concepts? genre ajout des permissions, etc .. ? Si vous donnez des droit a votre group AD le people picker arrive t'il a le trouver?

    Thanks!


    My Technical Blog on Wordpress

    vendredi 19 juillet 2013 06:29
  • Oui il fonctionne très bien pour les droits/permissions avec groupes SP et AD, utilisateurs etc.

    Il n'y a que dans la page de création d'une alerte où il ne remonte pas. J'ai même testé le mode "barbare" en éditant la page Subnew.aspx (souscription d'une nouvelle alerte) en modifiant la signature du peoplepicker et lui ajoutant tous les types d'éléments... même résultat, seuls les users remontent. 

    Je commence à me demander si ce n'est pas une régression, une nouvelle restriction, it's not a bug... it's a feature ;)

    vendredi 19 juillet 2013 06:52
  • question con, comme c'est des alertes, l'outbound mail est bien déclaré? les comptes on une boite? le compte avec lequel tu fais la manip / les comptes a flagger a/ont les droits sur le contenu concerné?  :)

    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2013)

    vendredi 19 juillet 2013 14:50
  • Oui bien sûr ;)

    Les mails sortant sont configurés (et fonctionnent pour les alertes pour 1 utilisateur, les workflows etc).

    Tous les comptes / groupes AD ont une boite mail dans exchange et renseignée dans l'AD.

    Et le compte a bien les droits partout (même essayé avec le compte admin du domaine..., admin SP)

    vendredi 19 juillet 2013 15:25
  • Bonjour,

    A titre d'information, les alertes sous Sharepoint ne fonctionnent pas sur des groupes de Sécurité AD, par contre elles fonctionnent sur des groupes de distribution. Il s'agit d'une limite du produit.

    Pour faire une liste de distribution mail, vous pouvez faire un groupe Sharepoint qui contient des utilisateurs.

    Bon courage


    Thierry Buisson

    lundi 22 juillet 2013 09:40
    Modérateur
  • Bonjour,

    J'ai eu la même problématique en SP2010, et j'ai finalement créé des alertes "unitaires" car cela pose le problème de l'envoi de mail à un groupe de sécurité... ce qui n'est pas vraiment prévu par Exchange, si j'ai bien compris.

    Il y a visiblement un "contournement" pour pouvoir le faire, en créant le groupe de sécurité avec une adresse mail (plus possible après la création), mais je n'ai pas réussi à le mettre en place.


    Lloyd, MCITP SharePoint Administrator 2010


    • Modifié Gokan OzcifciMVP mercredi 24 juillet 2013 06:46 modification du mot hack
    lundi 22 juillet 2013 13:04
  • Bonjour,

    Ce sujet m'intéresse. Je suis sur un SharePoint Online 2013.

    Dans une liste de discussion (au sein d'un Site forum Sharepoint) je souhaiterais définir une alerte pour un ensemble d'utilisateurs. J'ai donc procédé de la sorte : définition d'une alerte dans "Envoyer les alertes à" mais le champ n'accepte que les utilisateurs individuellement. Impossible d'y mettre un groupe ; j'obtiens le message "Nous n'avons pas trouvé de concordance exacte".

    Auriez-vous une idée ?

    Merci d'avance.

    Cordialement

    mardi 8 mars 2016 16:16