none
[WSS] [Installation Features - Erreur exécution] RRS feed

  • Question

  • Bonjour,

    J'ai installé une features sous WSS : Mapilab statistics. La features est activée au niveau de l'admin centrale de SP ainsi sur sur mes sites. Sur les sites, pas de probléme.

    Par contre, sur le site d'admin de SP, j'ai une erreur lorsque je veux consulter les statistiques. Voici ce que me donne les logs :

    05/31/2010 17:43:23.97  w3wp.exe (0x0AA8)                        0x0C8C Windows SharePoint Services    General                        8dzz High     Exception Type: System.Web.HttpException  Exception Message: Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.

    J'ai tenté de mettre les lignes suivantes dans le web.config (répertoire 12\config) dans la rubrique httpmodules mais rien ne change.

    <add name="MAPILabStatisticCollector" type="MAPILab.SharePoint.Statistics.MLHttpModule, MAPILab.SharePoint.Statistics, Version=1.0.3000.15, Culture=neutral, PublicKeyToken=b2bc3c467982d939" />
          <add name="Session" type="System.Web.SessionState.SessionStateModule" />

    Quelqu'un a t'il une idée ?

    Merci d'avance

    Eric

    lundi 31 mai 2010 15:54

Réponses

  • Un grand merci Xavier.

    Grace à l'outil de gestion de IIS, j'ai pu me rendre compte que l'admin (port 2675) pointait sur le répertoire 19070 dans inetpub !!! J'ai pu modifier enfin le bon web.config pour y ajouter les lignes manquantes dans la section httpmodules.

    Désormais, Ma features fonctionne aussi sur l'admin. Il n'y avait pas de raison

    • Marqué comme réponse Mix59 mercredi 2 juin 2010 13:17
    mercredi 2 juin 2010 13:14

Toutes les réponses

  • Mon fichier web.config me semble correcte (httpmodule déclaré et valeur sessionstate à True) ainsi que la page aspx (directive sessionstate à true).

    Petite précision suite à diverses recherches : La central admin est en anglais alors que mes sites sont en français. Celà peut il avoir une importance ?

    mardi 1 juin 2010 13:27
  • Bonjour,

    les changements du fichiers de configuration doivent se faire ou se situe le site:

    c:\inetpub\wwwroot\wss\virtual directories\port du site\

    pas dans le répertoire 12\config, cela peut meme être dangereux.

     


    Xavier VANNESTE http://www.xvanneste.com http://media.xvanneste.com
    mardi 1 juin 2010 13:49
    Auteur de réponse
  • Bonjour Xavier,

    Effectivement et j'en suis conscient. J'ai opéré cette manipulation car dans inetpub, il n'existe pas de répertoire pour l'admin central de SP. En l'occurence, je ne touve pas de répertoire nommé avec le même numéro de port !

    D'ailleurs, j'aimerai comprendre où se situe la wep app de la centrale admin !

     

    mercredi 2 juin 2010 09:02
  • Avec IIS tu peux avoir les port et repertoire de tes sites. Tu vas dans panneau de config/ outil d'admin et dans IIS tu as les differents site qui apparaissent et quand tu en selectionne dans ses propriétés tu as le répertoire qui correspond au site.

    A la rigueur seul _layout est différent mais comme il herite du site parent ce ne sera pas genant pour toi.

     


    Xavier VANNESTE http://www.xvanneste.com http://media.xvanneste.com
    mercredi 2 juin 2010 09:13
    Auteur de réponse
  • Un grand merci Xavier.

    Grace à l'outil de gestion de IIS, j'ai pu me rendre compte que l'admin (port 2675) pointait sur le répertoire 19070 dans inetpub !!! J'ai pu modifier enfin le bon web.config pour y ajouter les lignes manquantes dans la section httpmodules.

    Désormais, Ma features fonctionne aussi sur l'admin. Il n'y avait pas de raison

    • Marqué comme réponse Mix59 mercredi 2 juin 2010 13:17
    mercredi 2 juin 2010 13:14