none
[WWS3.0] Connexion LDAP (avec authentification par formulaire) RRS feed

  • Question


  • Bonjour à tous,


    Je rencontre un problème de connexion vers un serveur Active Directory à partir de de site WSS utilisant l'authentification par formulaire par le protocole LDAP.
    Les 2 machines (celle hebergeant l'application WSS et celle de l'AD) sont différentes et appartiennent à 2 réseaux distincts.

    J'ai suivi les différentes étapes décrites dans les sites:
    • http://technet2.microsoft.com/windowsserver/WSS/en/library/91035419-980e-4230-b3ae-67253b94af4a1033.mspx?mfr=true
    • http://softlogger.com/3599/most-popular-post/Using-the-Active-Directory-Membership-Provider-with-Forms-Authentication-in-MOSS-2007.aspx
    Les paramètres de connexion LDAP sont corrects (la connexion marche avec un client ADAM installé sur la même machine pour les mêmes paramètres)
    Mais j'obtiens toujours l'erreur suivante:
    "Le serveur n'a pas pu vous inscrire. Vérifiez que votre nom et votre mot de passe sont corrects, puis réessayez."

    Auriez vous déjà rencontré ce problème ?
    Avez vous des pistes de résolution ?
    Pouvez vous m'aider ? Big Smile

    Je vous remercie par avance,


    mercredi 8 août 2007 18:23

Toutes les réponses

  • Bonjour

     

    Vu le message d'erreur, je serais tenté de dire que ça vient du compte utilisé pour la connexion à l'annuaire LDAP.

     

    J'ai eu à configurer une authentification sur du LDAP, et il m'a fallu reconfigurer un peu l'annuaire pour autoriser les connexions anonymes :

    1.    Lancer la ligne de commande ADAM (ADAM Command Prompt)

    2.    Faire « dsmgmt »

    3.    Taper « ds behavior »

    4.    Puis « connexions »

    5.    Le prompt doit être « server connections », taper « connect to server localhost:389 »

    6.    Puis « quit »

    7.    Taper « allow passwd op on unsecured connection », puis « quit »

    8.    Au prompt « dsmgmt », taper « configurable settings »

    9.    Puis « set RequireSecureProxyBind to 0 »

    10.  « commit changes »

    Puis sortez de l’application par une série de « quit »

     

    De plus, voici un exemple de ma configuration :

    <membership defaultProvider="AdamMembershipProvider">

            <providers>

              <clear />

              <add

                name="AdamMembershipProvider"

                type="Microsoft.Office.Server.Security.LDAPMembershipProvider, Microsoft.Office.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"

                server="Nomduserveur"

                port="389"

                useSSL="false"

                userDNAttribute="distinguishedName"

                userNameAttribute="userPrincipalName"

                userContainer="CN=Users,DC=MONSITE,DC=COM"

                userObjectClass="person"

                userFilter="(ObjectClass=person)"

                scope="Subtree"

                otherRequiredUserAttributes="sn,givenName,cn"

                applicationName="/"

              />

            </providers>

          </membership>

     

    J'espère que ca pourra aider.
    vendredi 10 août 2007 20:43
  • Bonjour,

    Merci beaucoup pour ta réponse.
    J'ai peut etre mal compris ta réponse mais en fait, l'authentification LDAP se fait sur un Active Directory et non sur un  ADAM. D'autre part, je n'utilise pas une connexion anonyme, j'ai un compte qui fonctionne bien.
    Gat, tu te connectes bien sur un ADAM et non un AD, toi ??

    a+
    Cordialement

    lundi 13 août 2007 08:21