none
Problem deploying a custom retention formula feature RRS feed

  • Discussion générale

  • In a formLibrary I configured the retention mechanism.
    As I can not specify the cause of retention on a non-date field, I developed a custom retention formula feature.
    I deployed in my development environment from visual studio and all work fine.

    Then I deployed the feature in our production environment with PowerShell.

    In Central administration my solution has status Deployed, Globally Deployed.

    But in the configuration of the event stage, the option "set by a custom formula retention installed on this server" remain disabled and I do not know why.
    Is there a particular service to be activated, a feature or something? Any idea?

    Thank in advance

    Version : SharePoint 2010 Ent


    jeudi 23 janvier 2014 13:03

Toutes les réponses

  • Hi/Bonsoir SwissSeb,

    Ce forum étant francophone, pourriez-vous reformuler votre question en français SVP. D'avance, merci!

    This forum is French-speaking, can you please report your quest in French or post in the appropriate English-speaking one? Thanks beforehand!


    Marc Lognoul [Infrastructure Expert]

    My Site/Mon Site |  MyBlog [EN]  | Mon Blog [FR]  |  Twitter  |  LinkedIn

    jeudi 23 janvier 2014 19:23
  • Bonjour,

    Je travaille avec SharePoint 2010 Entreprise.

    Dans une bibliothèque de formulaire,  J’utilise la planification de rétention. Ma stratégie de rétention est basée sur une Date, un Statut de documents et la fait que le document soit extrait ou non.

    Ne pouvant exprimer ce déclanchement avec les options par défaut (Activation Rétention > Propriété de l’étape > Spécification de la cause de l’activation) qui restreint les règles sur des colonnes de type Date, j’ai développé « Une formule de rétention personnalisée ».

    Dans mon environnement de développement, avec un déploiement de type Visual Studio ou Power Shell, tout fonctionne bien et je peux sélectionner l’option « Définir par un formule de rétention personnalisée, installée sur ce serveur : » et sectionner le composant déployé.

    En revanche, lorsque que je déploie par Power Shell sur mon environnement de production, l’option précédente reste désactivée.

    Depuis la Central Admin, je constate que ma solution est bien déployée. De même dans le site concerné la Feature est bien activée, mais je ne peux pas configurer « Une formule de rétention personnalisée ».

    Si quelqu’un à une idée, je suis preneur.

    Merci d’avance

    vendredi 24 janvier 2014 11:17