none
[SP2013-VS2012] Serveur Sharepoint non reconnu RRS feed

  • Discussion générale

  • Bonjour, 

    J'ai un soucis avec mon serveur Sharepoint 2013, j'essai de créer un projet sous Visual Studio 2012, sauf que premièrement, au lancement de l'application j’ai un message comme quoi VS n'est pas compatible avec mon Win Serveur 2008 R2, et une fois lancée, je créer un projet SharePoint 2013, et message d'erreur "Sharepoint Not installed" alors qu'il est tout à fait présent et fonctionnel ...

    VS et SP sont sur le même serveur.

    Y'a il une configuration dans VS2012 à faire pour lui déclarer mon serveur ?

    Merci d'avance.

    Aurélien.

    mardi 25 juin 2013 11:26

Toutes les réponses

  • Bonjour,

    3 questions pour être sûr :

    1. As tu bien installé les dernière updates de VS2012 (notamment update 2)
    2. As tu bien installé le "Office Development tools for Visual Studio 2012" qui te permet les modèles de projets pour SharePoint 2013 et pour les APPs ?
    3. L'erreur dont tu parles tu l'as dès le début de la création du projet SharePoint sous VS , où à partir du moment où tu donnes l'url du site où tu veux deployer/debuguer le projet ?

    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    vendredi 28 juin 2013 07:49
  • Bonjour, 

    1. Suite à votre question j'ai installé le Update 3 (le seul disponible), du coup je n'ai plus l'erreur d'incompatibilité avec W2k8 R2, mais je ne peut toujours pas créer de projet SP 2013

    2. Oui j'ai bien le VS2012 Tools d'installé, j'ai bien les propositions de de projet SP2013 (projet, web part, workflow...)

    3. L'erreur apparait au moment où je veux créer un projet SP2013:

    - je vais dans nouveau projet

    - office/SP

    - SharePoint Solution

    - SharePoint 2013 Project

    - et je fais OK, et c'est à ce moment là que l'erreur apparaît: 

    "Sharpeoint Not Installed

    The required version of Sharepoint server is not installed on this system. SP Foundation 2013 or SP Server 2013 must be installed to work with SP Farm or sansboxed solutions"

    De plus, lorsque je vais dans l'explorateur de serveurs et que j'essai d'ajouter une "SharePoint Connections" j'ai un message d'erreur:

    "Une tache a été annulée".

    • Modifié Aurélien R vendredi 28 juin 2013 09:35 aout
    vendredi 28 juin 2013 09:11
  • Ok, alors je dois avoir ça potentiellement pour plusieurs raisons :

    • Visual studio pas lancé en mode "run as admin" (peu probable en fait à cette étape, mais on sait jamais :) )
    • Pas admin local de la machine
    • Pas SPShell-Admin -> Add-SPShellAdmin domain\login
    • Pas assez de droits sur l'instance SQL Server -> le plus simple pour valider (même si c un peu dirty) serait que tu ajoutes ton compte en tant que sysadmin sur toute l'instance....

    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    vendredi 28 juin 2013 10:16
  • J'utilise un compte admin du réseau, qui est présent dans le Groupe admin local, Groupe WSS_Admin_WPG local

    Par contre quand j'essai de me connecter à ma BDD depuis VS, il trouve pas mon serveur ... j'ai pourtant aucun soucis avec Sharepoint ou autre.

    Du coup est ce que VS n'aurai pas un soucis d'accès direct? (en gros, serveur injoignable) 

    vendredi 28 juin 2013 11:07
  • la question n'est pas VS, mais le compte utilisé lors du lancement de VS ;) et ce n'est pas forcement le même compte qui a été fourni à sharepoint lors de sa config....

    et oui je te confirme que le compte utilisé pour lancer VS doit avoir accès au SQL, sinon le ev sera pas possible. Donc il faut comprendre pkoi ce compte n'y a pas accès, verifie en lançant une commande powershell pour sharepoint :

    • get-spshelladmin 
    • add-spshelladmin [lenomducompte]


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    vendredi 28 juin 2013 11:58
  • J'y ai regardé et le compte que j'utilise depuis l'installation est bien ajouté à la base de donnée

    Je vais essayer de voir un peu plus du coté SQL alors

    vendredi 28 juin 2013 12:07
  • J'en enfin pu accéder à ma base de données sur VS2012, SQL Browser n’était pas actif, par contre aucun changement quand à la détection de SP2013, toujours introuvable ...
    lundi 1 juillet 2013 12:32
  • Bonjour Aurelien

    As tu la possibilité d'avoir les droits "SysAdmin" sur le SQL Serveur ? d'accord c'est un peu "cash", mais au moins temporairement ça permettrai de savoir si le soucis de détection SharePoint est un soucis d'accès SQL ou pas...


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    lundi 1 juillet 2013 12:40
  • le serveur m'appartient, je suis en administrateur, ce même compte est configuré pour SQL (je ne peux pas avoir plus de droits que le maximum) donc je ne pense pas que cela vienne de SQL, car en tentant une connexion SharePoint, VS2012 abandonne la tâche 
    lundi 1 juillet 2013 12:48
  • Hum...soit, (même si il est possible d'installer un serveur SQL sans en etre à terme l'administrateur) il est peu probable que ça vienne de là... même si c'est dommage de pas vérifier  !:)

    avez vous bien au moins une webapp qui tourne sur la machine, et avec un nom qui correspond au nom de la machine ? genre http://serverName:80/ 


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    lundi 1 juillet 2013 13:04
  • Que veux tu que je vérifie exactement? je pense qu'on s'est mal compris, je suis admin du serveur, de la base de donnée, que faut il que je regarde ?

    Sinon oui j'ai bien un site accessible par défaut sur le port 80 (même si ce n'est pas celui ci qui est utilisé)

    lundi 1 juillet 2013 13:15
  • au niveau SQL regarde le "server role" de ton user, es tu bien SysAdmin ?

    Tu dis que le site sur le port 80 n'est pas celui qui est utilisé, mais j'avais cru comprendre que VS te plante la création du projet avant même de te demander l'url du site sur lequel tu veux développer ?


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    lundi 1 juillet 2013 15:08
  • oui je suis bien Sysadmin.

    Oui, l'ouverture de projet SP2013 bloque dés le début, je voulais juste dire que dans mon SP, il existe bien une application par défaut (80) mais ce n’était pas celle ci qui étaient en "production".

    Il m'est toujours impossible de créer un SharePoint Connection ou créer u projet SP2013.

    mardi 2 juillet 2013 11:17
  • Salut

    je suis un peu à court d'idée là... y a t il un log de Visual studio ds le journal d'evènement du windows qui pourrai nous aider ?


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    mardi 2 juillet 2013 12:48
  • non malheureusement, j'ai recherché dans les journaux, les rapport de VS.. rien ...
    jeudi 4 juillet 2013 08:26
  • Salut Aurélien R.

    Je ne sais pas si ton problème est toujours d'actualité, mais j'ai eu le même souci. Après avoir essayé pas mal de trucs (réinstallation, configs des rôles, updates...) sans succès, la seule solution que j'ai trouvé et qui a marché était de virer VS 2012 et d'installer la version 2013 Preview qui arrive dans les bacs en ce moment.

    Depuis je crée mes projets SharePoint 2013 sans aucun problème.

    Le souci avec Microsoft parfois est qu'on a des erreurs qui ne sont pas logiques et pour lesquelles on n'a pas vraiment de pistes de solutions claires. "Aucun serveur Sharepoint n'est installé" alors que c'est bien sur mon serveur que je viens d'installer VS2012. C'était rageant.

    Voila pour ma "méthode", si ça peut aider.

    Bon courage à tous.

    jeudi 22 août 2013 08:30
  • Bonjour, 

    Ce n'est plus d'actualité, ayant fini ma période d'apprentissage, cela dit c'est une information intéressante, qui pourra surement servir plus tard. Donc à tester.

    Merci.

    jeudi 22 août 2013 08:36
  • Bonjour,

    Visual studio 2012 propose après une installation normale, la création de projet SharePoint 2010 seulement ! il faut installer "Office Dev Tools For VS 2012" pour pouvoir crée des projets SharePoint 2013.Sinon VS 2013 propose par défaut les projets SharePoint 2013
    j'ai eu aussi le même problème, ce n'est qu'après que j'ai découvert que les Template projet proposer par VS 2012 sont pour la version SharePoint 2010

    Merci.

    mercredi 18 décembre 2013 11:09