none
Flux de travail créer une nouvelle page .aspx dans une bibliothèque de document Sharepoint 2016 RRS feed

  • Question

  • Bonjour,

                 je tente actuellement de généré automatiquement une page web .aspx à partir d'un type de contenu dans une bibliothèque de document classique en utilisant un flux de travail. 

    J'ai déjà un flux de travail semblable qui démarre lors du dépôt d'un document dans une autre bibliothèque.

    Ce premier flux démarre suite au dépôt du document et génère dans une liste personnalisé un nouvel élément contenant certaines informations extraites du document que je viens de déposer dans ma bibliothèque. 

    Ce premier flux de travail s'exécute sans erreur et génère correctement mon nouvel élément dans la liste.

    Lorsque j'utilise le même type de flux de travail sur ma 2e bibliothèque de document j'obtiens une erreur inconnu lors de l'exécution. 

    <input class="s4-selectAllCbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="Sélectionner ou désélectionner tous les éléments" type="checkbox" />
    Date de survenance
    Type d'événement
    Présence activée pour cette colonneID de l'utilisateur
    Description
    Résultat
    <input aria-label="137" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 10:33 Erreur
    Aucune information de présenceCompte système
    Le flux de travail n’a pas pu créer l’élément de liste. Vérifiez que la liste existe et que l’utilisateur dispose des autorisations nécessaires pour ajouter des éléments à la liste. Erreur inconnue
    <input aria-label="138" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 10:33 Erreur
    Aucune information de présenceCompte système
    Une erreur s’est produite dans test.
    <input aria-label="139" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 10:33 Erreur
    Aucune information de présenceCompte système
    Pour plus d’informations, lisez cet article : http://go.microsoft.com/fwlink/?LinkID=323543&clcid=0x409

    Pourtant j'utilise la même configuration dans mon flux sur SharePoint Designer 2013. 

    Mon flux de travail est en version 2010, car selon ce que j'ai lu en version 2013 ça ne fonctionne plus. 

    Mon problème semble venir du paramètre «Chemin d'accès et nom».

    J'ai testé quelques configuration: 

    Si dans ce paramètre je tape bob.aspx, j'obtiens l'erreur ci-dessus. 

    Si je modifie la configuration pour mettre le nom de ma première bibliothèque comme source avec la colonne Nom.

    J'obtiens l'erreur ci-dessous.

    <input aria-label="141" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Le flux de travail n’a pas pu créer l’élément de liste. Vérifiez que la liste existe et que l’utilisateur dispose des autorisations nécessaires pour ajouter des éléments à la liste. Le flux de travail n’a pas pu créer l’élément de liste, car le nom du fichier manque ou n’est pas valide.
    <input aria-label="142" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Une erreur s’est produite dans test.
    <input aria-label="143" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Pour plus d’informations, lisez cet article : http://go.microsoft.com/fwlink/?LinkID=323543&clcid=0x409

    J'ai aussi remarqué que dans mon flux fonctionnel associé à une liste personnalisé au lieu d'une bibliothèque, le paramètre 

    «Chemin d'accès et nom» n'est pas requis et tout fonctionne sans erreur. 

    Je m' interroge  donc à savoir d'ou vient l'erreur, est-ce-que que doit entrer un chemin spécifique dans ce paramètre pour que ça fonctionne, ou est-ce-que les flux de création fonctionne correctement uniquement sur des listes personnalisés ? 

    Pour tant lorsque je recherche sur internet, je vois des exemples qui créer des document set dans des bibliothèque avec le même type de flux de travail. 

    J'ai aussi vu d'autre exemple de liste personnalisé qui via un flux de travail alimente une bibliothèque de document. 

    J'ai recréer c'est exemples, mais j'obtiens tout de même c'est erreur lorsque je test avec une bibliothèque. 

    Toutes idées est bienvenu !


    <input aria-label="141" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Le flux de travail n’a pas pu créer l’élément de liste. Vérifiez que la liste existe et que l’utilisateur dispose des autorisations nécessaires pour ajouter des éléments à la liste. Le flux de travail n’a pas pu créer l’élément de liste, car le nom du fichier manque ou n’est pas valide.
    <input aria-label="142" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Une erreur s’est produite dans test.
    <input aria-label="143" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Pour plus d’informations, lisez cet article : http://go.microsoft.com/fwlink/?LinkID=323543&clcid=0x409
    <input aria-label="141" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Le flux de travail n’a pas pu créer l’élément de liste. Vérifiez que la liste existe et que l’utilisateur dispose des autorisations nécessaires pour ajouter des éléments à la liste. Le flux de travail n’a pas pu créer l’élément de liste, car le nom du fichier manque ou n’est pas valide.
    <input aria-label="142" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Une erreur s’est produite dans test.
    <input aria-label="143" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 11:11 Erreur
    Aucune information de présenceCompte système
    Pour plus d’informations, lisez cet article : http://go.microsoft.com/fwlink/?LinkID=323543&clcid=0x409
    jeudi 18 juillet 2019 15:19

Toutes les réponses

  • Je continu mes tests concernant ce Flux de travail. 

    Dans le paramètre  Chemin et Nom, j'ai modifié la ligne pour ajouter des guillemets. 

    Exemple  "test"

    Maintenant j'ai une nouvelle erreur qui mentionne que quelques chose ne c'est pas déroulé correctement dans mon flux de travail.

    Historique des flux de travail
    Le flux de travail a enregistré les événements suivants.
    <input class="s4-selectAllCbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="Sélectionner ou désélectionner tous les éléments" type="checkbox" />
    Date de survenance
    Type d'événement
    Présence activée pour cette colonneID de l'utilisateur
    Description
    Résultat
    <input aria-label="226" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 13:59 Erreur
    Aucune information de présenceCompte système
    Une erreur s’est produite dans test.
    <input aria-label="227" class="s4-itm-cbx" style="font-family:inherit;font-size:inherit;vertical-align:middle;" title="checkbox" type="checkbox" /> 18/07/2019 13:59 Erreur
    Aucune information de présenceCompte système
    Pour plus d’informations, lisez cet article : http://go.microsoft.com/fwlink/?LinkID=323543&clcid=0x409

    jeudi 18 juillet 2019 18:16
  • J'ai fais une extraction du log sur mon serveur de développement en fusionnant tous les messages d'erreur.

    J'ai découvert que lorsque j'ajoutes des " " , j'obtiens une erreur de caractère non valide. 

    Ce qui explique le message précédent. 

    J'ai donc enlever les " " réexécuté le flux et extrait de nouveau le log du serveur. 

    J'ai maintenant l'erreur suivante: 

    « La valeur n'est pas comprise dans la plage attendue». 

    J'ai testé de supprimer ma bibliothèque et de la créer de nouveau, car avec ce message d'erreur j'ai vu sur un autre site que ça pouvait être causé par le nom de la bibliothèque qui comprend un espace. 

    J'ai donc recréé la bibliothèque avec un nom sans espace et ajouté de nouveau mon type de contenu. 

    J'obtiens la même erreur dans le log. 

    J'ai aussi testé d'ajouté mon type de contenu à la bibliothèque par défaut créé par SharePoint pour les pages internet. J'ai le même résultat.

    J'ai réussi une fois la semaine dernière a créer un flux fonctionnel avec ce type de contenu, mais je ne sais plus qu'elle différence j'ai mis dans l'ancien flux test qui a été supprimé depuis. 

    vendredi 19 juillet 2019 12:28