none
Compatibilité de mon application sur différents OS ?? Comment savoir ? RRS feed

  • Question

  • Bonjour,

    l'appli que je dois développer doit être compatible avec Windows xp, vista, seven and later (32 et 64 bits)...
    Personnelement, je développe sous visual C# express 2010 en utilisant le framework .NET...

    et sous seven 64 bits...

    comment savoir si mon appli sera compatible avec ces différents systems d'exploitation ???

    merci! !!


    dimanche 29 décembre 2013 09:45

Réponses

  • Bonjour,

    1/Respecter les "grands standards" préconisés par Microsoft qui existent depuis NT4/Windows 2000 (par exemple votre application ne doit pas fonctionner avec les droits administrateurs, ne doit pas lire ou modifier des fichiers dans le répertoire C:\Windows ou C:\Program Files,...etc la liste est très longue...).

    2/Vous voulez que votre application fonctionnent avec Windows XP alors vous devez utiliser au maximum le .NET Framework 4.0. La version 4.5 et 4.5.1 ne sont pas compatibles avec Windows XP.

    Pour ce qui est l'architecture 32 ou 64-bit cela ne posera aucun problème.

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance - P.O.S Informatique
    Blog : http://gilles.tourreau.fr - Suivez-moi sur Twitter
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCSA : SQL Server 2012
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0 / TFS 2010 / Windows Azure

    • Marqué comme réponse Aurel Bera lundi 6 janvier 2014 12:23
    dimanche 29 décembre 2013 14:59
    Modérateur