none
[SPF2010] Envoi de mail à une liste de distribution AD RRS feed

  • Question

  • Bonjour,

    Tout d'abord, je tiens à prévenir que je suis débutant sur SharePoint.

    Ceci étant dit, j'ai un problème sur lequel je cale : je n'arrive pas à envoyer des mails depuis SharePoint à des listes AD. Je m'explique, normalement tout est bien configuré au niveau de Exchange 2010 et de SharePoint Foundation 2010 au niveau des mails entrants et sortants, la preuve, je peux envoyer des mails depuis mon client Outlook 2010 à une bibliothèque SP, et je peux depuis une bibliothèque ou liste SP envoyer des alertes à un utilisateur.

    Je peux même envoyer des mails via un Workflow à un ou plusieurs utilisateurs. Par contre, ce que je n'arrive pas à faire, c'est envoyer un message à une liste AD du style "Liste service X" par exemple (liste de distribution dans l'AD qui contient les membres du service X).

    Je m'en suis rendu compte en voulant faire un workflow dont la dernière étape (une fois que toutes les validations internes ont été faites) envoit un message à une liste de distribution AD pour prévenir qu'un nouveau document est disponible. Mais, en fouillant, je me rend compte que même directement à partir du site, cela ne fonctionne pas : j'ai ajouté cette liste AD en tant que Visiteurs du site (dans Autorisation) et j'ai laissé coché les cases pour l'envoi d'un mail d'invitation ... et rien, pas de message envoyé. Par contre, quand je sélectionne cette liste et que je fait Action, Utilisateur de courrier électronique, cela fonctionne (mais d'après ce que je comprend, dans ce cas, c'est l'utilisateur actif qui envoie le message et pas le site en lui même).

    Si certains parmi vous ont des pistes pour m'aider, je les en remercie d'avance

    mercredi 4 avril 2012 16:22

Réponses

  • Re bonjour,

    Alors, suite à vos réponses et au différents liens, il me semble que j'ai trouvé la solution :

    Pour que cela fonctionne (dans mon cas mais à vérifier pour les autres):

    - peut importe le type de groupe, que ce soit un groupe de sécurité ou de distribution, peut importe du moment qu'il a une adresse mail (normal !),

    - pas besoin de le rajouter dans un groups SP. Encore que là, comme sur mon site le groupe Utilisateur du domaine à le droit de lecture, je suis pas sur, maid ce qui est sur c'est que dans ce cas, pas besoin d'ajouter le groupe nommément,

    - par contre, l'élément extrémement important etqui fait la différence (ça marche - ça marche pas) : il faut aller, à partir du serveur Exchange, dans les propriétés du groupe en question, dans l'onglet "Paramètes du flux de messagerie", aller dans les propriétés de Restrictions du flux de remise et décocher Exiger l'authentification de tous les expéditeurs. Et là miracle, les mails arrivent

    En tous les cas, merci à vous !

    jeudi 5 avril 2012 10:50
  • Bonjour,

    Il faut tout simplement que votre adresse email pour votre groupe de sécurité soit dans un groupe sharepoint...

    http://geekswithblogs.net/MOSSLover/archive/2008/03/24/but-my-ad-group-is-email-enabled-so-why-cant.aspx


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    • Marqué comme réponse Florin Ciuca mardi 10 avril 2012 16:37
    jeudi 5 avril 2012 08:34

Toutes les réponses

  • Bonjour,

    La dernière étape de votre workflow est-elle une activité "Envoyer un email" ou bien une autre activité ?

    Je me demande si votre liste de distribution n'est pas perçue comme un groupe de sécurité. Si c'est le cas, SharePoint pourrait tenter d'envoyer des emails à chaque utilisateur associé au groupe de sécurité plutôt qu'à la liste de distribution elle même.

    Pouvez-vous vérifier ce point et tester un workflow avec une seule activité "Envoyer un email" avec votre liste de distribution en unique destinataire ?


    Sébastien PICAMELOT - http://blogs.developpeur.org/gribouillon/

    mercredi 4 avril 2012 19:52
  • Bonjour,

    J'ai déjà répondu à cette question ici : http://social.technet.microsoft.com/Forums/fr-FR/sharepoint2010tnfr/thread/b482bcc5-14d1-473f-95d7-ec34be5f4f91


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    mercredi 4 avril 2012 21:32
  • Bonjour,

    Tout d'abord, merci pour vos réponses, mais malheureusement, cela ne fonctionne pas, ou bien je n'ai pas compris.

    Déjà, la dernière étape de mon workflow ne fait pas que ça, mais elle contient "Envoyer un mail" à cette fameuse liste, et ensuite d'autres actions qui elles se passent bien (et pour info, un autre Envoyer un mail à des personnes cette fois).

    Ensuite, cette liste est à l'origine un groupe de sécurité universelle qui a une adresse mail de définie. J'ai fait également des tests avec un groupe de distribution mais cela ne fonctionne pas non plus.

    Finalement Pascal, je dois avouer que je ne comprend pas bien votre procédure : d'après moi, j'ai bien un groupe de sécurité avec une adresse mail, contenant des utilisateurs ayant (évidement) eux même des adresses mails, donc, la 1ere partie de votre réponse me semble être en place. Par contre, c'est le PS qui me pose problème et que franchement, je ne comprend pas.

    "pour que cela fonctionne il faut également s'assurer que l'adresse email pour le groupe de sécurité dans l'AD soit importé dans SharePoint"

    Qu'entendez vous par là et que faut il faire exactement pour cela ?

    Merci d'avance

    jeudi 5 avril 2012 07:59
  • Bonjour,

    Il faut tout simplement que votre adresse email pour votre groupe de sécurité soit dans un groupe sharepoint...

    http://geekswithblogs.net/MOSSLover/archive/2008/03/24/but-my-ad-group-is-email-enabled-so-why-cant.aspx


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    • Marqué comme réponse Florin Ciuca mardi 10 avril 2012 16:37
    jeudi 5 avril 2012 08:34
  • Re bonjour,

    Alors, suite à vos réponses et au différents liens, il me semble que j'ai trouvé la solution :

    Pour que cela fonctionne (dans mon cas mais à vérifier pour les autres):

    - peut importe le type de groupe, que ce soit un groupe de sécurité ou de distribution, peut importe du moment qu'il a une adresse mail (normal !),

    - pas besoin de le rajouter dans un groups SP. Encore que là, comme sur mon site le groupe Utilisateur du domaine à le droit de lecture, je suis pas sur, maid ce qui est sur c'est que dans ce cas, pas besoin d'ajouter le groupe nommément,

    - par contre, l'élément extrémement important etqui fait la différence (ça marche - ça marche pas) : il faut aller, à partir du serveur Exchange, dans les propriétés du groupe en question, dans l'onglet "Paramètes du flux de messagerie", aller dans les propriétés de Restrictions du flux de remise et décocher Exiger l'authentification de tous les expéditeurs. Et là miracle, les mails arrivent

    En tous les cas, merci à vous !

    jeudi 5 avril 2012 10:50
  • Merci pour ce retour.

    Cordialement,

    Pierre


    Pierre Vivier-Merle - MVP SharePoint Server
    http://blogs.developpeur.org/pierre | http://www.vnext.fr
    Merci de valider les réponses qui correspondent à votre problème afin qu'ils apparaissent comme résolus.

    jeudi 5 avril 2012 12:09
    Modérateur
  • +1 :D

    Merci pour le retour également.


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    jeudi 5 avril 2012 15:00