none
impossible de faire fonctionner un webservice sur hébergement mutualisé alors qu'il fonctionne parfaitement en local RRS feed

  • Question

  • Bonjour,
    J'ai dévelpper un webservice ne C# ASP .NET , 3.5 . Il fonctionne parfaitement en local.
    Mais quand je publie le webservice , j'obtients biens la liste de mes methodes... mais quand j'attaque mon webservice  en POST ,
    j'ai l'erreur suivante :

    Erreur du serveur dans l'application '/MyWS'.

    Le format demandé n'est pas reconnu pour l'URL se terminant par '/CarrousselTout'.

    Description : Une exception non gérée s'est produite au moment de l'exécution de la demande Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur l'erreur et son origine dans le code.

    Détails de l'exception: System.InvalidOperationException: Le format demandé n'est pas reconnu pour l'URL se terminant par '/CarrousselTout'.

    Erreur source:

    Une exception non gérée s'est produite lors de l'exécution de la demande Web actuelle. Les informations relatives à l'origine et l'emplacement de l'exception peuvent être identifiées en utilisant la trace de la pile d'exception ci-dessous.

    Trace de la pile:

    [InvalidOperationException: Le format demandé n'est pas reconnu pour l'URL se terminant par '/CarrousselTout'.]
    System.Web.Services.Protocols.WebServiceHandlerFactory.CoreGetHandler(Type type, HttpContext context, HttpRequest request, HttpResponse response) +405961
    System.Web.Services.Protocols.WebServiceHandlerFactory.GetHandler(HttpContext context, String verb, String url, String filePath) +212
    System.Web.Script.Services.ScriptHandlerFactory.GetHandler(HttpContext context, String requestType, String url, String pathTranslated) +47
    System.Web.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +307
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155


    Informations sur la version :  Version Microsoft .NET Framework :2.0.50727.3074; Version ASP.NET :2.0.50727.3074



    Meme le HelloWord fournis en exemple ne marche pas !! .

    La génération du service me génère bien le /bin et j'ai bien le .dll dedans .. je vous dis, ça marche en local .

    Quelle est la méthode ?

    Je suis hébergé chez ikoula .. Hébergement MSDN , IIS7, Framework 3.5 ..

    Voici le lien test :http://www.lesaumondenorvege.com/Service1.asmx

    Merci d'avance ..

    Bruno
    samedi 20 juin 2009 13:55

Réponses