none
IIS syntaxe SQL Server CE 4.0 RRS feed

  • Question

  • Bonjour à tous,
    Je cherche à déployer mon application ASP.NET MVC3 Razor sur un serveur IIS 7.
    J’ai réussi mon déploiement, mais comme je veux accéder à une page qui interroge ma base de données, j’ai le message d’erreur dans mon navigateur :

    Le format de la chaîne d'initialisation n'est pas conforme à la spécification qui débute à l'index 0.

    Ma question est la suivante :
    Est-ce quelqu’un connait la syntaxe spécifique attendu par un serveur IIS, pour une connexion string avec Sql Server CE 4.0 ?
    Merci d’avance pour vos réponses.
    Cordialement

    jeudi 22 mars 2012 08:20

Réponses

Toutes les réponses

  • Pour connaitre la syntaxe de toutes les ConnectionString, un site sympa : 

    http://connectionstrings.com/


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    jeudi 22 mars 2012 08:29
  • Bonjour,

    Oui , je connais ce site (c’est une bonne référence d’ailleurs). Mais apparemment IIS attend une autre syntaxe.  Car j’ai essayé la connexion suivante, (une connexion vraiment classique  et simple) :

    “data source=C:\inetpub\wwwroot\Mvc3Application2_deploy\App_Data\Northwind.sdf”

    Et j’ai toujours un message d’erreur.

    «Détails de l'exception: System.ArgumentException: Mot clé non pris en charge : 'data source'. »

     

    Autre tentative, j’ai essayé avec un projet qui utilise une base de données SQL server express.  J’importe mon package et j’installe sur mon serveur IIS 7.

     La connexion de base crée par Visual studio web et que je retrouve dans le menu de chaine de connexion de mon site est la suivante :

    {% token='$(ReplacableToken_#(parameter)_#(tokennumber))' xpathlocator='name' parameter='MyDataEntities-Web.config Connection String' description='MyDataEntities Chaîne de connexion utilisée dans web.config par l'application pour accéder à la base de données.' defaultValue='metadata=res://*/Models.Model1.csdl|res://*/Models.Model1.ssdl|res://*/Models.Model1.msl;provider=System.Data.SqlClient;provider connection string="data source=.\SQLEXPRESS;attachdbfilename=|DataDirectory|\MyData.mdf;integrated security=True;connect timeout=30;user instance=True;multipleactiveresultsets=True;App=EntityFramework"' tags='SqlConnectionString' %}

    Je teste et  je retrouve la même erreur, vue dans mon poste précédent.

    Étrange ???


    • Modifié jackbreak vendredi 23 mars 2012 08:11
    vendredi 23 mars 2012 08:10
  • Humm, c'est pas un pb de ConnectionString, c'est un problème de syntaxe avec Entity Framework :P (j'aime pâs Entity Framework et ta question me conforte ;-))).

    Désolé, là je ne saurais pas répondre.


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    vendredi 23 mars 2012 08:26
  •  

    Bonjour, Jackbreak,

    Pour l’erreur avec Sql Server CE 4.0 il semble que votre erreur vient en fait de votre chaine de connexion (voir aussi cet article, cette question et cette discussion). Dans cette discussion, vous avez aussi une explication un peu détalée : l’index 0 signifie que le début de votre chaine de connexion est incorrect ou incomplet.

    Pour l’erreur avec le serveur SQL Express, il semble qu’il y a de nouveau un problème avec la chaine de connexion. Plus précis, je ne vois pas la définition de providerName dans votre exemple (voir aussi cette discussion et ce thread). En plus, les infos que vous nous avez données ne viennent pas du fichier web.config. Comment gérez-vous la modification lors du déploiement ? Si vous déployez sur un serveur, parfois il faut modifier les chaines de connexion et le plus simple est le faire via le fichier de configuration. Finalement, dans cette discussion, je vois que l’erreur « Mot clé non pris en charge : 'data source' » peut être aussi liée a la version d’EF utilisez et n’apparaisse pas en EF 4.1. Quelle version d’Entity Framework utilisez-vous ?

    Bonne journée,

    Cipri


    Suivez MSDN sur Twitter   Suivez MSDN sur Facebook


    Ciprian DUDUIALA, MSFT  
    •Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    lundi 26 mars 2012 06:58