none
webpart requête de contenu RRS feed

  • Question

  • Bonjour,

    J'utilise le webpart requête de contenu pour afficher les données d'une liste de liens sur un autre site.

    Le problème est le suivant : dans les champs à afficher, je dois afficher une colonne qui appartient au groupe de colonne de site "colonnes de base". Donc je saisi "URL [colonnes de base]" dans la zone titre. Sauf que le message suivant s'affiche : Le groupe de colonnes de site ou de liste « Colonnes de base » n’existe pas.

    Je pense à un problème de traduction de nom de groupe de colonne. Quelqu'un a-t-il eu ce problème ? Comment lui faire identifier le groupe de colonne de site ?

    mercredi 23 mai 2012 09:04

Réponses

  • Oups ok désolé pour la confusion ;-)

    Le soucis quand on utilise des colonnes de bases c'est qu'il est parfois difficile de les utiliser par après. Si on prend la colonne URL comme dans votre exemple, elle utilisée à différents endroits ce qui porte à confusion. Pour éviter ce genre de chose je vous invite vivement à utiliser les Best Practice qui consiste à créer un type de contenu spécifique pour votre liste de liens (ou créer juste une colonne si vous ne voulez pas jouer avec les types de contenu).

    Dans ce type de contenu vous créer une colonne qui porte par exemple le nom URLCUSTOMLINK et vous renseigner ensuite ce nom dans votre webpart de requête de contenu, comme cela tout est bien "isolé". Prenez bien soin de ne pas mettre d'espace et/ou de caractère spéciaux lorsque vous créer votre colonne sinon le nom interne sera altérer par %20 à la place d'un espace par ex. Une fois votre colonne créer, libre à vous de la renommer comme bon vous semble avec espaces, majuscules, caractère spéciaux car le nom interne aura déjà été défini (il est inaltérable).

    Bon courage ;-)


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    vendredi 25 mai 2012 10:05
    Modérateur

Toutes les réponses

  • Bonjour,

    Je ne comprend pas pourquoi vous saisissez l'url dans la zone "Titre". Lorsque vous configurer le webpart vous lui dites où il doit chercher l'information (dans le site, dans la liste, etc...) ensuite vous renseigner le nom interne de la colonne (qui est souvent différent du nom de la colonne, pas d'espace, pas d'accents,etc...)


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    mercredi 23 mai 2012 09:25
    Modérateur
  • Je ne saisi par l'url, mais "URL" qui est le nom de la colonne de site (appartenant au groupe "colonnes de base") que je souhaite récupérer dans le webpart.

    mercredi 23 mai 2012 19:14
  • Oups ok désolé pour la confusion ;-)

    Le soucis quand on utilise des colonnes de bases c'est qu'il est parfois difficile de les utiliser par après. Si on prend la colonne URL comme dans votre exemple, elle utilisée à différents endroits ce qui porte à confusion. Pour éviter ce genre de chose je vous invite vivement à utiliser les Best Practice qui consiste à créer un type de contenu spécifique pour votre liste de liens (ou créer juste une colonne si vous ne voulez pas jouer avec les types de contenu).

    Dans ce type de contenu vous créer une colonne qui porte par exemple le nom URLCUSTOMLINK et vous renseigner ensuite ce nom dans votre webpart de requête de contenu, comme cela tout est bien "isolé". Prenez bien soin de ne pas mettre d'espace et/ou de caractère spéciaux lorsque vous créer votre colonne sinon le nom interne sera altérer par %20 à la place d'un espace par ex. Une fois votre colonne créer, libre à vous de la renommer comme bon vous semble avec espaces, majuscules, caractère spéciaux car le nom interne aura déjà été défini (il est inaltérable).

    Bon courage ;-)


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    vendredi 25 mai 2012 10:05
    Modérateur