none
Expression Web Adds Folders

    Question

  • When I create a new website page ".htm" file, Expression Web creates a new folder with the same name, but appended with _files, for example: "{folder}_files".  I see these files on the server, but sometimes they show up on the local computer in EW4, but not always.  The {folder}_ files folders appear an disappear randomly.  Have I changed a setting that causes this?  I've never read anywhere why EW4 creates these folders, so some background explanation would be greatly appreciated.
    Friday, March 24, 2017 8:09 PM

All replies

  • Please describe exactly what you are doing.  Are you editing your local site on your PC (as you should be doing ) or trying to edit on the server?  Are you using FTP (which transfers files down to your PC to edit and doesn't actually edit live)?  Or are you using the old FrontPage Server Extensions (which edits live, but which have been deprecated for a many years)? And what version of Expression Web are you using?

    The only thing I know of that creates name_files folders is Word, when you save a document as HMTL, where it will put the images in the document in that folder.  (Since Word creates atrocious HTML, I hope you are not doing that.)


    Kathleen Wilber
    BrightWillow - Asp.Net Applications

    Saturday, March 25, 2017 5:56 PM
  • I always edit local site on my PC.  After editing any file I publish changed files with EW4 (Expression Web 4).  I stopped using FrontPage Server Extensions a long time ago, but they were used by the original creator of the website in 2009 who was using FrontPage. I have removed all FrontPage Wizard generated items from the website.  I used FrontPage until early 2015.  I have been using EW4 for almost 2 years.

    In the last 3 months I have been using Code View and making templates and slowly changing some pages by coding with HTML5 and CSS3.  I will continue using EW4 Design View to maintain the DWT (menu) and Home Page until I have re-created them in HTML5 and CSS3. Since I started learning more about HTML and CSS I have been able to fix errors in EW4, which has improved website performance.  I have never used Word files in the Website and found it worked much easier to open word files with notepad to strip formatting and then paste the plain text into EW4 and now I use HTML and CSS to format content.

    I kept searching for answers on this forum and discovered Thickets.  It appears that EW4 is creating Thickets and in later versions starting with EW3 Thickets may appear, but were originally hidden files.  Here is a website I found in this forum:

    See the 3rd post in this thread: {FORUM BLOCKS LINKS UNTIL ACCOUNT VERIFIED - I GUESS 3 YEARS ISN'T ENOUGH TIME?}

    And see this link:  {SAME MESSAGE HERE}

    I haven't found an explanation of what EW4 is doing with Thicket files, but at least I now have some idea how to clean up the code and still use EW4 for it's other meta file and IntelliSence capabilities, FTP, and Reports.

    Saturday, March 25, 2017 9:01 PM
  • remove spaces to see thread:

    https:/   /social.msdn.microsoft.com/Forums/expression/en-US/2e34aff0-34d0-4975-a0b1-9a54c46d1ae4/thicket?forum=web

    same thing:  remove spaces to see this link:

      http:/   /www.rxs-enterprises.org/fp/articles/thickets.aspx

    Saturday, March 25, 2017 9:32 PM
  • As I said, and as that thread says, it's not something EW creates, but something created by making an HTML page from Word (or other Office program).

    "A folder with a name similar to pagename_files is a thicket folder.  Thickets are created when content is created in Word, Excel, PowerPoint or Publisher and saved as HTML from those applications, or when VML graphics are used." "They are always invisible in Frontpage and Expression Web."

    You may not have made the pages from Word, but if you are copying pages that the original creator made from Word, perhaps that explains it.


    Kathleen Wilber
    BrightWillow - Asp.Net Applications

    Saturday, March 25, 2017 10:17 PM
  • It would be more likely that something in FrontPage was responsible, but there is no evidence to verify what happened.  I will contact the originator of the website and see if he can recall if any files from other apps were imported.

    OK, so given the current situation, here's what I did next.  I deleted all {filename}_files folders on the server in Site|Publishing view.  These folders all contained the following files:

    filelist.xml

    image001.gif

    Thumbs.db

    Their status was "Unmatched", indicating that they did not  exist on the  local machine.  It appears to me that Site|Publishing is showing all files (including hidden files). 

    Next I did  Tools|Recalculate Hyperlinks.  In the Site|Publishing view all the {filename}_ files folders reappeared on both the local machine and the server.  So, If EW4 is not creating these files, where are they coming from?  When I go back to folder view in EW4, none of the {filename}_ files folders appear, indicating that they are hidden files.  The whole purpose of "Publishing" is to include hidden files when FTP updates the server.

    When I look at what's in the {filename}_ files folders in Site|Publishing their status is "Unmatched" and the date and time is 3/25/2017 3:26 PM, which is exactly when I used Tools|Recalculate Hyperlinks. This process does more than just recalculate hyperlinks.

    When trying to delete {filename}_ files folders in EW4 Folder View (not in Site|Publishing), the same error message appears that Thicket files produce, but it may be that {filename}_ files folders are not Thicket files, but part of EW4's metadata or something else?

    Sunday, March 26, 2017 3:23 PM
  • Again, those did not originate from EW.  What they contained is exactly what they would have contained if the original html page was made in Word.  But if EW knows they existed, simply deleting them wouldn't erase that knowledge. Try deleting them again, and going to Site->Site Settings and unchecking Metadata. EW will delete its metadata for the site.  Then reverse the process: recheck Metadata and let EW regenerate it.

    If that doesn't solve the problem, try FPCleaner (google it, and select the one for EW4).  It can do a more thorough cleaning of old data.

    Adding more:  You could also try a work-around. Identify the page (or pages) where this is happening and assume that page was created in Word at one point.  Create a new page with a different name.  Copy all the current HTML from the problematic page into the new page.  Save it.  Delete the old page.  Try renaming the new page to the original page name, and see if the relationship with the thicket files was removed when you deleted the original one.  If simply regenerating the meta data doesn't help, perhaps this would.


    Kathleen Wilber
    BrightWillow - Asp.Net Applications


    • Edited by KathyW2 Monday, March 27, 2017 4:26 AM
    Sunday, March 26, 2017 6:25 PM