none
Get error using Microsoft Access as the database in my web site. RRS feed

  • Question

  • My service provider moved my web site to a new server and now I get this error "The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine".  I get the error when is click on the Honor Scores tab in GFUSBCA.org web site.  I have posted this before and still not gotten an answer that works.  It is very frustrating.  My web site is for a local bowling association.  I use Microsoft Access as the database to store honor scores.  The web site allows the user to search for honor scores by name, league, bowling center, and season.  The association does not have money to pay a professional to fix it.  The service provider will not fix it and they are not allowed try.  Please someone help me.  Try it and see what you get then see if you can help me.  Thanks and have a very blessed day. 

    D.J. Johnson Web Master (I am not a professional just a retired programmer that has been working with Microsoft Access for 14 years and with Expressions Web 4 for at least 6 years.


    D.J. Johnson

    Thursday, July 6, 2017 12:17 PM

Answers

  • "My service provider moved my web site to a new server and now I get this error "The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine".

    That is a hosting issue, as I said in your first post on this issue, once it became clear you were talking about your live site and not previewing your local site.

    There is nothing we can tell you that will fix it.  Your host needs to fix it.  If they won't or can't, you need a new host.  Make sure any new host explicitly says it will support Access databases of the version you are using.


    Kathleen Wilber
    BrightWillow - Asp.Net Applications

    • Marked as answer by D.J. Johnson Thursday, July 6, 2017 10:31 PM
    Thursday, July 6, 2017 5:31 PM
  • Do not worry if you have paid in advance for your hosting contract. Since they took unilateral action that has disabled your Web site, you are perfectly within your rights to ask them for a refund of your unused balance so that you can move to another host. Before you do so, of course, do your research and find a host who, as Kathy advised, can guarantee that they can host your version of Access database. That way you will be ready to make the move if it comes to that.

    However, I would wager that if you call their sales line (not tech support) and tell them you want to move and need a refund, and explain why, they will put a burr under tech support's saddle, and they will "discover" that, "oh, yeah, we can support that after all."

    They don't like losing customers; it's too competitive and too hard to get them in the first place in that business. They're not going to want to see one walk over something as stupid and as easily remediable as this. Give it a shot...  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Marked as answer by D.J. Johnson Thursday, July 6, 2017 10:32 PM
    Thursday, July 6, 2017 7:17 PM

All replies

  • It might be a simple setting at your host.  Ask them to make sure 32 bit applications are enabled in the Application Pool. 

    ClarkNK AKA HomePage Doctor
    Database Tutorials Using ASP.NET Controls
    My recommended web hosting company: RDOServers

    Thursday, July 6, 2017 12:48 PM
  • "My service provider moved my web site to a new server and now I get this error "The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine".

    That is a hosting issue, as I said in your first post on this issue, once it became clear you were talking about your live site and not previewing your local site.

    There is nothing we can tell you that will fix it.  Your host needs to fix it.  If they won't or can't, you need a new host.  Make sure any new host explicitly says it will support Access databases of the version you are using.


    Kathleen Wilber
    BrightWillow - Asp.Net Applications

    • Marked as answer by D.J. Johnson Thursday, July 6, 2017 10:31 PM
    Thursday, July 6, 2017 5:31 PM
  • Do not worry if you have paid in advance for your hosting contract. Since they took unilateral action that has disabled your Web site, you are perfectly within your rights to ask them for a refund of your unused balance so that you can move to another host. Before you do so, of course, do your research and find a host who, as Kathy advised, can guarantee that they can host your version of Access database. That way you will be ready to make the move if it comes to that.

    However, I would wager that if you call their sales line (not tech support) and tell them you want to move and need a refund, and explain why, they will put a burr under tech support's saddle, and they will "discover" that, "oh, yeah, we can support that after all."

    They don't like losing customers; it's too competitive and too hard to get them in the first place in that business. They're not going to want to see one walk over something as stupid and as easily remediable as this. Give it a shot...  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Marked as answer by D.J. Johnson Thursday, July 6, 2017 10:32 PM
    Thursday, July 6, 2017 7:17 PM
  • While clean up some files on my computer I deleted something that gave me the same error on my office PC.  I googled the error (Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine) and was recommended that I reinstall AccessDatabaseEngine.exe.  Which I did and now the website works on my machine.  I contacted the website provider and told them what I had done.  They indicated that the problem was probably in the web.config file.  This is the config file that I am using on my office PC and that was uploaded to the website provider:

    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>
      </configSections>
      <appSettings/>
      <connectionStrings>
        <add name="GFUSBC_Bowling_DataConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString2" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString3" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString4" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString5" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString6" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString7" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
        <add name="GFUSBC_Bowling_DataConnectionString8" connectionString="Provider=Microsoft.Jet.OLEDB.12.0;Data Source=&quot;C:\Web Sites\GFUSBCA\data\GFUSBC_Bowling_Data.mdb&quot;"
          providerName="System.Data.OleDb" />
      </connectionStrings>
      <system.web>
        <!--
                Set compilation debug="true" to insert debugging
                symbols into the compiled page. Because this
                affects performance, set this value to true only
                during development.
            -->
        <compilation debug="false">
          <assemblies>
            <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
        </compilation>
        <!--
                The <authentication> section enables configuration
                of the security authentication mode used by
                ASP.NET to identify an incoming user.
            -->
        <authentication mode="Windows" />
        <!--
                The <customErrors> section enables configuration
                of what to do if/when an unhandled error occurs
                during the execution of a request. Specifically,
                it enables developers to configure html error pages
                to be displayed in place of a error stack trace.
         -->
            <customErrors mode="Off" defaultRedirect="GenericErrorPage.htm">
                <error statusCode="403" redirect="NoAccess.htm" />
                <error statusCode="404" redirect="FileNotFound.htm" />
            </customErrors>

        <pages>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          </controls>
        </pages>
        <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
        </httpHandlers>
        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </httpModules>
      </system.web>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4"
                    type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <providerOption name="CompilerVersion" value="v3.5"/>
            <providerOption name="WarnAsError" value="false"/>
          </compiler>
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4"
                    type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <providerOption name="CompilerVersion" value="v3.5"/>
            <providerOption name="OptionInfer" value="true"/>
            <providerOption name="WarnAsError" value="false"/>
          </compiler>
        </compilers>
      </system.codedom>
      <!--
            The system.webServer section is required for running ASP.NET AJAX under Internet
            Information Services 7.0.  It is not necessary for previous version of IIS.
        -->
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
        <modules>
          <remove name="ScriptModule" />
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </modules>
        <handlers>
          <remove name="WebServiceHandlerFactory-Integrated"/>
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode"
               type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode"
               type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </handlers>
      </system.webServer>

      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>

    Thank you for your attention to this matter and have a blessed day.


    D.J. Johnson

    Sunday, July 23, 2017 1:32 PM
  • Did you ever ensure that 32 bit applications are enabled in the Application Pool?

    ClarkNK AKA HomePage Doctor
    Database Tutorials Using ASP.NET Controls
    My recommended web hosting company: RDOServers

    Sunday, July 23, 2017 2:06 PM
  • No, your host is wrong. They moved you to a new server. If you didn't, at the same time, change your web.config, it's obvious that the move, not your web.config, caused the problem and that it's the setup on the new server that is the problem.  I will point out that you have repeated identical connection strings with different names. Why? Why not use the same connection string, since it is identical? But, again, that won't cause the error you get.

    Kathleen Wilber
    BrightWillow - Asp.Net Applications

    Monday, July 24, 2017 5:44 AM
  • I have changed my web.config file to use version 4 and it works except when I select an item from list of items in the database then I get an error.  If the page just queries the database I get the results.  I have moved my web site to GoDaddy and when I try upload all of the files the are suppose to go to a folder /httpdocs, but the transfer setup page will not allow me to put that address in.  The tech at GoDaddy is not familiar with Expressions Web 4.  He stated that file must reside in the /httpdocs folder to the site to see them and use them.  Any suggestions would be greatly appreciated.  Thanks for all of the help you have provided.  Have a blessed day.

    D.J. Johnson

    Friday, August 11, 2017 3:54 PM
  • "the transfer setup page will not allow me to put that address in"

    Describe your error/problem using terms that map to Expression Web and its menus.  (What is it that you are calling the "transfer setup page"?)

    Also, this really should have been a new post.  You are adding it to a thread about a different topic that has already been marked answered.


    Kathleen Wilber
    BrightWillow - Asp.Net Applications


    • Edited by KathyW2 Friday, August 11, 2017 4:23 PM
    Friday, August 11, 2017 4:05 PM