none
Problem with symbols in Expression Web 2 RRS feed

  • Question

  • After using FrontPage 2003 for several years, I downloaded my web site into Expression Web. Recently, I upgraded to the trial version of Expresson Web 2.

    The download had problems with symbols -- generally with the copyright symbol (small c in a circle). It rendered this as an empty square box coded as<span class="style1">&#65533;</span>

    Style1 is defined as {font-family: "Times New Roman";}

    When I changed the box to a copyright symbol using the Symbols option on the Insert pull down menu, it looked OK. The coding display within Expression Web shows the symbol as as <span class="style1">©</span>

    So far, so good.

    But when Expressions Web stores the essay, the coding changes to
    <span class="style1">�</span> 

    After uploading to our website, the text reads something like: Copyright � 1999 to

    It looks the same in Mozilla Firefox and Internet Explorer browsers.
    How do I get Expressions Web to display a symbol properly?

    Saturday, July 12, 2008 1:15 PM

All replies

  • It looks like a page encoding issue of some sort.

    To get around the issue in the short term change the copyright symbol to '&copy;'

    HTH

    Ian

    http://www.ew-resource.co.uk
    Ian Haynes
    • Edited by Ian Haynes Saturday, July 12, 2008 2:04 PM spelling correction
    Saturday, July 12, 2008 2:04 PM
  • Avoid to edit or save more of your pages until you know the source of this problem. Chances are that saving your pages irretrievably destroys the symbols.

    If you have saved a page and now see the � sequence, a character was not decoded properly when xWeb opened the page, so it was replaced with U+FFFD REPLACEMENT CHARACTER. You have to restore the original character manually.

    Pages that lack a meta encoding declaration are decoded as UTF-8 by default in xWeb. If you have pages that lack a meta encoding declaration and are not UTF-8 encoded, xWeb cannot decode the page properly, and all non-ASCII characters are replaced by U+FFFD. The change this behavior, go to Site > Site Settings... > Language > Default page encoding and choose US/Western European (Windows) instead of Unicode (UTF-8). Then open the page again. If the symbol characters are still broken, go to File > Properties... > Language > Reload the current document as and select US/Western European (Windows).

    In both cases, now go to File > Properties... > Language > Save the document as and choose an encoding (I recommend UTF-8). This will create a meta declaration which xWeb will use the next time you open the page.

    Again, only save a page when all characters look correct.
    Saturday, July 12, 2008 3:40 PM