none
unable to open design project in MS blend for VS 2015...

    Question

  • hello,

    I just installed VS 2015 and blend for VS 2015. but I have a problem in opening universal app project in MS blend for VS 2015.

    when I open the universal app for Visual C++ in MS blend, it pops up error message:

    "System.NullReferenceException...blah blah blah".

    this situation happened only in opening project from VC++ template for universal windows app. nothing happened in opening others.

    I need your help to fix this problem.

    thanks for your answer in advance.

    Tuesday, August 11, 2015 2:32 AM

Answers

  • I solved this problem. 

    I should enable "developer mode". blend opens normally after doing that.

    cheers,

    c00012

    • Marked as answer by ohseihyung Sunday, November 12, 2017 5:32 PM
    Sunday, November 12, 2017 5:32 PM

All replies

  • Not that it helps you out, I did give this a try and the Blend opened as expected, the UWP C++ App fine.

    If you are not able to open the C++ Project in Blend, then you may need to go to the control panel and select change for the Visual Studio, and Fix the installation.  Make sure to pay attention to the components of C++ being installed.

    On the other hand, if you are opening an existing view from inside of Visual Studio 2015.  This opens Blend, but apparently not the required resources.  In my previous issues it was resolved by Saving and closing Visual Studio 2015 IDE and then open Blend, then from inside Blend open the solution that you have an issue with.  This will load the resources and may solve the problem.

    If either of these solves your Blend issue, please mark this as answered!  Thank you!

    P.S.: As for the "blah, blah, blah" part of the problem, it sounds like you may have an ex-CEO trapped in your computer, and the way to fix this is to sell him a basketball team.  He will then have more fun with the basketball team.


    Sam Stokes

    Tuesday, August 11, 2015 3:31 AM
  • Dear Sam,

    first of all, I'd like to say thank you for your suggestion. it didn't work though.

    first, I tried to open the erroneous project on VS 2015 first and then tried it on blend.  

    it has same error message: "System.NullReferenceException...."

    again, thanks for your answer.

    If I resolve the problem, I will let you know.

    seihyung

    Wednesday, September 9, 2015 11:02 PM
  • Dear Sam, 

    I have same error with seihyung. 

    I create javascript project - Universal App, but i can't open this in Blend or I can't see "Open in blend" when i right click on project menu. 

    Thanks you

    Friday, September 11, 2015 2:55 AM
  • I solved this problem. 

    I should enable "developer mode". blend opens normally after doing that.

    cheers,

    c00012

    • Marked as answer by ohseihyung Sunday, November 12, 2017 5:32 PM
    Sunday, November 12, 2017 5:32 PM