none
Expression Web 3 to Expression Web 4 and now cannot find the option to insert the Check Browser and Check Add-In behavior RRS feed

  • Question

  • I have done an expensive web search and found nothing, I recently upgraded from Expression Web 3 to Expression Web 4 and now cannot find the option to insert the Check Browser and Check Add-In behavior from the insert dropdown on the Behaviors Panel. Was this dicontinued?
    Wednesday, July 21, 2010 5:11 AM

Answers

  • Kathy,

     

    I did try using the "Behavior Insert" from editing inside the <body> in EW4 and it was not working earlier. However, now I went back to replicate and now it is working. I can't replicate the situation I had before. I don't have time to spend on it because as you said "never use so don't miss \"Check browser\"".

    Wednesday, July 21, 2010 5:33 PM

All replies

  • Just checked. I can't get the Behaviors->Insert feature to work in EW4 either. In EW3, if you highlight the body tag or place the insertion cursor in the head tag, the Insert tab lights up. In EW4 I can not find any way to get the Insert tab in the Behaviors Panel to light up.

    Maybe the authors are trying to save us from those bits of elderly Front Page javascript that it wants to insert for "Check Browser" and the other Insert options? If so, it's a good move.

    I recommend you look into using jQuery for your browser detection.

    As far as EW 4 goes, my copy is not working like the documentation says it should in this regard.

    Wednesday, July 21, 2010 10:31 AM
  • "In EW4 I can not find any way to get the Insert tab in the Behaviors Panel to light up."

    Behavior's Insert is live if you are inside the <body>, not <head>.  If you've clicked in Code View in <head>, it doesn't seem to recognize when you then click inside the <body>.  Click in Design View.  After that, it does recognize going back and forth between them in Code View.  That does seem to be a small bug - but it happens in EW3, too.

    Now, I do not see (and never use so don't miss) "Check browser" or "Check Plug-in" among the choices in EW4, and they are there in EW3.

    Wednesday, July 21, 2010 3:53 PM
  • Kathy,

     

    I did try using the "Behavior Insert" from editing inside the <body> in EW4 and it was not working earlier. However, now I went back to replicate and now it is working. I can't replicate the situation I had before. I don't have time to spend on it because as you said "never use so don't miss \"Check browser\"".

    Wednesday, July 21, 2010 5:33 PM
  • I have done an expensive web search

    "Expensive"?  How much did it cost?  ;-))

    Andrew M


    http://www.murraywebs.com

    "Nothing spoils numbers faster than a lot of arithmetic"


    -- Peppermint Patty (Peanuts, Charles M. Schulz)
    Wednesday, July 21, 2010 10:03 PM
  • I have just noticed the same problem. I want to add a simple mouse-over image swap in a new web site.

    1. I select menu > format > Behaviors, and the Behaviors pane appears on the right. So far, so good.

    2. I select the image I want to swap, but the *Insert* and *Delete* buttons are greyed out, so I cannot add a behavior.

    3. I closed this web site, and opened one where I had previously set up mouse-overs. The web still works with mouse-overs, but when I select an image on which a mouse-over behavior already exists, the Behaviors buttons are both greyed out. So I cannot add further behaviors to existing images, nor to new images in this web site, when previously I could!

    Can anyone tell me what's happened?

    HELP!!!

    Tuesday, June 28, 2011 8:44 AM
  • Post a link to the page.

    Tuesday, June 28, 2011 2:19 PM