Strange problem with Expression Web 2 RRS feed

  • Question

  • I have a strange problem that prevents Expression Web 2 from running. On all web pages, when I try to display in the Browser (both IE and Firefox), I get the following three messages:

     “The directory ‘E:”/vpath:/” does not exist’.

    There is nothing in my system that resembles E:”/vpath:/”

     Then the next message is;

    “This page may contain dynamic content that requires a web server in order to be previewed correctly”

    And the last message is:

    The XML page cannot be displayed

    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

    A name was started with an invalid character. Error processing resource 'file:///E:/Brigade Discountasp/default.aspx'. Lin...

    <%@ Page masterpagefile="Brigade.master" language="C#" title="Brigade" %>


    I have been in web development using Expression Web 2 for 8-10 hours a day for the past seven months with no problems. I cannot do any web development. I have reinstalled Expression 2 with no solution. Both Design and code view work fine it is only when I try to view in the Browser

    Can anyone point me toward a solution to this problem?

    Monday, May 3, 2010 4:14 PM

All replies

  • with the site open go to Site > Site settings > Preview tab.
    Make sure EW is set to preview the site using the development server.

    Expression Web MVP
    Monday, May 3, 2010 4:45 PM
  • As Steve alluded to, that is exactly the error you will get trying to preview a child page created from a master page when you are asking the browser to parse it directly rather than letting a server handle the content and feed the resulting html to the browser.

    Check your site preview settings and hand the page to the development server first.

    But, your error about vpath raises questions.  Does that refer to the virtual directory name for your application's root directory?  Is this running on a local IIS server?

    Monday, May 3, 2010 8:12 PM