none
Expression web 4 publishing problems

    Question

  • I am trying to publish my website, and not seeing the edits.

    My ftp and directory are correct.

    I am working in Windows 10.

    Any suggestions?

    Thursday, May 4, 2017 9:57 PM

All replies

  • Not enough information. Are you actually connecting? When you click "Site View|Publishing|Connect to current publishing destination," do you see your local Web folder on the left and your remote site (on the server) on the right? If so, have you tested by editing index.html and then simply dragging it from the left side to the right side (which publishes it)?

    If so, and you still can't see your change, then you have the wrong value in the "Directory" entry of your Connection Settings (see below, where it says "httpdocs/sandbox").

    For many Apache/nginx servers that directory will be "public_html." For many Windows servers it will be "wwwroot." However, each provider may make that target folder whatever they wish it to be (as above, where Lunarpages prefers "httpdocs"). If you are actually publishing, but not seeing your edits online, then you need to call your provider's tech support and ask them the name of the folder that you should publish to. Having the right FTP address gets you to the server, but not having the correct directory will not allow you to publish properly.

    If, as you say, you're sure that you have the correct directory, and you have tried the drag and drop publishing method, and you still cannot see your edits, then you need to provide more information—for example, exactly what steps you are taking to publish, in order, and what you see as a result of each operation.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Edited by paladyn Friday, May 5, 2017 3:17 AM
    Friday, May 5, 2017 3:09 AM
  • Yes, I am connecting.

    My ISP is GoDaddy and they inform me that my Directory is to be left blank.

    My FTP address has been confirmed.

    I have worked with Microsoft Web Expression since 2009, without problem.

    I am right clicking on the html file I desire to publish, but still not seeing the changes on the website.

    Thank you for your help.

    Friday, May 5, 2017 4:18 PM
  • I have worked with Microsoft Web Expression since 2009, without problem.

    I am right clicking on the html file I desire to publish, but still not seeing the changes on the website.

    ???

    What? Right-clicking where? Site View|Folders file list? The left pane of the Publishing pane? Right-click brings up a context menu. What do you select from that context menu? "Publish selected files to..." will publish the file you right-click. Is that what you did? If you then open that file on your remote site, do you not see your edits?

    Getting the information needed to help you is like pulling snail teeth. You say that you are connecting. So, that means that when you click the Site View tab, then the Publishing tab, then "Connect to current publishing destination," you are seeing two panes, your local site on the left and the remote site on the right. Is that correct? If so, then create a new, empty page. Save it as "1-filetest.html." That should put it at the top of the list. Connect to your remote site. On the left side, the newly-created file should be at the top of the file list. Right-click it and select "Publish selected files to...", or left-click it to highlight it, then click the blue right-pointing arrow in the center to publish it, or just left-click, then drag and drop to the right side. Any of those will publish the file. Does it then appear at the top of the list on the right side?

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Friday, May 5, 2017 8:17 PM
  • I use 1and1.com to manage my websites and recently had to relearn out how to do this after my old PC died unexpectantly...  

    Go to Sites | Publishing Settings 

    Select your Publishing Profile and choose Edit

    Select Connection Type:  FTPS

    On 1and1 go to the Secure FTP Account option | Choose the SecureFTP account you use to publish.  If you don't have one set up, set one to land in your folder at the root of your web site space that you publish.

    Capture the Host Name, user name, password (reset if you dont know it & wait 5 minutes)

    In Expressions Connection Settings:
    - Location: paste the host name after the "ftps://" then append ":990" to the end
         (e.g.  ftps://home123.1and1.data.host:990 )
    - Directory: /
    - User Name:  1and1SFTP user name
    - Password:  1and1 password for the account above
    - Max Connections: 8
    - Use Passive: Checked

    Save and then use the created / update publishing provide 

    And bob is your uncle.  No idea why 1and1 doesn't provide this as a How-to as far too many people still use this tool as it does a great job managing content changes.  If this helped you please vote it up.


    Ken F

    Sunday, September 16, 2018 6:18 PM
  • If this helped you please vote it up.


    Ken F

    These forums don't have that option. If the OP should happen to come back, (only) he can check "Mark as Answer" to mark your reply as an answer to his question. Since, lately, OPs often never even return to acknowledge a response or say whether it worked, I wouldn't hold my breath...

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Sunday, September 16, 2018 9:08 PM
  • This thread was from May of 2017, and was talking about a site hosted on GoDaddy.  A reply about settings for 1and1 would not be relevant, especially since the OP said she was able to connect.  (We'll never know, since the OP never came back, but the problem could simply have been a case of browser caching.)

    Kathleen Wilber
    BrightWillow - Asp.Net Applications

    Wednesday, September 19, 2018 2:11 AM