none
No designer, nor toolbox in Blend, after opening a project

    Question

  • Hello,

    I'm currently developing a WPF project. Since it has many features, it also has many visual problems (i.e. Selected row color in GridView is overriden by Background property). I have Telerik framework added to my project, and all solution I'm finding recommends me to open my project in Microsoft Expression Blend and edit it simply. However, when I'm opening my project here, I can only browse my code build and run the project. I'm having no toolbox, no ability to add item, or to visually design anything. It's a window application, with .NET 4.5, Telerik and Entity Framework. Also I'm working on VS 2013 and Blend for 2013 on Windows 10. How do I make it work?

    Best Regards,

    Mateusz

    Tuesday, January 30, 2018 1:48 PM

All replies

  • It sounds as if you might need to enable "developer mode" on your computer. To do this, close VS and Blend if they're open, go to Settings, then "Update and Security," then on the left select "For Developers," and finally, on the right, tick the "Developer Mode" radio button. Ignore the warning; just click "Yes." Open VS and Blend, then reopen and retry your project.

    If this fixes your issue, please "Mark as Answer" this reply. Thank you.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Tuesday, January 30, 2018 5:50 PM
  • Ok, my bad, I didn't mentioned that designer works itself, on new project setup. Just doesn't work on my project. And thanks for this tip, Msdn doesn't mention it, however win 10 directs you to this setting if it's turned off. 
    Wednesday, January 31, 2018 8:11 AM