none
Expressions Web 2 Install Problem RRS feed

  • Question

  • when installing expressions web 2 I get this message at the end of the install:

    "Installation of the Microsoft Expression Web 2 product has reported the following error: 1402"

    I am running Vista x64 and I was under the impression that this program would work with this version of Windows. 

    Any help would be wonderful.

    thanks
    Sunday, March 29, 2009 10:31 PM

Answers

All replies

  • There are several different errors with that error code. You can help us by posting the full text of the error message if it is available.

    Steve Easton, one of the EW MVP's, is the "EW Installation Wizard" around here. Hopefully he'll be able to help you out.

    Also, support by MS for installation issues is available, and it's free.

    -Preston
    Columbia, CA. USA http://www.gildedmoon.com
    • Edited by Preston B Monday, March 30, 2009 12:15 AM Removed a reference to MS Office
    Sunday, March 29, 2009 10:48 PM
  • A 1402 error is a permissions issue when the installer tries to write to the registry.
    Try running the install: As Administrator.
    FrontPage MVP
    Monday, March 30, 2009 12:01 AM
  • I tried running it as administrator and got the same error.  I've also turned off UAC and tried it.  Still no worky.

    I have the retail version and the other programs on the disk install fine.  Only Web 2 doesn't.  It was working in the past but it stopped working and I was trying to reinstall and this is the problem.

    any other ideas?  I can post the install log I guess but it's pretty big :)

    Monday, March 30, 2009 1:02 AM
  • Phone support for installation problems is free from Microsoft.

    https://support.microsoft.com/oas/default.aspx?gprid=12105

    They'd have more resources for that kind of problem, including dealing with error messages, etc. Most people here are users.
    Monday, March 30, 2009 2:26 AM
  • The 1402/1406 errors of writing to/reading from a registry key can be a simple and quick fix or they can be an indication of a registry with numerous permissions problems.

    I do know that every 1402/1406 case that's come into support has not been easy to fix because it's not been just one registry key that was stripped of permissions - there were cases where there were over a hundred keys missing permissions! What we have not determined is what is going into Windows and taking the administrator and system permissions off these keys. My guess right now would be some third party program or possibly a rootkit.

    In either case, there is a sure fire way to repair registry permissions. Check this blog here and follow the steps in the "How to Resolve" section. Even though this blog is not specifically for the 1402/1406 error message, it still applies because the root problem is registry key permissions.

    Will

    Monday, March 30, 2009 3:00 PM
    Moderator
  • Will, could you try posting that link again?  It just leads to the forum.
    Monday, March 30, 2009 3:03 PM
  • Odd, I'm showing it working now. At first it did post back to the forum for some odd reason. I'm thinking the new format has a few wrinkles yet to be ironed out. Here's where the goes:

    http://blogs.msdn.com/xwebsupport/archive/2009/03/18/solution-expression-web-re-installs-itself-each-time-it-is-launched.aspx
    Monday, March 30, 2009 3:13 PM
    Moderator
  • Ok I tried the blog solution and still no luck.  Any other ideas?
    Monday, April 6, 2009 11:37 PM
  • Do a system restore and select a restore point from *before* the issue started.

    Another option is to browse to C:\Windows, right click Regedit.exe and select Run as Administrator.
    When the registry editor opens right click HKEY_LOCAL_MACHINE and select Permissions.
    Check to see if both Administrator and System have both Full Control and Read permissions checked.
    If not check them then click Advanced and make sure the inherit permissions box is checked.
    Note: This is  avery dangerous operation and be prepared to do a system restore if it fails.


    FrontPage MVP
    Monday, April 6, 2009 11:40 PM