none
BOMs RRS feed

  • Question

  • Also asked this on the EW Facebook site ...

    BOM's and me are not friends
    I am working on a site and last week EW decided it would start unchecking the BOM mark required checkbox for this site. I can't predict when it happens, but it seems to be entirely random (which I suppose unlikely to be the case).
    I went through every page last week and manually checked the BOM check box and today some pages have it unchecked again
    Clearly this is because of something I set somewhere. But I don't know what that is. I'd like to know so I don't do it again
    Thanks!


    Stabes

    Monday, May 26, 2014 3:08 PM

All replies

  • Look in Tools -> Page Editor Options -> Authoring.  That tells EW when to add, or not, a BOM when creating or renaming UTF-8 documents.

    Monday, May 26, 2014 6:06 PM
  • Thanks Kathy. Unfortunately, aspx pages are not listed.
    FWIW, all the other were checked on.

    Martin


    Stabes

    Tuesday, May 27, 2014 7:23 AM
  • You didn't mention you were talking about asp.net pages.  Can't help you there, since I don't know why your BOM checkmarks change.

    Can you tell me why you don't want a BOM on an asp.net page?  A PHP page I could understand, but what problems do you find with a BOM on a UTF-8 encoded asp.net page?

    Tuesday, May 27, 2014 9:18 PM
  • No, I do want BOM's in all my pages :-) It's just that they just keep vanishing for no good reason and I don't know why.
    Come back you BOM :-)

    Martin


    Stabes

    Wednesday, May 28, 2014 8:44 AM
  • Do your pages actually not have BOMs, or is the box simply unchecked?  I have no way of knowing why the box is getting unchecked, but are your pages actually changing?

    Open the file in NotePad, and "Save As..."  Look at the encoding dropdown.  Does Notepad think the file is UTF-8?  If so, it is.  If you are not sure, save it from NotePad as UTF-8 and it will also add the BOM.  Refresh EW's folder view, and open the file again in EW, and check: is the encoding UTF8 and the BOM checked?

    Wednesday, May 28, 2014 3:17 PM
  • Thanks Kathy. I will do a few checks in due course.
    What I have discovered (and to me, this is the crucial bit) is that whenever I do a global Find and Replace, all the files that are changed during this process automatically have their BOM checkboxes unchecked. These files then display incorrectly in a browser.

    Martin


    Stabes

    Thursday, May 29, 2014 12:48 PM