The application failed to initialize properly (0xc000007b) Click on OK to terminate the application.


  • Hello,

    I'm getting this error when I try to run Design 3.  I had 2 installed and running without a problem then installed 3 and now neither works.  I found 2 other threads with this error but there is no solution to the problem.

    Does anyone know why I cannot get it to run?  All other Expression Studio 3 apps work.  I did not uninstall version 2 first which was a trial version before installing a non-trial version 3.

    thank you,
    Thursday, August 20, 2009 11:15 PM

All replies

  • Hello Bob,

    I apologize for the lateness of ththis reply. I am just today returning to the office from vacation.

    If you are prompted to send an error report to Microsoft, please do so. If there is a log file generated or a link that says "click here to see what this error report contains", please click that link and either copy and paste the contents of that report to notepad or to an email. If you copied to notepad, please save and email that to me as I would like to have a look at the crash report.

    My email address is WILLBU@MICROSOFT.COM


    Will Buffington
    Microsoft Expression Support
    Monday, August 24, 2009 8:42 PM
  • I too have the same problem....does not give you the option to send MS anything, just terminates the program...Thanks!
    Friday, September 04, 2009 8:30 AM
  • Hello Longstroke,

    I've emailed Will earlier this week but have not yet received an answer.  I emailed him again this morning.

    I'm a bit frustrated as I feel like we've been left hanging with a product that dosn't work.

    Friday, September 04, 2009 3:11 PM
  • Hey guys,

    I apologize for the delay once again. When I see an error opening Design like this my first is the .NET Framework, especially if Design 2 was working, you installed version 3 and now neither will work. Please try the following:

    1. Uninstall the .NET Framework 3.5 from Add/Remove Programs (in the Control Panel) on Windows XP or Programs and Features on Windows Vista/Windows 7.

    Even if the uninstall fails, go on to step 2.

    2. After the Framework 3.5 has been uninstalled or if it failed, download and run the .NET Framework removal tool.

    Here's the link to Aaron Stebner's Framework Removal tool on Windows Live Skydrive:

    Aaron Stebner is a Microsoft employee. The tool he's developed is linked on that page and makes easy work of cleaning up damaged .NET Frameworks from your system so they can be reinstalled. When you run the tool, choose the .NET Framework 3.5 from the list and choose to cleanup. After this is done, reinstall the .NET Framework 3.5 that Design 3 needs by running the Expression Design 3 setup package again. It will detect that the .NET Framework 3.5 is missing and reinstall it for you. After that's done, try running Design 3 again.

    3. If that still fails to resolve the problem, go to START, RUN and type CMD to run a command prompt. Type CHKDSK /R and hit ENTER. Hit the letter Y and restart the machine. Allow the machine to do the check disk scan. After this is done and it goes back into Windows, try Expression Design again.

    Will Buffington
    Microsoft Expression Support

    Friday, September 04, 2009 11:36 PM
  • Thank you Will, I'll give this a try and report back.

    Saturday, September 05, 2009 12:53 PM
  • Hi Will,

    I followed all the steps you provided but unfortunately I'm still receiving the same error.  I'm not sure if it makes any difference but I also have .Net versions previous to 3.5 installed, should I have removed everything before reinstalling 3.5 and sp1?


    Monday, September 07, 2009 6:47 PM
  • I have seen .NET 3.0 and .NET 2.0 cause problems like this before. If you see either of those appear in the Add or Remove Programs list then you can try completely removing them. Design only needs .NET Framework 3.5 to run.

    If that fails to solve the problem then there is something else that would help determine why this is happening (aside from a crash dump), and that is to get a process monitor log. Here's how to get one:

    1. Go to and on the top right of the page click the link to save Procmon to your machine.
    2. Save the ZIP file to a directory on your machine. After the file is saved, open the file.
    3. Extract ‘procmon.exe’ to a directory on your local machine. Then navigate to that directory and run procmon.exe
    4. When process monitor starts it will start logging immediately. Click the magnifying glass button to stop logging, then click the Edit menu > Clear Display.
    5. Start the logging process by clicking the magnifying glass button and then launch Expression Web. After the configuration process is finished, click the magnifying glass button in process monitor to stop the logging process.
    6. Click File > Save and under "Events to Save" select the option "All Events". Under "Format" select the "Native Process Monitor Format (PML)" option. You can change the path to where the file is saved in the "Path" window. By default this is saved in the same directory from where Process Monitor is run from. Click OK to save the file.

    Please send that file to me in email - my email address is

    It may be quite large, so you might want to include it in a ZIP file.

    Will Buffington
    Microsoft Expression Support

    Tuesday, September 08, 2009 3:02 PM
  • Hi Will

    Thank you for your response.  I'll try removing the 3.0 and 2.0 first.  If that fails to remedy the problem I'll send you Process monitor log.

    Friday, September 11, 2009 7:10 PM
  • Hello Will,

    I removed all versions of .Net from my machine and reinstalled 3.5 and the latest SP but Designer still will not run.  I emailed you the log file as requested in your previous post.  Please let me know what we can do next.

    Sunday, September 13, 2009 7:09 PM
  • Okay, this is what I see going on:

    Design.exe processes fire up and start doing their thing:

    DESIGN.EXE 2500 RegOpenKey HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Design.exe
    DESIGN.EXE 2500 RegOpenKey HKLM\System\CurrentControlSet\Control\SafeBoot\Option
    DESIGN.EXE 2500 RegOpenKey HKCU\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
    DESIGN.EXE 2500 RegOpenKey HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Design.exe

    Then they are interrupted by a flurry of this process:

    SMC.EXE - which is Symantec Endpoint Protection


    Onetouch.exe - which is Maxtor Onetouch Detection

    The only other Design.EXE event that happens after that is a THREAD EXIT which means the thread has either faulted or been killed.

    So here is what I would recommend you do:

    Use MSCONFIG to boot the machine without Symantec Endpoint Protection and without Onetouch running. Do the following:

    1. Go to START, and from the RUN line, type MSCONFIG and hit ENTER.

    2. The System Configuration Utility will launch. On the General tab, click the Selective Startup option. Then uncheck the boxes labeled "Load Startup Items" and "Load System Services".

    3. Click on the Services tab. Find the column header at the top labeled "Service" and left click that column header to sort these services in alphabetical order. Scroll down in the list and find service called "Windows Installer" and "Windows Presentation Foundation" and click them so that they have a check in the square box.

    4. Click Apply and when the changes are made, the OK button will read "Close". Click this button and you will asked to reboot the machine.

    5. After the machine has restarted, click OK when the System Configuration Utility information dialog appears. If the System Configuration Utility itself appears, click the red X at the top right corner of the dialog box. If you are prompted to restart the machine, click the button labeled "Exit Without Restart".

    6. Try launching Expression Design.

    If this still fails, try uninstalling and reinstalling Expression Design 3 while in this reduced setup mode and then launch again.

    To get the machine back to Normal mode, open MSConfig again as in Step 1 and on the General tab click the “Normal” startup option. Click Apply, the Close and reboot the machine.

    Will Buffington
    Microsoft Expression Support
    Monday, September 14, 2009 4:52 PM
  • Bob, this is Will again.

    I haven't heard back from you on this and I wanted to check and see if the last suggestion was of any help. If not, there is one more thing we can do and that's to grab a crash dump using a program called debug diagnostics - a Microsoft program.

    1. Download Debug Diagnostics from and install it.
    2. When the install is finished, run it.
    3. In the wizard that appears, choose "Crash rule" and click Next.
    4. Select "A specific process" and click Next.
    5. In the process box, type "Design.exe" without the quotes and click NEXT (don't actually select it from the list, you will need to type the name).
    6. Click NEXT on the next screen as we won't change any options here
    7. Where it says "Userdump location", note the location specified as this is where the dump file will be written. Click NEXT.
    8. Click FINISH to activate the rule now.
    9. Launch Expression Design 3. When it crashes, DebugDiag should create a crash dump. It will be a file with a .DMP file extension and it will be in the folder from step 7 above. You will need to include that DMP file in a ZIP file that you can either share with me or upload to me.

    If you have done this and have a crash dump ready for me to check out, let me know either with a location to download the file such a Windows Live Skydrive ( or I can create a file upload site that you can upload the file into.

    Will Buffington
    Microsoft Expression Support

    Wednesday, September 16, 2009 9:51 PM
  • Hi Will,

    Thank you for your time and effort!

    I've been up to my eyeballs in work so I haven't had an opportunity to try your current suggestion.   Fortunately Blend 3 imports AI files so I have been able to get around using Designer for now.  I'll follow through this evening with your instructions from Monday and if that doesn't work I’ll download the Debug Diagnostics app.

    Thanks again.

    Wednesday, September 16, 2009 9:57 PM
  • hi 
    i am  having the same problem with Microsoft Expression Design 3,Microsoft Expression Web 3 and Microsoft Expression Encoder 3 but the rest of the applications are working fine ...Microsoft Expression Blend 3 ,Microsoft Expression Encoder 3 Screen Capture and Microsoft Expression Web 3 SuperPreview .......
    the thing is that it was not working giving me the same error ....but my brother wanted to do some work on Word i install office 2007 for him then i try web it start working ....then i update my windows using Microsoft install some updates for VS2008 and .net and other ....the i try to run the web 3 it gave me the same error....if i wanted to reinstall or uninstall it give me the same ..error
    i dont understand what is the problem.....????
    Monday, September 28, 2009 10:21 AM
  • Hotice,

    If your Expression Web 3 is crashing as soon as you launch it, please do the steps in the "Wednesday, September 16, 2009 9:51 PM" post from above where I am asking for a crash dump and send it to me. If it's too large to upload from anywhere, let me know and I'll create a file share for you to upload the file. Send me an email to when you have this crash dump ready and I'll take a look at it as soon as possible.

    Will Buffington
    Microsoft Expression Support
    Monday, September 28, 2009 3:08 PM
  • ok done and i am sending the log file to but thing is sure that problem is not with Expression Studio 3 the problem is with some Microsoft Update...why..
    -i have installed fresh copy of may windows xp...just in case to see ...i have install my printer it was working fine on error all..i just update my windows ...the printer startup give me the same error ...and i have not install a single software on it right now...installing expresstion 3 as my first software ...expresstion installer give me the same i have not install expression 3 yet.... ...
    sending you the log file of setup...
    Monday, September 28, 2009 7:04 PM
  • i googled it and find out that many people have the same error ....but with different application some got problem with printer,internet explorer and etc...some say that it is some kind of virus (WORM_KLEZ.E).....but not find any solution for it..


    Tuesday, September 29, 2009 2:22 PM
  • The error you've reported is a common problem although I don't know exactly what causes it. Will probably knows. But I'm sure there is no virus involved.

    Are you running Design on Vista? I know a long time ago when we had installation problems, uninstalling the Suite and then installing again using the "Run as Administrator" solved those problems. Have you tried that yet? What I mean by that is to go to the installation file, right click on it and choose "Run as Administrator" from the context menu.

    Tuesday, September 29, 2009 4:43 PM
  • I've had a very frustrating day with the same issue as stated above when trying to open Expression Design 2, all other apps in Expression Studio work without a problem. Expression Design 2 would open ok in Safe Mode. Tried updated video drivers as per microsoft with no sucess. I have been through the steps above. In the end I removed Symantec Endpoint Protection (version 11.0.3001.2224) and installed build 11.0.5002.333 and now it is working fine.
    Wednesday, October 28, 2009 6:03 AM
  • Hi,

    I'm new here.  I joined this forum trying to find an authoritative Microsoft solution to this problem: "The application failed to initialize properly (0xc000007b) Click on OK to terminate the application"

    Here's my situation:

    I'm running an old PC: Gateway 310X, Pentium 4, 250mb ram. on Windows XP Pro SP3. I have about 2 dozens or so, softwares mostly small registry clean-up/windows optimizer tool, like JV16 powertools, WinXP manager, etc.  I've been running this softwares for years, until recently, I tried some new ones, and new versions of the old utilities I have installed, and something went wrong.  I couldn't run some softwares that use to run flawlessly before, ex WinXP manager. This softwares that don't run are dependent on netframework 2 or higher to work.

    Thinking it might be a Virus,Worm, (This PC is NOT connected to the Internet) I tried a fresh install of WinXp Pro (delete partition, format my Hard Drive to NTFS) and reinstalled netframework 3.5 downloaded from Microsoft. I've redone the same procedure over and over, using Winxp pro sp1,sp2. sp3. and netframework 2 and 3, separately. Same thing, it won't run.

    I've been searching the web for any authentic Microsoft solution, but couldn't find one... this forum has  about the better advice (which I tried including Will Buff, suggetion of the netframework cleanup tool) to no avail...

    Is there any new development to this problem? Please help...

    Thursday, November 12, 2009 6:24 PM
  • Will,

    I am having the same problem, and have followed all of the steps that you ave listed. The strange thing is that I am only having this issue on laptops. I installed the trial of Expressions Design 3 on 2 Dell laptops with Mobile Intel 965 Express Chipset display adapters and get the error. I installed the same trial on a Dell Desktop with an Intel G33/G31 Express Chipset display adapter and the software works fine.

    Is there any limitations that the software would not work on a laptop? Both laptops have Dual Core processors with at least 2GB of RAM.

    Monday, May 10, 2010 6:25 PM
  • I had the same problem and updating Symantec Endpoint Protection (from version 11.0.3001.2224 to 11.0.4202.75) resolved the problem for me.
    Wednesday, May 26, 2010 9:59 AM
  • I had the same problem, it was that the 64bit program was wanting to link to the 32bit common controls. I updated the manifest to support both 32bit and 64bit and it worked fine after that.




    Saturday, May 07, 2011 6:37 AM