none
Can't seem to access existing website with Expression Web RRS feed

  • Question

  • I have a website that I've developed and have been maintaining for years with FrontPage.   My host company says they are dropping FrontPage support, so I thought I'd try migrating to Expression Web.   Downloaded and installed the app, and then tried to access my site (entered the url of the site, and the same credentials I use to open it in FrontPage).  It immediately starts flashing a message over and over about "loading files from http://www.mysite.com" ... but never actually loads/displays any files/folders from the site ... as if it is being "blocked" somehow, and keeps trying over and over.

    Any ideas as to what may be causing this?

    Sunday, December 7, 2014 4:49 AM

Answers

  • OK, the following is a lengthy process, but it is thoroughly described, step-by-step, and will work to bring down your entire site and get you set up for normal publishing.

    Don't use Import. That only gets files that are accessible to any visitor to the site. (This part doesn't apply to you.) If you have the files already in a folder on your hard drive (or can copy them there from a CD or thumb drive), simply use "Site|New Site," then select "General" and "Empty Site." Use the Browse button to navigate to the folder containing the site, and in the "Name" field, give it the name you want to call it. Click OK and the site will open in EW. From then on you can use "Site|Open Site..." or "Site|Recent Sites" to open it and begin work. You can use either the "Folder List" panel on the left or the "Site View" tab to open individual files after you have opened the site.

    (This part does apply to you.) If you don't have the files already on your system, you need to get the login credentials for the site from the former developer. You will need the FTP address, the user name, the FTP password for the site, and if necessary, the folder name (e.g. www, public_html, httpdocs, etc.) to place into the "Directory" field. The previous admin will have all of this info, or you can get it from your hosting provider's tech support.

    Once you have that, create a folder on your local drive that will be the local site root folder. Then, click "Site|Open Site." In the dialog that opens, in the "Location" field, enter the FTP address and, if there is a target folder, put a slash and enter the folder name. So, if the directory is "httpdocs," for example, you would enter "ftp://yourdomainname.com/httpdocs/". EW will ask if you want to edit live; click OK. You will then be asked for the user name and password. Enter them and click OK. The remote site will open in Site View.

    Now, click on the "Publishing" tab at the bottom of the page, then click on the "Add a publishing destination" link. The "Connection Settings" dialog will open. In the dropdown for "Connection Type," select "File System." Use Browse to navigate to the local site root folder you created earlier. Put whatever you want to call the site in the "Name" field, then click "Add."

    EW will then open a dual-pane display, with the "local" (actually the remote) site on the left, and the "remote" (actually local) site on the right. Now you can publish. Click "Site|Publish all files to <whatever-you-named-the-local-folder>". Get a cup of coffee and wait a while.

    OK, you're almost done. It is very, very bad practice to edit a site live, which is what you have set up for now. So, click "Site|New Site..." and navigate to the local folder you just created. As described in the first paragraph above, select "General" and "Empty Site," give it a name, etc., then click OK. Now, with the site open in "Site View," click the "Publishing" tab at the bottom, then "Add a publishing destination..." to open the "Connection Settings" dialog. This time, the "Connection Type" will be FTP, and you will enter the other login credentials in the appropriate places, then click "Add."

    Now, from now on, both sites will appear in the "Open Site" list. It is easy to distinguish them, because the remote site's path will begin with "FTP." You don't really need it anymore, now that you have the files locally (and you always want to work and test locally before publishing ;-), so if you wish, you can use "Site|Manage sites list..." to delete it. That will only remove it from the list; it still exists as the other site name you created.

    I have tried before the method of creating a local site, then a publishing destination, then selecting all the files on the right and either dragging them to the left or clicking the blue left-facing arrow, but that has invariably failed to successfully recurse all the remote subfolders and bring all of the files down. The only way that I have consistently been able to "publish down" from remote to local in one pass is to follow the procedure described above. Time-consuming as it is, it gets the job done, first time, every time.  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Marked as answer by tullglaz Tuesday, December 9, 2014 1:51 PM
    Monday, December 8, 2014 10:31 PM

All replies

  • Impossible for us to say, since we're not at your computer and can't see the EXACT error message (approximations and abbreviations aren't helpful), nor can we see what you have entered into the "Connection Settings" dialog, etc.

    How are you trying to access it—the FPSE (HTTP), FTP, what)? Have you tried repairing/reinstalling the FPSE at the server end? Tell us more.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Sunday, December 7, 2014 5:26 AM
  • Try creating a folder on your computer and then ftp all the files from your website into that folder (using ftp: protocol, not http: protocol).

    Then use EW to open that local copy of your website. See if that works.




    ClarkNK, A.K.A. HomePage Doctor
    HomePageDoctor.com -- Database Tutorials
    Ownertrades.com -- Created with Expression, VWDExress, SQL Express, and ASP.NET
    Arvixe -- My favored web host

    Sunday, December 7, 2014 1:38 PM
  • Dropping FrontPage support means they're dropping support for the FrontPage extensions.

    You need to open the site suing the ftp:// address.


    Expression Web MVP

    Sunday, December 7, 2014 3:01 PM
  • Heh, heh... good catch, Steve. The way the OP worded it, "...they are dropping FrontPage support..." made it sound as if the occurrence would be at a date future, so I thought that he still had the use of FPSE transfers. However, you may be right; he may have meant that it's already a done deal, in which case his only alternative is FTP or (far less likely) WebDAV.

    To the OP, the FTP protocol is, as its name indicates, a File Transfer Protocol. Transferring an entire file at a time is as granular as it gets, so keystrokes, mouse movements, etc. are out of the question. That means that if you have been in the habit of editing live on the server you will have to stop. Although EW offers what appears to be live editing over FTP, what actually happens is that the file is downloaded, you edit it, then it is transferred back up when you save it.

    So, do as Clark says, which is standard industry best practice anyway—publish your site down to a local folder (which becomes a "site" when you open it in EW), then do all your editing locally. Then test in all four major desktop browsers, plus any mobile platforms you want (or need) to support, before publishing your changes up to the live server.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Monday, December 8, 2014 8:46 PM
  • Thanks to all who have responded!   I created a local folder and have attempted to ftp the entire site there (using EW's "Import Wizard" tool).   It appeared to work ... until I actually examined the contents of the folders from the original web site, and found that they were all empty!  (The transfer process created all the folders - some 120 different folder names - but didn't copy any of the contents from those individual folders).   All of the pages/files that were just under the "root directory (not in a sub-folder) were transferred correctly.

    Anyway to set it so the "import" process works transfers the folder contents (sub-levels?) from all the existing folders on the site?

    Thanks again!

    p.s.   the hosting site hasn't actually stopped supporting Front Page yet ... but it sounds "imminent", so I think I'd better find another way to maintain the site.   When I tried to use Expression Web to connect to the site using FP extensions, it accepted my username/password credentials, and then seemed to try and do a directory listing of all the site's folders/files - but just "hung" and never returned.  

    Monday, December 8, 2014 9:31 PM
  • OK, the following is a lengthy process, but it is thoroughly described, step-by-step, and will work to bring down your entire site and get you set up for normal publishing.

    Don't use Import. That only gets files that are accessible to any visitor to the site. (This part doesn't apply to you.) If you have the files already in a folder on your hard drive (or can copy them there from a CD or thumb drive), simply use "Site|New Site," then select "General" and "Empty Site." Use the Browse button to navigate to the folder containing the site, and in the "Name" field, give it the name you want to call it. Click OK and the site will open in EW. From then on you can use "Site|Open Site..." or "Site|Recent Sites" to open it and begin work. You can use either the "Folder List" panel on the left or the "Site View" tab to open individual files after you have opened the site.

    (This part does apply to you.) If you don't have the files already on your system, you need to get the login credentials for the site from the former developer. You will need the FTP address, the user name, the FTP password for the site, and if necessary, the folder name (e.g. www, public_html, httpdocs, etc.) to place into the "Directory" field. The previous admin will have all of this info, or you can get it from your hosting provider's tech support.

    Once you have that, create a folder on your local drive that will be the local site root folder. Then, click "Site|Open Site." In the dialog that opens, in the "Location" field, enter the FTP address and, if there is a target folder, put a slash and enter the folder name. So, if the directory is "httpdocs," for example, you would enter "ftp://yourdomainname.com/httpdocs/". EW will ask if you want to edit live; click OK. You will then be asked for the user name and password. Enter them and click OK. The remote site will open in Site View.

    Now, click on the "Publishing" tab at the bottom of the page, then click on the "Add a publishing destination" link. The "Connection Settings" dialog will open. In the dropdown for "Connection Type," select "File System." Use Browse to navigate to the local site root folder you created earlier. Put whatever you want to call the site in the "Name" field, then click "Add."

    EW will then open a dual-pane display, with the "local" (actually the remote) site on the left, and the "remote" (actually local) site on the right. Now you can publish. Click "Site|Publish all files to <whatever-you-named-the-local-folder>". Get a cup of coffee and wait a while.

    OK, you're almost done. It is very, very bad practice to edit a site live, which is what you have set up for now. So, click "Site|New Site..." and navigate to the local folder you just created. As described in the first paragraph above, select "General" and "Empty Site," give it a name, etc., then click OK. Now, with the site open in "Site View," click the "Publishing" tab at the bottom, then "Add a publishing destination..." to open the "Connection Settings" dialog. This time, the "Connection Type" will be FTP, and you will enter the other login credentials in the appropriate places, then click "Add."

    Now, from now on, both sites will appear in the "Open Site" list. It is easy to distinguish them, because the remote site's path will begin with "FTP." You don't really need it anymore, now that you have the files locally (and you always want to work and test locally before publishing ;-), so if you wish, you can use "Site|Manage sites list..." to delete it. That will only remove it from the list; it still exists as the other site name you created.

    I have tried before the method of creating a local site, then a publishing destination, then selecting all the files on the right and either dragging them to the left or clicking the blue left-facing arrow, but that has invariably failed to successfully recurse all the remote subfolders and bring all of the files down. The only way that I have consistently been able to "publish down" from remote to local in one pass is to follow the procedure described above. Time-consuming as it is, it gets the job done, first time, every time.  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Marked as answer by tullglaz Tuesday, December 9, 2014 1:51 PM
    Monday, December 8, 2014 10:31 PM
  • Wow!   Thanks SO much, Scott, for this very detailed, and very helpful response.   It actually worked ... almost ...

    All was going fine until the "publish all" procedure generated the following error message and aborted:

    "Server error:  The URL '_vti_script' is invalid.   It may refer to a nonexistant file or folder, or refer to a valid file or folder that is not in the current site".

    A directory listing of the remote site does show a folder named "_vti_script" ... although I have no idea where that came from.   I have no idea what is in that folder.  Is there any way to tell it to "publish all .... EXCEPT '_vti_script' ??

    Thanks again!

    --Paul

    UPDATE:   I did a "Google" search, and found some information that referred to how to "exclude" files/folders" from publishing in EW that involved doing a "right-click" on the folder/files you want to exclude, and then choose "Exclude from publishing" from the drop down .... except when I do a right-click, I don't see any such "exclude" option ???

    Also, I notice that nearly every folder on the remote site includes a sub-folder named "_vti_cnf" .... is that going to cause me problems as well??

    • Edited by tullglaz Tuesday, December 9, 2014 2:06 PM
    Tuesday, December 9, 2014 1:51 PM
  • I tried selecting all folder/files except for the "_vti_script" folder and then clicked on the blue "right-arrow" to try and publish all the remaining folders/files to my local directory ... but it quickly failed as soon as it hit the first folder that included one of those "_vti_cnf" sub-folders in it (which is the vast majority of them).

    Still hoping there's some easy way to have it "ignore" any files/folders that start with the "_" underscore character ....  ?

    Tuesday, December 9, 2014 4:07 PM
  • Oh, yeah, that's a bloody problem. Those "_vti****" files and folders are leftovers from FrontPage. They're used by EW, too, if you use the FPSE, but only locally for site management if you don't. Unfortunately, EW's publish function chokes on them in this process.

    There is a workaround, but it only finds files, not folders. Download and install the free, excellent FileZilla. Set up your site root as a remote server and log in, then select"Server|Search remote files..." and enter "_vti".

    The problem is, that will return the contents of all those folders. Now you can select all (Ctrl-A) and delete them (right-click), but that still leaves the folders, which still bolloxes the publish.

    So, what I suggest is that you call your provider's support and ask them to run a script to bulk delete those folders. They can do stuff at the local server level that you can't do, other than manually. Once they're gone, your publish operation should go smooth lahk buttah.  ;-)

    cheers,
    scott

    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Wednesday, December 10, 2014 5:08 AM
  • *sigh* ... guess the adage of "there ain't nuthin' easy" definitely applies.  

    I guess you are saying that deleting these "_vti*****" files/folders won't adversely affect the current website, correct?   Since I currently have no way to update the website, I want to be sure I won't break anything by removing those files (can someone explain what they are for ... and why EW can't deal with them?).

    If it's safe, I'll probably have to delete them from the site manually myself - getting my ISP to do anything like that would no doubt be pricey ... and I'm not sure I'd trust them to do it right.

    As far as I can tell, most of those _vti folders that exist are completely empty ... are there "hidden" files or something?

    I'm still curious about the documentation for EW4 I found that references a method of marking individual files/folds for "exclusion" from publishing ... since I don't see that option, does that just mean I need to download a different version of the EW software from somewhere so I could try that?   That seems like the easiest way to handle this .... if it works.

    Wednesday, December 10, 2014 2:07 PM
  • Best thing to do with the _vti folders and files is to forget they exist and leave them alone.
    EW even uses them on your local site when you have it set to maintain the site using hidden metadata.


    Expression Web MVP

    Wednesday, December 10, 2014 2:48 PM
  • I would LOVE to ignore them and leave them alone!   But EW is "choking" on them when I try to do a one-time create of my website on my local disk.   Trying to "publish" all files from the "remote" server (my "live" website) down to my local disk so I can start with that initially, and then use EW to publish files from my local disk back to the host server going forward isn't working because EW can't get past all those "_vti" folders to make the initial local copy ...
    Wednesday, December 10, 2014 3:03 PM
  • Best thing to do with the _vti folders and files is to forget they exist and leave them alone.
    EW even uses them on your local site when you have it set to maintain the site using hidden metadata.
    Steve, that is not an option. If you had read the thread, you would know that the remote "_vti" folders are preventing him from publishing his site down. EW uses those folders locally for its "hidden metadata," but they're only used remotely by the FPSE, and EW's FTP publishing doesn't know how to handle those hidden, protected remote folders, so it abends the publish process every time it encounters one.

    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Wednesday, December 10, 2014 10:46 PM
  • I'm still curious about the documentation for EW4 I found that references a method of marking individual files/folds for "exclusion" from publishing ...

    That refers to your local copy.  If you are trying to use that on the hosted copy you are publishing down - no, that option is not there.

    Wednesday, December 10, 2014 11:07 PM
  • *sigh* ... guess the adage of "there ain't nuthin' easy" definitely applies.  

    I guess you are saying that deleting these "_vti*****" files/folders won't adversely affect the current website, correct?   Since I currently have no way to update the website, I want to be sure I won't break anything by removing those files (can someone explain what they are for ... and why EW can't deal with them?).

    If it's safe, I'll probably have to delete them from the site manually myself - getting my ISP to do anything like that would no doubt be pricey ... and I'm not sure I'd trust them to do it right.

    As far as I can tell, most of those _vti folders that exist are completely empty ... are there "hidden" files or something?

    I'm still curious about the documentation for EW4 I found that references a method of marking individual files/folds for "exclusion" from publishing ... since I don't see that option, does that just mean I need to download a different version of the EW software from somewhere so I could try that?   That seems like the easiest way to handle this .... if it works.

    As to your first question, no, deleting those remote "_vti****" files and folders won't adversely affect the current website. They are used on the server side solely by the FPSE, and EW knows/cares nothing about them. They are basically hidden from EW and were created and used by the server extensions similarly to the way they are used locally by EW—as hidden metadata to keep track of the status of your site. EW can't deal with them because they were created and managed by the extensions, and are hidden and protected from EW, and EW's FTP publishing process doesn't know how to deal with such folders.

    As for your second paragraph, why not simply ask? As a former server admin, I can tell you that you would be surprised how quickly and easily such a task can be performed by a server admin, either by writing a quick script to recurse your root directory, find all "_vti****" files and folders, and delete them, or these days, using Windows PowerShell to accomplish the same thing. Use a little social engineering on them, pointing out that you have been a loyal customer for all this time, and now that they are unilaterally ditching the FPSE, they owe you a little assistance making the transition (only the truth, after all...).

    As for the file/folder exclusion process, think about it—that only works on local files and folders. EW has no way to mark files and folders on the remote server as excluded, since it does not have file system level access to the remote operating system. Give it a try on local files and folders and you will find that it works just fine, and there are no versions of EW that have ever operated any differently. Not to mention that the free version EW4 SP2a that you are using is the only version you could install that wouldn't require you to buy a license to activate it.  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Wednesday, December 10, 2014 11:09 PM
  • Ok, I think I get - thanks for clearing that up. 

    I did go ahead and install the Mozilla ftp client, and used it to copy the entire remote website down to a folder on my local hard drive - slick!   It didn't seem to have any problem with the_vti_*** files/folders - brought them down as well.  So NOW my question is, can't I just point EW4 to that Mozilla-created folder as my "local" copy, and set up the remote website as the "publishing destination", and then mark the _vti folders as "excluded" when I publish with EW4?

    Wednesday, December 10, 2014 11:27 PM
  • EW doesn't publish the vti files it creates. You don't have to do anything to prevent that from happening.
    Thursday, December 11, 2014 2:33 AM
  • Best thing to do with the _vti folders and files is to forget they exist and leave them alone.
    EW even uses them on your local site when you have it set to maintain the site using hidden metadata.
    Steve, that is not an option. If you had read the thread, you would know that the remote "_vti" folders are preventing him from publishing his site down. EW uses those folders locally for its "hidden metadata," but they're only used remotely by the FPSE, and EW's FTP publishing doesn't know how to handle those hidden, protected remote folders, so it abends the publish process every time it encounters one.

    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Sorry Scott, but that's not the issue.

    EW in ftp mode ignores the remote _vti folders.


    Expression Web MVP

    Thursday, December 11, 2014 3:16 AM
  • Yep, just select "Site|Open Site..." and Browse to the folder and open it. EW will create it using the folder name as the default name for the site. For more control over such things, use "Site|New Site..." and Browse to the folder. Select General, Empty Site, and give it a name of your choice.

    As for the "_vti****" files and folders, now is when you can just forget about/ignore them. In the local site, they are hidden metadata (EW will not display them in the Folder List or Site View, so you can't possibly exclude them ;-), and they are not published to the server, since they are used only for local site management. The ones that are still on the server will remain there unless you clean them up, but unless you perform another publishing don action will simply be dross and can be ignored.

    You're probably curious, so the point of doing the publish down operation the other way was to establish your local/remote synchronization state immediately. Doing it this way instead, you will find that every file in your site shows a status of either "Changed" or "Conflict," which makes sense since EW has no idea how those files got there or when they were last published. To resolve that, select "Site|Publish All Files to <yoursitename>" and sit back and have a cup of mocha. When the publish process is completed, the metadata will be updated, and all files should have a status of"Unchanged," and EW will then be able to track your edits, so thenceforth after you finish work you can just use "Site|Publish Changed Files to <yoursitename>", and EW will know to publish only those files that have been edited. That should get you all set!  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Thursday, December 11, 2014 11:06 PM
  • Sorry Scott, but that's not the issue.

    EW in ftp mode ignores the remote _vti folders.

    No, Steve, you are incorrect. EW, in any mode, hides the _vti folders, both locally and remotely, so they are not shown in either publishing pane. That means that they are not acted upon when any "select and publish" action is taken. In the scenario described, however, publishing down an entire site, when it enumerates every file and folder in the site, every time that EW encounters one of those _vti folders in the publishing process it abends the process. I have experienced this myself when I first moved from external FTP to EW4's site management, and this is not the first person moving from the FPSE to encounter it.

    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Friday, December 12, 2014 10:09 PM