none
No me carga el griedview cuando ejecuto el programa RRS feed

  • Pregunta

  • Estimado tengo una duda tengo un programa que estoy haciendo con un textbox un boton , un radiogruup y una grilla, al ejecutar el programa la grilla no aparece pero todo lo demas si que puede ser??

    PD la grilla esta en visible = true

    miércoles, 28 de marzo de 2012 15:35

Respuestas

  • hola

    cuando asignas los datos usas algo como ser

    gridview1.DataSource = ...

    gridview1.DataBind();

    el DataBind() es muy importante

    ademas valida que hay registros que mostrar sino deberias definir el EmptyItemTemplate

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    • Marcado como respuesta Vitius86 jueves, 29 de marzo de 2012 11:19
    miércoles, 28 de marzo de 2012 15:43

Todas las respuestas

  • hola

    cuando asignas los datos usas algo como ser

    gridview1.DataSource = ...

    gridview1.DataBind();

    el DataBind() es muy importante

    ademas valida que hay registros que mostrar sino deberias definir el EmptyItemTemplate

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    • Marcado como respuesta Vitius86 jueves, 29 de marzo de 2012 11:19
    miércoles, 28 de marzo de 2012 15:43
  • Estimado Leandro gracias por tu respuesta mira yo la declaración del gridview la hago de esta manera 

    "grvTabla.DataSource = MiTabla"

    donde mi tabla es un datatable que contiene todo lo que necesito, la cuestion es que cuando hago la depuracion ya sea tanto el datatable como el gridview tiene los elementos que traigo de la consulta, mi lo que necesito es que se vea la grilla en la ejecucion del programa ya que en la ventana de diseño si la veo pero al ejecutarla es como si no existiera, probe creando una nueva pagina y poniendo un nuevo grid pero es como si no existieran. si necesitas ver el codigo avisame

    Saludos

    miércoles, 28 de marzo de 2012 21:09
  • despues de asignar el datasource agrega la linea grvTabla.DataBind() tal y como dice leandro, si no la grilla no se va a cargar

    Saludos

    miércoles, 28 de marzo de 2012 22:02
  • creo que no has leido la respuesta que he dado, porque no mencionas si usas

    grvTabla.DataBind();

    si esta linea no esta no importa que tengas o no datos en el datatable nunca se generara el grid


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    jueves, 29 de marzo de 2012 5:48
  • Estimado Leonardo, es verdad tenes la verdad sobre el elemneto gracias por la ayuda tema solucionado 
    jueves, 29 de marzo de 2012 11:19