none
TRADUCIR CODIGO DE PSEINT A C# RRS feed

  • Pregunta

  • HOLA 

    Como seria este codigo de Pseint traducido a C#

    Gracias de Antemano

    Segun Mayusculas(b) Hacer
    "A":
    Si i=1 o j=1 o i=f-trunc(f/2) o j=c Entonces
    Escribir Sin Saltar "*"
    SiNo
    Escribir Sin Saltar " "
    FinSi
    "E":
    Si i=1 o j=1 o i=f-trunc(f/2) o i=f Entonces
    Escribir Sin Saltar "*"
    SiNo
    Escribir Sin Saltar " "
    FinSi
    "I":
    Si i=1 o j=c-trunc(c/2) o i=f Entonces
    Escribir Sin Saltar "*"
    SiNo
    Escribir Sin Saltar " "
    FinSi
    "O":
    Si i=1 o j=1 o j=c o i=f Entonces
    Escribir Sin Saltar "*"
    SiNo
    Escribir Sin Saltar " "
    FinSi
    "U":
    Si j=1 o j=c o i=f Entonces
    Escribir Sin Saltar "*"
    SiNo
    Escribir Sin Saltar " "
    FinSi
    Fin Segun

    miércoles, 6 de noviembre de 2019 15:18

Todas las respuestas

  • Hola Delloream Lawston

     

    Gracias por levantar tu consulta en los foros de MSDN. Con respecto a la misma, te comento que para que la comunidad de foros te pueda asesorar mejor, es necesario que nos compartas el form/code que estás desarrollando. Así como una pregunta específica.

     

    Por el momento te comparto algunos enlaces que contienen información que podría ayudarte a seguir desarrollando tu código.

     

    https://docs.microsoft.com/en-us/dotnet/csharp/programming-guide/

     

     https://docs.microsoft.com/en-us/dotnet/csharp/language-reference/keywords/do

     

    https://docs.microsoft.com/en-us/dotnet/csharp/language-reference/keywords/switch

     

    Gracias por usar los foros de MSDN.

     

    Pablo Rubio

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    miércoles, 6 de noviembre de 2019 16:41
    Moderador
  • es algo asi

    switch (Mayusculas(b))
                {
                    case "A":
                        if (i == 1 || j == 1 || i == f - Math.Truncate(f / 2) || j == c)
                        {
                            Console.Write("*");
                        }
                        else
                        {
                            Console.Write(" ");
                        }
                        break;
                    case "E":
                        if (i == 1 || j == 1 || i == f - Math.Truncate(f / 2) || i == f)
                        {
                            Console.Write("*");
                        }
                        else
                        {
                            Console.Write(" ");
                        }
                        break;
                    case "I":
                        if (i == 1 || j == c - Math.Truncate(c / 2) || i == f)
                        {
                            Console.Write("*");
                        }
                        else
                        {
                            Console.Write(" ");
                        }
                        break;
                    case "O":
                        if (i == 1 || j == 1 || j == c || i == f)
                        {
                            Console.Write("*");
                        }
                        else
                        {
                            Console.Write(" ");
                        }
                        break;
                    case "U": 
                        if (j == 1 || j == c || i == f)
                        {
                            Console.Write("*");
                        }
                        else
                        {
                            Console.Write(" ");
                        }
                        break;
                }

    miércoles, 6 de noviembre de 2019 20:25