none
Error Exit facility code:1204 RRS feed

  • Pregunta

  • Hola buen dia, estoy teniendo un inconveniente a instalar el SQL SERVER 2008 R2 Express, probe muchas alternativas de solucionarlo que encontre en internet, pero sin tener resultado.

    el instalador me ejecuta correctamente las secuencia pero se interrumpe mostrandome el mensaje de error (adjunto sumary al final) y se detiene notificandome de que no se realizo la instalacion.

    la maquina donde estoy instalando es una maquina virtual, recien instalada, con Windows 10 64bits.
    http://download.microsoft.com/download/5/1/A/51A153F6-6B08-4F94-A7B2-BA1AD482BC75/SQLEXPR_x64_ENU.exe
    estoy usando el siguente link para descargar el archivo relacionado a mi aquitectura.

    adjunto summary, desde ya muchas gracias por su ayuda

    Overall summary:
      Final result:                  Failed: see details below
      Exit code (Decimal):           -2068578304
      Exit facility code:            1204
      Exit error code:               0
      Exit message:                  'ALL' is not a valid value for setting 'FEATURES'. Refer to Help for more information.
      Start time:                    2016-08-22 22:07:08
      End time:                      2016-08-22 22:07:16
      Requested action:              RunRules

    Machine Properties:
      Machine name:                  DESKTOP-05RT9GK
      Machine processor count:       1
      OS version:                    Future Windows Version
      OS service pack:               
      OS region:                     United States
      OS language:                   español (España, alfabetización internacional)
      OS architecture:               x64
      Process architecture:          64 Bit
      OS clustered:                  No

    Package properties:
      Description:                   SQL Server Database Services 2008 R2
      ProductName:                   SQL Server 2008 R2
      Type:                          RTM
      Version:                       10
      SPLevel:                       0
      Installation location:         c:\d39af835bb112b91349fd031\x64\setup\
      Installation edition:          EXPRESS

    User Input Settings:
      ACTION:                        RunRules
      CONFIGURATIONFILE:             
      ENU:                           True
      FARMACCOUNT:                   <empty>
      FARMADMINPORT:                 0
      FARMPASSWORD:                  *****
      FEATURES:                      ALL
      HELP:                          False
      IACCEPTSQLSERVERLICENSETERMS:  True
      INDICATEPROGRESS:              False
      INSTANCENAME:                  <empty>
      PASSPHRASE:                    *****
      QUIET:                         False
      QUIETSIMPLE:                   True
      RULES:                         GlobalRules
      UIMODE:                        AutoAdvance
      X86:                           False

      Configuration file:            C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20160822_220649\ConfigurationFile.ini

    Detailed results:

    Rules with failures:

    Global rules:

    There are no scenario-specific rules.

    Rules report file:               The rule result report file is not available.

    Exception summary:
    The following is an exception stack listing the exceptions in outermost to innermost order
    Inner exceptions are being indented

    Exception type: Microsoft.SqlServer.Chainer.Infrastructure.InputSettingValidationException
        Message:
            'ALL' is not a valid value for setting 'FEATURES'. Refer to Help for more information.
        Data:
          SQL.Setup.FailureCategory = InputSettingValidationFailure
          DisableWatson = true
        Stack:
            at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.LogAllValidationErrorsAndThrowFirstOne(ValidationState vs)
            at Microsoft.SqlServer.Configuration.BootstrapExtension.ValidateChainerSettingAction.ExecuteAction(String actionId)
            at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
            at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.ExecuteActionHelper(TextWriter statusStream, ISequencedAction actionToRun)
        Inner exception type: Microsoft.SqlServer.Chainer.Infrastructure.InputSettingValidationException
            Message:
                    'ALL' is not a valid value for setting 'FEATURES'. Refer to Help for more information.
            Data:
              SQL.Setup.FailureCategory = InputSettingValidationFailure

    lunes, 22 de agosto de 2016 20:15

Respuestas

  • No creo que sea eso,yo instale el 2008 comun y el R2 en dos w10 64 bits sin problemas.

    Es porque estas instalando con la instancia por default,ponele un nombre de instancia.

    http://www.sqlcoffee.com/Troubleshooting094.htm

    • Marcado como respuesta boehler martes, 23 de agosto de 2016 21:47
    lunes, 22 de agosto de 2016 22:52
  • boehler,

    MSSQLSERVER es un nombre de instancia predeterminado, por tanto no deberías colocarlo como valor del atributo server. Intenta colocando sólo el nombre del servidor:

     server = "NOMBRE SERVIDOR | IP";

    Por otro lado, la cadena de conexión no debería estar como parte del código de la aplicación, debes tenerlo en un archivo de configuración (App.config)

    Has las pruebas y coméntanos como te fue.


    Espero que la información proporcionada te haya sido de utilidad, quedo atento a tus comentarios.
    • Marcado como respuesta boehler martes, 23 de agosto de 2016 21:47
    martes, 23 de agosto de 2016 5:25

Todas las respuestas

  • Saludos,

    SQL Server 2008 R2 no es comptatible con Windows 10, solo 2012, 2014 y 2016. Aunque existen maneras de forzarla no es recomendado ni soportado.

    https://support.microsoft.com/en-us/kb/2681562
    • Propuesto como respuesta JoseSalas lunes, 22 de agosto de 2016 20:43
    • Editado Enrique AA lunes, 22 de agosto de 2016 20:45
    lunes, 22 de agosto de 2016 20:28
  • No creo que sea eso,yo instale el 2008 comun y el R2 en dos w10 64 bits sin problemas.

    Es porque estas instalando con la instancia por default,ponele un nombre de instancia.

    http://www.sqlcoffee.com/Troubleshooting094.htm

    • Marcado como respuesta boehler martes, 23 de agosto de 2016 21:47
    lunes, 22 de agosto de 2016 22:52
  • Efectivamente, en el codigo para ejecutarlo desde el instalador cambie
    '/QS  /IACCEPTSQLSERVERLICENSETERMS /ACTION=Install /FEATURES=All /INSTANCENAME=SQLEXPRESS /SQLSVCACCOUNT="NT AUTHORITY\Network Service" /SQLSYSADMINACCOUNTS="builtin\administrators"'

    por esto:

    '/Q /Action=install /FEATURES=SQL /INSTANCENAME=MSSQLSERVER /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /AGTSVCACCOUNT="NT AUTHORITY \Network Service" /SECURITYMODE=SQL /SAPWD=@pass /IACCEPTSQLSERVERLICENSETERMS /TCPENABLED=1'

    y logre instalarlo sin problema, pero estoy teniendo un problema con mi programa ahora, no logro crear una cadena de conexiones acorde, estoy teniendo el tipo problema de "error relacionado con la red..."

                        server = ".\\MSSQLSERVER";
                        Password = "@pass";
                        User = "sa";
                        
                        SqlConnection cn;
                        SqlCommand cm;
                        SqlDataReader dr;
                        string path = @"Data source =" + server + "; Initial catalog = master ;user id=" + User + ";password=" + Password;

                        

                        DataTable odt = new DataTable();
                        cn = new SqlConnection(path);
                        cm = new SqlCommand("select * from sys.databases where name = 'Gestion'", cn);
                        cn.Open();
                        dr = cm.ExecuteReader();
                        DataTable dt = new DataTable();
                        dt.Load(dr);
                        cn.Close();

    para ver si tengo respuestas o no... pero seguramente mi cadena de conexiones no quedo bien armada y el codigo con el que pude instalar lo encontre buscando por internet, y no le puedo dar a la tecla de los valores con la cual deba setearla ahora.

    espero puedas ayudarme si no consulto en el foro relacionado de C#

    desde ya muchas gracias.


    • Editado boehler martes, 23 de agosto de 2016 4:28 error de tipeo
    martes, 23 de agosto de 2016 4:27
  • boehler,

    MSSQLSERVER es un nombre de instancia predeterminado, por tanto no deberías colocarlo como valor del atributo server. Intenta colocando sólo el nombre del servidor:

     server = "NOMBRE SERVIDOR | IP";

    Por otro lado, la cadena de conexión no debería estar como parte del código de la aplicación, debes tenerlo en un archivo de configuración (App.config)

    Has las pruebas y coméntanos como te fue.


    Espero que la información proporcionada te haya sido de utilidad, quedo atento a tus comentarios.
    • Marcado como respuesta boehler martes, 23 de agosto de 2016 21:47
    martes, 23 de agosto de 2016 5:25
  • Saludos

    A temor de sonar repetitivo luego existen problemas reportados por compatibilidad, haz una prueba de UDL (https://blogs.msdn.microsoft.com/farukcelik/2007/12/31/basics-first-udl-test/) para ver que puedas de menos llegar al servidor de base de datos.

    martes, 23 de agosto de 2016 14:40
  • boehler,

    Nota que el único elemento de la matriz de separador es GO, ¿no será que la tabla se llama PAGO? De ser así es de esperar que la cadena se subdivida por contener -como parte de la palabra- el separador definido. Se recomienda tener cuidado en elegir el separador para no tener inconvenientes, quizá sea buena idea que definas el separador ";".

    Por otro lado, las últimas consultas que realizas no tienen mucho que ver con el título del hilo (post original), creo que lo conveniente será que cierres el presente hilo y cualquier otra duda la realices en un nuevo post seleccionando la sección adecuada.


    Espero que la información proporcionada te haya sido de utilidad, quedo atento a tus comentarios.
    martes, 23 de agosto de 2016 21:44