none
acceso denegado al registro solicitado c# RRS feed

  • Pregunta

  • cuando intento crear un proyecto en C# me salta ese error,es  decir un cartel con el texto"acceso denegado al registro solicitado", ya descargue el visual studio pero el problema se sigue presentarlo, podrian ayudarme por favor..

    muchisimas gracias..

    sábado, 20 de abril de 2013 19:30

Respuestas

  • subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=system=f


    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f


    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=system=f

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    se ha solucionado.... :D

    desde el administrador principal le di permisos de control total  a el usuarios "todos" en HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 luego fui a "opciones avanzadas" de los permisos

    y en "propietario" seleccione a "todos".

    tambien le di los mismo permisos a "todos" en HKEY_CLASSES_ROOT\VisualStudio.csproj.laucher.10.0 

    saludos y muchísimas gracias de verdad... 

    • Marcado como respuesta euge.p.92 domingo, 21 de abril de 2013 22:50
    domingo, 21 de abril de 2013 21:41

Todas las respuestas

  • hola

    en que carpeta es que defines la creacion del proyecto ?

    podrias poner una imagen donde indica ese acceso denegado ?

    que tipo de proyecto intentas crear ? estas ejecutando como admin local de la pc?


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina


    sábado, 20 de abril de 2013 19:59
  • hola, sinceramente no se en que carpeta lo defino lo que yo hago es esto:

    voy a archivo-> nuevo proyecto luego cuando elijo el tipo de proyecto, cualquiera que elija me da error.... aun no lo he usado porque no me permite crear nada, pero si tiene la licencia porque lo registre ya que el express es gratis.

    y por ultimo el error http://25.media.tumblr.com/c4b186fd8bfa0d9effd4c8616e03cd4e/tumblr_mlkmr3kYsh1rs9m9yo1_500.jpg

    si,lo estoy ejecutando como adm local..

    sábado, 20 de abril de 2013 20:41
  • intenta ejecutar el Vs con esta opcion

    imagen

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    sábado, 20 de abril de 2013 21:18
  • lo ejecute como mostraste en la imagen y el error persiste....

    sábado, 20 de abril de 2013 21:29
  • Prueba reinstalando el framework y el visual studio. Quizá tienes algún componente corrompido.

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 21:31
    Moderador
  • Activaste la versión express con el codigo de Microsoft??

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 21:34
    Moderador
  • el framework me vino instalado con la pc y es original,no  se si aun si podria tener problemas...

    sobre el visual studio lo descargue luego de que se me presentara el problema. pero aun asi instalado me marco este error...

    [04/18/13,20:26:14] TFS Object Model (x86): [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073afc
    [04/18/13,21:29:01] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: CDownloadJobCompositeImpl: Download completed with hr = 0x80004004
    [04/18/13,21:29:02] Microsoft Visual Studio 2010 Ultimate - ENU: [2] Failed to fetch setup file in CGRootComponent::PreInstall(), cancelled
    [04/18/13,21:29:03] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [04/18/13,21:29:04] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [04/18/13,21:29:04] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [04/18/13,21:29:05] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [04/18/13,21:29:05] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [04/18/13,21:29:05] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [04/18/13,21:29:05] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates VC 10.0 Runtime (x86) was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft Visual F# 2.0 Runtime was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Macro Tools was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates TFS Object Model (x86) was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] Return for Microsoft Visual Studio 2010 Ultimate - ENU indicates a failed installation. DepCheck indicates the component is installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft Web Deployment Tool (x86) was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 - Visual Studio 2010 Tools was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft Silverlight 3 SDK was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Tools for Office Runtime (x86) was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Microsoft Office Developer Tools (x86) was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Dotfuscator Software Services - Community Edition was not attempted to be installed.
    [04/18/13,21:29:06] VS70pgui: [2] DepCheck indicates Crystal Reports templates for Visual Studio 2010 was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x86) ENU was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Visual Studio 2010 Tools for SQL Server Compact 3.5 SP2 ENU was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Runtime v1.0 (x86) ENU was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft Sync Services for ADO.NET v2.0 (x86) ENU was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Services v1.0 (x86) ENU was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework SDK v1.0 (x86) ENU was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Performance Collection Tools (x86) was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard 1.4 was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Framework was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Project was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Transact-SQL Language Service was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft SharePoint Developer Tools was not attempted to be installed.
    [04/18/13,21:29:07] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 ADO.NET Entity Framework Tools was not attempted to be installed.
    [04/19/13,13:28:34] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073afc
    [04/19/13,13:51:48] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073b01
    [04/19/13,13:54:54] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073b01
    [04/19/13,14:01:29] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073b01
    [04/19/13,14:14:01] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073b01
    [04/19/13,14:30:07] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073b01
    [04/19/13,14:33:48] Microsoft Visual Studio 2010 Ultimate - ENU: [2] dlmgr: IBackgroundCopyError::GetErrorDescription failed: hr= 0x80073b01
    ***EndOfSession***

    sábado, 20 de abril de 2013 21:36
  • Sigue este enlace por favor

    http://petesbloggerama.blogspot.com.es/2008/01/fix-requested-registry-access-is-not.html

    http://leonardoblanco.wordpress.com/2010/02/10/permisos-en-visual-studio-2k8/


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 21:39
    Moderador
  • Hola!seguiste mis enlaces? Saludos

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 22:23
    Moderador
  • si, los segui, descargue el programa pero la verdad no supe que hacer... ._.

    sábado, 20 de abril de 2013 22:31
  • J

    Ha probado a esto en el registro de Windows? 

    Los usuarios de C# debemos darle permisos a la siguiente clave de registo:

    HKEY_CLASSES_ROOT\VisualStudio.csproj.9.0

    Con este procedimiento ya podemos seguir desarrollando en esta fantastica suite.


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 22:47
    Moderador
  • Ejecutaste el fix.bat del programa?

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 22:49
    Moderador
  • J

    Ha probado a esto en el registro de Windows? 

    Los usuarios de C# debemos darle permisos a la siguiente clave de registo:

    HKEY_CLASSES_ROOT\VisualStudio.csproj.9.0

    Con este procedimiento ya podemos seguir desarrollando en esta fantastica suite."

    ________________________________________

    de echo intente darle permisos pero al parecer no solo debia darselos a HKEY_CLASSES_ROOT\VisualStudio.csproj.9.0 (en mi caso en 10.0) el permiso a esa clave de registro fue aceptada pero tambien debia darle permisoa \VisualStudio.launcher .csproj.10.0--> o algo asi... pero esa clave no me permitio darle permisos.. 

    (y el error perduro) 



    • Editado euge.p.92 sábado, 20 de abril de 2013 23:28
    sábado, 20 de abril de 2013 23:21
  • Ejecutaste el fix.bat del programa?

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    si, pero solo apareció un flash de editor, osea la pantalla negra y letras blancas...
    sábado, 20 de abril de 2013 23:27
  • Ejecutas el bat con Iniciar como Administrador?. Al igual que regedit


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    sábado, 20 de abril de 2013 23:48
    Moderador
  • lo ejecute como administrador pero aparecio el pantallaso y el problema persiste...

    el regedist llego a el con "ejecutar"

    domingo, 21 de abril de 2013 0:33
  • Tu usuario de Windows pertenece al grupo de administradores de tu maquina?? agregalo a dicho grupo e intenta modificar los valores del registro aplicando permisos

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    domingo, 21 de abril de 2013 15:22
    Moderador
  • si, pertenece al grupo de administradores, es mas la cuenta es administrador (tengo2 administradores pero al parecer mi cuenta tiene menos permisos, aunque esta habilitado para todo y tiene como permiso "control total") intente con el otro administrador ( el principal)  pero tampoco funciono y me dio error...
    • Editado euge.p.92 domingo, 21 de abril de 2013 19:46
    domingo, 21 de abril de 2013 19:45
  • subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=system=f


    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f


    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=system=f

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    domingo, 21 de abril de 2013 19:50
    Moderador
  • una pregunta, no puedes conseguir un Visual Studio mayor al Express ? quizas una distribibucion Professional

    o es mas, porque prueba con el express 2012

    solo para descartar si algo se corrompio en esa instalacion en concreto

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    domingo, 21 de abril de 2013 20:15
  • Si,estoy de acuerdo. Esa fue mi primera respuesta. Tal vez algo se corrompió. Inténtalo y nos cuentas

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    domingo, 21 de abril de 2013 20:19
    Moderador
  • subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.vbproj.10.0 /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 /grant=system=f


    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f


    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=users=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT\VCSExpress.csproj.10.0 /grant=system=f

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    se ha solucionado.... :D

    desde el administrador principal le di permisos de control total  a el usuarios "todos" en HKEY_CLASSES_ROOT\VisualStudio.csproj.10.0 luego fui a "opciones avanzadas" de los permisos

    y en "propietario" seleccione a "todos".

    tambien le di los mismo permisos a "todos" en HKEY_CLASSES_ROOT\VisualStudio.csproj.laucher.10.0 

    saludos y muchísimas gracias de verdad... 

    • Marcado como respuesta euge.p.92 domingo, 21 de abril de 2013 22:50
    domingo, 21 de abril de 2013 21:41
  • Me alegro de haberte ayudado. Un saludo y happy coding!!

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    domingo, 21 de abril de 2013 21:46
    Moderador