none
Specified cast is not valid. RRS feed

  • Pregunta

  • saludos quisiera saver por que  esto me da error  al momento de agregar el item al combobox


                string des = cliente.IdentificacionDescripcion;
                string cod = cliente.TipoIdentificacion.ToString();
    
                ListItem item = new ListItem(des, cod);
               // var item = new ListItem(des,cod);
                _cbTipoIdentificacion.Items.Add(item);

    martes, 4 de agosto de 2009 19:47

Respuestas

Todas las respuestas

  • te refieres a lo que tienes comentado??? y que error te da???
    martes, 4 de agosto de 2009 20:18

  • hola

    no has probado de esta forma:

    _cbTipoIdentificacion.Items.Add(new ListItem(des, cod));


    la verdad yo lo he utilizado muchas veces y nunca tuve problemas la verdad es raro.


    cuando te da error cual es la descripcion del mismo ?


    puedes probar tambien si funciona de esta forma:

    string des = cliente.IdentificacionDescripcion;
    _cbTipoIdentificacion.Items.Add(des);



    solo para descartar que item con sola descripcion funcionan.

    saludos
    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    martes, 4 de agosto de 2009 22:38
  • Hola gяєgσяу   , como resolviste este tema?



    Colabora con la comunidad, si éste mensaje te ha sido de utilidad, márcalo como respuesta correcta.
    Juan Carlos Ruiz Pacheco
    Ingeniero de Sistemas
    Microsoft MVP C#
    MCP,MCTS,DCE+Platino,OCA,OCP
    Mi Blog C# XNA Sistemas Operativos
    jueves, 6 de agosto de 2009 15:10
    Moderador
  • si me das unas horas te digo.. mi pc donde  esta el proyecto esta en soporte jeje...
    jueves, 6 de agosto de 2009 15:46
  • hice esto

    string des = cliente.IdentificacionDescripcion;
    string cod = cliente.TipoIdentificacion.ToString();

    ListItem item = new ListItem(des, cod);

    _cbTipoIdentificacion.Items.Add(item);

    _cbTipoIdentificacion.SelectedIndex = 0;
    pense que funcionaba

    pero acabo de hacer una prueba y ahi esta el error


    esta es la descripcion completa


    at System.Windows.Forms.
    UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
      at System.Windows.Forms.StringSource..ctor(String[] strings)
      at System.Windows.Forms.ComboBox.SetAutoComplete(Boolean reset, Boolean recreate)
      at System.Windows.Forms.ComboBox.ObjectCollection.Add(Object item)
      at EWarehouse.Forms.FrmCliente.Mostrar(Cliente cliente) in E:\E-Warehouse\E-Warehouse\Forms\FrmCliente.cs:line 139
      at EWarehouse.Forms.FrmCliente._bntPrimerRegistro_Click(Object sender, EventArgs e) in E:\E-Warehouse\E-Warehouse\Forms\FrmCliente.cs:line 91
      at EWarehouse.Forms.FrmCliente.Optener() in E:\E-Warehouse\E-Warehouse\Forms\FrmCliente.cs:line 70
    viernes, 7 de agosto de 2009 13:40
  • Nota..
    para solucionarlo solo  puse las propiedades AutoCompleteSource y AutoCompleteMode  = none...

    y realmente ignoro la causa de esto
    • Marcado como respuesta Gregory Pilar martes, 11 de agosto de 2009 18:32
    viernes, 7 de agosto de 2009 14:00
  • suena como a un bug.... revisa que tengas las actualizaciones de vs instaladas.


    Colabora con la comunidad, si éste mensaje te ha sido de utilidad, márcalo como respuesta correcta.
    Juan Carlos Ruiz Pacheco
    Ingeniero de Sistemas
    Microsoft MVP C#
    MCP,MCTS,DCE+Platino,OCA,OCP
    Mi Blog C# XNA Sistemas Operativos
    viernes, 7 de agosto de 2009 15:01
    Moderador
  • bueno yo hasta reinstale vista y nada.... total lo deje así mientras... lol
    martes, 11 de agosto de 2009 18:32