none
Problemas con Visual Studio 2015 y Crystal Reports RRS feed

  • Pregunta

  • Tenía instalado Visual Studio 2012 y todo iba sin problemas, decidí ponerme el 2015 y...errores

    Cuando ejecuto la aplicación e intento sacar el informe me da este error:

    Excepción no controlada del tipo 'System.IO.FileNotFoundException' en mscorlib.dll

    Información adicional: No se puede cargar el archivo o ensamblado 'file:///C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\dotnet1\crdb_adoplus.dll' ni una de sus dependencias. El sistema no puede encontrar el archivo especificado

    *Comentaros que la aplicación está hecha para Framework 4.5
    • Cambiado Enrique M. Montejo martes, 13 de diciembre de 2016 17:40 Pregunta relacionada con Crystal Reports.
    lunes, 12 de diciembre de 2016 18:50

Respuestas

  • Termino de encontrar la solución.....

    Me faltaba añadir estas líneas en app.config

    </connectionStrings>
          <startup useLegacyV2RuntimeActivationPolicy="true">
          <requiredRuntime version="v4.0.30319"/>
          <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5"/>
        </startup>
    </configuration>

    • Marcado como respuesta Joyce_AC lunes, 12 de diciembre de 2016 21:33
    lunes, 12 de diciembre de 2016 19:09

Todas las respuestas

  • Termino de encontrar la solución.....

    Me faltaba añadir estas líneas en app.config

    </connectionStrings>
          <startup useLegacyV2RuntimeActivationPolicy="true">
          <requiredRuntime version="v4.0.30319"/>
          <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5"/>
        </startup>
    </configuration>

    • Marcado como respuesta Joyce_AC lunes, 12 de diciembre de 2016 21:33
    lunes, 12 de diciembre de 2016 19:09
  • En las versiones posteriores a Visual Studio 2008 el Crystal Reports se debe instalar por aparte. Y para poder usarlo tienes que escribir unas lineas en tu Archivo App.Config para corregir ese problema.

    Las Lineas son las siguientes

    dentro del marcado <configuration></configuration> debes agregar el siguiente código:

    <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
     </startup>
    Espero te sirva...

    lunes, 12 de diciembre de 2016 20:55
  • Trate de Agregar en web.config el sgte codigo :

    <startup useLegacyV2RuntimeActivationPolicy="true">
        <requiredRuntime version="v4.0.30319"/>
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5"/>
      </startup>

    Y sigue igual, estoy trabajando en C# 2013 con .NETFramework 4.0

    miércoles, 31 de julio de 2019 22:08