none
Css no esta aplicando cambios RRS feed

  • Pregunta

  • Estoy utilizando el sitio web que por defecto trae visual studio , pero he anexado un css que lo utilizo para poner el fondo en gris cuando activo modalpopu extender, el fondo gris no esta funcionando con el archivo css , la referencia del archivo css lo he puesto tanto en el master page , como en el propio formulario pero ni aun asi funciona, lo que he hecho para resolver es ubicar el css dentro del formulario y ahi si funciona , pero quisiera  resolver este problema y ubicar todos los archivos en css.

    Gracias por la repuesta


    Guido.

    lunes, 21 de mayo de 2012 0:45

Respuestas

  • hola

    esto es porque seguramente el masterpage y la pagian estan a diferentes niveles dentro del sitio

    recuerda que quien define la ruta final es la pagina, no el masterpage

    por eso es que deberias tratar de usar el ~/ o el ResolveUrl() para definir la ruta relativa al archivo de estilo si es que lo vas a poner en la masterpage

    sin esta resolviendo de forma incorrecta, por eso no aplcia el estilo cuando esta en la master

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    lunes, 21 de mayo de 2012 3:29
  • Hola, en la mayoría de los navegadores tienes una consola de desarrollo donde podrás ver si los archivos css se están cargando correctamente (lo cual descartaría problemas con las rutas) o el orden en que se están aplicando los css, así también descartas problemas con las prioridades.

    Podrías usarla y así ves si tienes alguno de los problemas anteriormente mencionados


    Atentamente, Sergio.

    Blog
    Twitter

    lunes, 21 de mayo de 2012 7:11

Todas las respuestas

  • hola

    esto es porque seguramente el masterpage y la pagian estan a diferentes niveles dentro del sitio

    recuerda que quien define la ruta final es la pagina, no el masterpage

    por eso es que deberias tratar de usar el ~/ o el ResolveUrl() para definir la ruta relativa al archivo de estilo si es que lo vas a poner en la masterpage

    sin esta resolviendo de forma incorrecta, por eso no aplcia el estilo cuando esta en la master

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    lunes, 21 de mayo de 2012 3:29
  • Hola, en la mayoría de los navegadores tienes una consola de desarrollo donde podrás ver si los archivos css se están cargando correctamente (lo cual descartaría problemas con las rutas) o el orden en que se están aplicando los css, así también descartas problemas con las prioridades.

    Podrías usarla y así ves si tienes alguno de los problemas anteriormente mencionados


    Atentamente, Sergio.

    Blog
    Twitter

    lunes, 21 de mayo de 2012 7:11