none
Crystal Reports RRS feed

  • Pregunta

  • Hola, q tal, tengo un problema con el control CrystalReportViewer, al momento de mostrar un reporte sencillo
    (select * from customers)  lo carga de manera rapida, pero la navegacion es bastante lenta, y no se como solucionarlo, ya que a pesar de que he leido q no use subconsultas ni nada por el estilo, q tan lento puede ser mostrar un reporte q no tiene ni 500 resultados?
    Espero puedan ayudarme.
    martes, 29 de abril de 2008 16:19

Respuestas

  •  

    Hola net_Slayer,

     

    Sólo se me ocurre que mejores tu consulta SQL, evita el * del SELECT  e indica los campos que vas a mostrar. Utiliza índices en tu tabla que agilicen la consulta...por último prueba a generar la consulta por diferentes métodos con Dataset tipados, consultas conectadas...

     

    Javi.

    viernes, 2 de mayo de 2008 23:02

Todas las respuestas

  • Hola net_Slayer,

     

    El problema de la navegación yo lo "sufrí" en algún otro caso, se generaban informes para unos 3000 registros. Y al igual que te pasa a ti la navegación era lentísima, en cambio la generación era bastante rápida.

     

    La solución paso por omitir todos los subinformes y arreglarmelas para generar el mismo informe sin tener que recurrir a ellos, mediante fórmulas, grupos, etc...

     

    Espero que te sirva.

     

    Javi.

     

    jueves, 1 de mayo de 2008 15:12
  • Pero yo no tengo subreportes, son a lo mucho 300 registros y solo agrupo por 1 campo, no tiene sentido de ser, gracias por responder, pero aun tengo el mismo problema, sea grande o chico igual lo sigue mostrando lento

     

    viernes, 2 de mayo de 2008 19:51
  •  

    Hola net_Slayer,

     

    Sólo se me ocurre que mejores tu consulta SQL, evita el * del SELECT  e indica los campos que vas a mostrar. Utiliza índices en tu tabla que agilicen la consulta...por último prueba a generar la consulta por diferentes métodos con Dataset tipados, consultas conectadas...

     

    Javi.

    viernes, 2 de mayo de 2008 23:02