none
Access 2013 (x64) y VisualStudio 2015: "Microsoft.ACE.OLEDB.12.0 no está registrado" (SOLUCIONADO) RRS feed

Respuestas

  • "Admin Pablo Fac" preguntó:

    > Especificaciones: Microsoft Access 2013 x64, Microsoft Visual Studio
    > Enterprise 2015, Windows 8.1 x64
    >
    > Mensaje de Error: 'Microsoft.ACE.OLEDB.12.0' no está registrado en el equipo local.
    >

    Hola:

    Si ese mensaje de error lo obtienes cuando deseas configurar una conexión con la base de datos de Access desde el propio entorno de desarrollo de Visual Studio 2015, la solución es la que aparece en el enlace que has indicado, que consiste en instalar una versión de 32 bits del motor de Microsoft Access, ya que la arquitectura de Visual Studio es de 32 bits y, por lo que comentas, dispones en tu equipo de la versión de 64 bits de Microsoft Access 2013. Como no dispones de una versión instalada y registrada de 32 bits, es el motivo de que obtengas el mensaje de error mencionado.

    Controlador de 2007 Office system: Componentes de conectividad de datos

    Un saludo


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.

    jueves, 4 de febrero de 2016 7:06
    Moderador
  • "Admin Pablo Fac" escribió:

    > Instalé el programa que me dejaste en el link, pero al crear de nuevo la
    > conexión a la base de datos (que por cierto es local) dice el siguiente
    > mensaje (de error).
    >
    > Mensaje de Error:
    >
    > No se reconoce el formato de base de datos. 'C:\Users\Pablo\Desktop\Agenda1.accdb'.

    ¡Vamos a ver! Ese mensaje de error NO TIENE NADA QUE VER con el mensaje de error «'Microsoft.ACE.OLEDB.12.0' no está registrado en el equipo local», que si ya no lo recibes es porque la solución que te ofrecí es la correcta.

    Otra cuestión diferente es que el motor de datos Microsoft Access 2007 de 32 bits no reconozca el formato del supuesto archivo de Access indicado en el parámetro Data Source de la cadena de conexión, bien porque no se trate de una base de datos de Access, o porque ésta se encuentre protegida con una contraseña que se estableció con la versión de Microsoft Access 2010 o superior, cuyo sistema de cifrado NO ES COMPATIBLE con el sistema de cifrado de Access 2007.

    Si por casualidad se trata de esto último, desinstala la versión de 32 bits de Access 2007 e instala la versión de 32 bits de Access 2010:

    Componente redistribuible del motor de base de datos de Microsoft Access 2010

    Y si no se trata de una cosa ni de la otra, pues sinceramente te digo que no tengo ni la menor idea a qué se puede deber este NUEVO mensaje de error que estás obteniendo.


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.


    viernes, 5 de febrero de 2016 7:36
    Moderador

Todas las respuestas

  • "Admin Pablo Fac" preguntó:

    > Especificaciones: Microsoft Access 2013 x64, Microsoft Visual Studio
    > Enterprise 2015, Windows 8.1 x64
    >
    > Mensaje de Error: 'Microsoft.ACE.OLEDB.12.0' no está registrado en el equipo local.
    >

    Hola:

    Si ese mensaje de error lo obtienes cuando deseas configurar una conexión con la base de datos de Access desde el propio entorno de desarrollo de Visual Studio 2015, la solución es la que aparece en el enlace que has indicado, que consiste en instalar una versión de 32 bits del motor de Microsoft Access, ya que la arquitectura de Visual Studio es de 32 bits y, por lo que comentas, dispones en tu equipo de la versión de 64 bits de Microsoft Access 2013. Como no dispones de una versión instalada y registrada de 32 bits, es el motivo de que obtengas el mensaje de error mencionado.

    Controlador de 2007 Office system: Componentes de conectividad de datos

    Un saludo


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.

    jueves, 4 de febrero de 2016 7:06
    Moderador
  • Hola Enrique.

    Instalé el programa que me dejaste en el link, pero al crear de nuevo la conexión a la base de datos (que por cierto es local) dice el siguiente mensaje (de error).

    Mensaje de Error:

    No se reconoce el formato de base de datos. 'C:\Users\Pablo\Desktop\Agenda1.accdb'.


    Atte. Pablo

    jueves, 4 de febrero de 2016 21:49
  • "Admin Pablo Fac" escribió:

    > Instalé el programa que me dejaste en el link, pero al crear de nuevo la
    > conexión a la base de datos (que por cierto es local) dice el siguiente
    > mensaje (de error).
    >
    > Mensaje de Error:
    >
    > No se reconoce el formato de base de datos. 'C:\Users\Pablo\Desktop\Agenda1.accdb'.

    ¡Vamos a ver! Ese mensaje de error NO TIENE NADA QUE VER con el mensaje de error «'Microsoft.ACE.OLEDB.12.0' no está registrado en el equipo local», que si ya no lo recibes es porque la solución que te ofrecí es la correcta.

    Otra cuestión diferente es que el motor de datos Microsoft Access 2007 de 32 bits no reconozca el formato del supuesto archivo de Access indicado en el parámetro Data Source de la cadena de conexión, bien porque no se trate de una base de datos de Access, o porque ésta se encuentre protegida con una contraseña que se estableció con la versión de Microsoft Access 2010 o superior, cuyo sistema de cifrado NO ES COMPATIBLE con el sistema de cifrado de Access 2007.

    Si por casualidad se trata de esto último, desinstala la versión de 32 bits de Access 2007 e instala la versión de 32 bits de Access 2010:

    Componente redistribuible del motor de base de datos de Microsoft Access 2010

    Y si no se trata de una cosa ni de la otra, pues sinceramente te digo que no tengo ni la menor idea a qué se puede deber este NUEVO mensaje de error que estás obteniendo.


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.


    viernes, 5 de febrero de 2016 7:36
    Moderador
  • Hola.

    La solucion que me diste a la pregunta principal (Access 2013 (x64) y VisualStudio 2015: "Microsoft.ACE.OLEDB.12.0 no está registrado") estaba bien, por eso gracias por responderme y ayudarme a llegar a solucionarlo.

    Ahora bien, cuando me surge otro problema, que surgió en base a que hice lo que decía en tu respuesta, lo más lógico que se me ocurrió era preguntarte como arreglarlo, porque en definitiva, arreglaba algo pero no andaba otra cosa, y el propósito de la pregunta, ya sea principal o secundaria, era "Como resolver este problema: ...",  que por cierto, es el propósito de todas las preguntas que se publican en este sitio.

    Igualmente, gracias por responder mi pregunta, mis otras preguntas, y cualquier otra pregunta de este sitio.



    Atte. Pablo

    viernes, 5 de febrero de 2016 20:43
  • "Admin Pablo Fac" escribió:

    > Ahora bien, cuando me surge otro problema, que surgió en base a que hice
    > lo que decía en tu respuesta, lo más lógico que se me ocurrió era
    > preguntarte como arreglarlo, porque en definitiva, arreglaba algo pero no
    > andaba otra cosa, ...

    Digo yo que "arreglaste" lo principal, porque si no tienes instalada la versión de 32 bits del motor Microsoft.ACE.OLEDB.12.0, ¿cómo pretendes crear una conexión con una base de datos de Access 2007 o superior con cualquier programa de 32 bits, como es el caso de Visual Studio 2015? Necesitas, sí o sí, tener instalada una versión de 32 bits compatible, aunque posteriormente te surjan nuevos problemas. Pero estos problemas, digamos secundarios, no tienen nada que ver con instalar una versión de 32 bits, que vuelvo a insistir, es lo principal, siempre y cuando desees establecer una conexión con una base de datos de Access desde la ventana Explorador de servidores de cualquier versión de Visual Studio, claro está.

    > ... y el propósito de la pregunta, ya sea principal o secundaria, era
    > "Como resolver este problema: ...",  que por cierto, es el propósito de
    > todas las preguntas que se publican en este sitio.

    Efectivamente ese es el propósito, pero lo que no se debería hacer es englobar preguntas que no tienen nada que ver la una con la otra en una misma conversación o "hilo", porque si todos los usuarios hicieran eso, lo único que estaríamos haciendo es impedir que los restantes usuarios del foro busquen por sí solos soluciones satisfactorias a sus problemas. Lo normal es que hubieras cerrado la pregunta e iniciar una nueva para el mensaje de error No se reconoce el formato de base de datos, y que en ella hubieses indicado algunas características del archivo 'Agenda1.accdb', como por ejemplo, si tiene establecida una contraseña, y si ésta fue creada con una versión de Access 2007, o de Access 2010 o superior.

    Si ello es cierto y lo hubieses indicado en tu primera pregunta, entonces no te habría dicho que instalaras el controlador para Access 2007, sino que descargaras e instalaras directamente el controlador de 32 bits para Access 2010, por lo que "habrías matado dos pájaros de un tiro". Pero como bien creo que podrás comprender, ignoro por completo las características que tiene el archivo de Access llamado 'Agenda1.accdb'. ;-)

    En resumidas cuentas: ¿has solucionado el problema No se reconoce el formato de base de datos instalando el controlador de 32 bits de Access 2010? ¿Tiene contraseña? ¿Estableciste la contraseña con Access 2013?


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.

    sábado, 6 de febrero de 2016 7:43
    Moderador
  • Hola Enrique.

    Hoy pude conectar la base de datos creada en Access 2013 con formato 2007-2013 a Visual Studio. Eliminé el motor de access 2007 e instalé el de 2010 y ahora funciona.

    Gracias x tu ayuda.


    Atte. Pablo

    sábado, 6 de febrero de 2016 21:28