none
Se para el servicio Claim To Windows Token Service RRS feed

  • Pregunta

  • Muy buenas. 

    Tengo una máquina en la que hay montado un Sharepoint Server 2010 Enterprise. Entre otras cosas funcionando tengo Performancepoint Services con varios dashboard funcionando.

    Inicialmente todos las conexiones a orígenes de datos (fundamentalmente cubos de Analysis Services) que usan los dashboard están configuradas para conectarse mediante la cuenta de servicio de Performancepoint, y esto funciona sin problemas. Ahora bien, la cuestión es que necesito que esas conexiones de datos utilicen autenticación por usuario.

    Para eso he configurado todo para que la autenticación sea mediante Kerberos, y todo ha acabado funcionando bien. 

    El problema es que, cuando le da la gana, el servicio c2wts se para, y evidentemente los dashboard dejan de funcionar hasta que lo vuelvo a iniciar. 

    Encontré por Internet un problema conocido por el que el servicio c2wts no se iniciaba automáticamente al reiniciar la máquina debido a que faltaba por crear una dependencia de este servicio con el servicio de criptografía, y esto lo he solucionado, sin embargo se sigue parando sin saber muy bien porqué.

    ¿Alguna idea?

    Muchas gracias.

    jueves, 5 de julio de 2012 16:39

Respuestas

  • Buenas, Juan Carlos.

    Ya he encontrado el problema y lo he solucionado. 

    La cuestión es que yo iniciaba el servicio C2WTS directamente desde la consola de servicios de Windows, pero no había iniciado el servicio "Notificaciones del servicio de token de windows" en Sharepoint (por lo tanto a efectos de Sharepoint el servicio estaba como no iniciado).

    Parece ser que el propio Sharepoint hace "barridos" de comprobación de los servicios cada hora en punto (esto es curioso, porque había comprobado que las paradas del servicio siempre se producían cada hora en punto, en concreto a las 17:00:01, 18:00:01, etc., y siempre así). Como Sharepoint tenía en su lista de servicios al servicio "Notificaciones del servicio de token de Windows" como parado, y sin embargo encontraba que el servicio de "Claim to Windows Token Service" estaba iniciado, era el propio Sharepoint el que se encargaba de pararlo.

    La solución ha sido simplemente iniciar el servicio "Notificaciones del Servicio de token de Windows" en Sharepoint. Esto se hace desde Administración Central de Sharpeoint / Administración Central / Configuración del Sistema / Administrar Servicios en el servidor.

    Espero que os sirva.

    martes, 10 de julio de 2012 6:27

Todas las respuestas

  • Hola,

    ¿Se registra algún error que esté motivando la parada del servicio? ¿Qué nivel de actualizaciones tienes instalado en tu ambiente de SharePoint 2010?

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    viernes, 6 de julio de 2012 6:22
  • Hola, Juan Carlos.

    He mirado el visor de sucesos y se registran eventos tanto en la rama de Aplicación como en la rama de Sistema, pero no son eventos de error, sino eventos informativos.

    Por ejemplo, en la rama de eventos de Sistema se han registrado estos dos eventos:

    - El servicio Claims to Windows Token Service entró en estado "detenido".

    - El tipo de inicio del servicio Claims to Windows Token Service se cambió de inicio automático a deshabilitado.

    Es decir, que no solo detiene el servicio, sino que cambia el tipo de inicio de automático a deshabilitado, por lo que la siguiente vez que se reinicie el servidor este servicio no iniciará porque está deshabilitado.

    En la rama de sucesos de Aplicación aparece este evento informativo (tampoco es un evento de error):

    - El servicio se detuvo correctamente.

    Para mas información, el servidor corre bajo Windows Server 2008 R2.

    Cualquier ayuda se agradece.

    Saludos.

    lunes, 9 de julio de 2012 15:16
  • Hola,

    ¿Y en los logs de SharePoint que información se recoge?

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    lunes, 9 de julio de 2012 16:06
  • Buenas, Juan Carlos.

    Ya he encontrado el problema y lo he solucionado. 

    La cuestión es que yo iniciaba el servicio C2WTS directamente desde la consola de servicios de Windows, pero no había iniciado el servicio "Notificaciones del servicio de token de windows" en Sharepoint (por lo tanto a efectos de Sharepoint el servicio estaba como no iniciado).

    Parece ser que el propio Sharepoint hace "barridos" de comprobación de los servicios cada hora en punto (esto es curioso, porque había comprobado que las paradas del servicio siempre se producían cada hora en punto, en concreto a las 17:00:01, 18:00:01, etc., y siempre así). Como Sharepoint tenía en su lista de servicios al servicio "Notificaciones del servicio de token de Windows" como parado, y sin embargo encontraba que el servicio de "Claim to Windows Token Service" estaba iniciado, era el propio Sharepoint el que se encargaba de pararlo.

    La solución ha sido simplemente iniciar el servicio "Notificaciones del Servicio de token de Windows" en Sharepoint. Esto se hace desde Administración Central de Sharpeoint / Administración Central / Configuración del Sistema / Administrar Servicios en el servidor.

    Espero que os sirva.

    martes, 10 de julio de 2012 6:27