none
La base de datos sql server express 2012 es compatible con visual studio community 2017 RRS feed

  • Pregunta

  • Hola amigos tengo una duda tengo instalado en mi ordenador visual studio community 2017 y quiero hacer unas pruebas integrando algunos softwares que he estado desarrollando para unas actividades de la universidad donde estudió con una base de datos sql server express 2012 debido a que en mi ordenador no puedo instalar las versiones más modernas de sql server express por que mi ordenador no tiene los recursos suficientes para ejecutarlas por eso quisiera saber si sql server express 2012 es compatible con visual studio community 2017 osea si puedo conectar los proyectos que desarrollo en visual studio community 2017 con una base de datos sql server express 2012.

    Si alguien me puede responder esta pregunta se lo agradeceria mucho 

    martes, 25 de septiembre de 2018 2:35

Respuestas

  • Todas las versiones de Visual Studio desde el 2002 hasta el 2017 son compatibles con todas las versiones de SQL Server desde la 2000 hasta la 2019 (e incluso anteriores si usas el proveedor OleDb en lugar del SqlClient).

    Ojo, al decir "compatibles" nos referimos a que en tiempo de ejecución los programas funcionan siempre que escribamos la cadena de conexión adecuada, y tengamos cuidado con las sentencias que escribimos para que sean compatibles con la versión que estamos usando. Si requieres usar los diseñadores y asistentes, en lugar de simplemente escribir el código, ahí sí que puedes encontrarte con algunas limitaciones si usas un Visual Studio muy moderno contra un SQL Server muy antiguo. Pero con la versión 2012 no deberías tener problemas.

    martes, 25 de septiembre de 2018 5:58

Todas las respuestas

  • Hola LuisAntonioRequena:

    Si puedes.

    Imagínate, que tuviésemos que depender obligatoriamente, que los desarrollos, fueran en la misma edición que el servidor de la base de datos, y cuando tuvieses un programa funcionando, y tus clientes, actualizasen el servidor, habría que hacer un nuevo programa para cada una de las versiones.

    Un saludo

    martes, 25 de septiembre de 2018 4:52
  • Todas las versiones de Visual Studio desde el 2002 hasta el 2017 son compatibles con todas las versiones de SQL Server desde la 2000 hasta la 2019 (e incluso anteriores si usas el proveedor OleDb en lugar del SqlClient).

    Ojo, al decir "compatibles" nos referimos a que en tiempo de ejecución los programas funcionan siempre que escribamos la cadena de conexión adecuada, y tengamos cuidado con las sentencias que escribimos para que sean compatibles con la versión que estamos usando. Si requieres usar los diseñadores y asistentes, en lugar de simplemente escribir el código, ahí sí que puedes encontrarte con algunas limitaciones si usas un Visual Studio muy moderno contra un SQL Server muy antiguo. Pero con la versión 2012 no deberías tener problemas.

    martes, 25 de septiembre de 2018 5:58