none
Ambiente de un aplicativo RRS feed

  • Pregunta

  • Me enviaron unas fuentes, y con ellas tengo que montar el ambiente en mi pc para empezar a programar, ¿Cómo lo hago? por favor me ayudan soy nuevo en esto
    viernes, 15 de noviembre de 2019 15:42

Respuestas

  • Ese error sale cuando tienes una solución que contiene un proyecto de tipo "librería de clases" y ese proyecto está marcado como "proyecto de inicio". No se puede iniciar desde una librería, solo se puede iniciar un ejecutable o un proyecto web. Fíjate en la Solución y si tiene varios proyectos, haz click-derecho sobre el proyecto de la aplicación web y selecciona "establecer como proyecto de inicio". El proyecto de inicio se ve en negrita dentro de la lista de proyectos de la solución.
    sábado, 16 de noviembre de 2019 10:52

Todas las respuestas

  • Este es mi web.config

    <?xml version="1.0" encoding="utf-8"?>

    <!-- Para obtener más información sobre cómo configurar la aplicación de ASP.NET, visite http://go.microsoft.com/fwlink/?LinkId=169433 --> <configuration> <configSections> <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 --> <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" /> </configSections> <connectionStrings /> <appSettings> <add key="webpages:Version" value="2.0.0.0" /> <add key="webpages:Enabled" value="false" /> <add key="PreserveLoginUrl" value="true" /> <add key="ClientValidationEnabled" value="true" /> <add key="UnobtrusiveJavaScriptEnabled" value="true" /> </appSettings> <!-- Para obtener una descripción de los cambios de web.config para .NET 4.5, vea http://go.microsoft.com/fwlink/?LinkId=235367. Los siguientes atributos se pueden establecer en la etiqueta <httpRuntime>. <system.Web> <httpRuntime targetFramework="4.5" /> </system.Web> --> <system.web> <compilation debug="true" targetFramework="4.5" /> <httpRuntime targetFramework="4.5.1" /> <authentication mode="None" /> <pages> <namespaces> <add namespace="System.Web.Helpers" /> <add namespace="System.Web.Mvc" /> <add namespace="System.Web.Mvc.Ajax" /> <add namespace="System.Web.Mvc.Html" /> <add namespace="System.Web.Optimization" /> <add namespace="System.Web.Routing" /> <add namespace="System.Web.WebPages" /> </namespaces> </pages> <profile defaultProvider="DefaultProfileProvider"> <providers> <add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" /> </providers> </profile> <membership defaultProvider="DefaultMembershipProvider"> <providers> <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" /> </providers> </membership> <roleManager defaultProvider="DefaultRoleProvider"> <providers> <add name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" /> </providers> </roleManager> <sessionState mode="InProc" customProvider="DefaultSessionProvider"> <providers> <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" /> </providers> </sessionState> </system.web> <system.webServer> <staticContent> <mimeMap fileExtension=".json" mimeType="application/json" /> </staticContent> <validation validateIntegratedModeConfiguration="false" /> <handlers> <remove name="ExtensionlessUrlHandler-ISAPI-4.0_32bit" /> <remove name="ExtensionlessUrlHandler-ISAPI-4.0_64bit" /> <remove name="ExtensionlessUrlHandler-Integrated-4.0" /> <add name="ExtensionlessUrlHandler-ISAPI-4.0_32bit" path="*." verb="GET,HEAD,POST,DEBUG,PUT,DELETE,PATCH,OPTIONS" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32" responseBufferLimit="0" /> <add name="ExtensionlessUrlHandler-ISAPI-4.0_64bit" path="*." verb="GET,HEAD,POST,DEBUG,PUT,DELETE,PATCH,OPTIONS" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness64" responseBufferLimit="0" /> <add name="ExtensionlessUrlHandler-Integrated-4.0" path="*." verb="GET,HEAD,POST,DEBUG,PUT,DELETE,PATCH,OPTIONS" type="System.Web.Handlers.TransferRequestHandler" preCondition="integratedMode,runtimeVersionv4.0" /> </handlers> </system.webServer> <runtime> <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"> <dependentAssembly> <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" /> <bindingRedirect oldVersion="1.0.0.0-2.0.0.0" newVersion="2.0.0.0" /> </dependentAssembly> <dependentAssembly> <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" /> <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.0.0.0" /> </dependentAssembly> <dependentAssembly> <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" /> <bindingRedirect oldVersion="1.0.0.0-2.0.0.0" newVersion="2.0.0.0" /> </dependentAssembly> <dependentAssembly> <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" /> <bindingRedirect oldVersion="0.0.0.0-6.0.0.0" newVersion="6.0.0.0" /> </dependentAssembly> <dependentAssembly> <assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35" culture="neutral" /> <bindingRedirect oldVersion="0.0.0.0-1.6.5135.21930" newVersion="1.6.5135.21930" /> </dependentAssembly> <dependentAssembly> <assemblyIdentity name="Antlr3.Runtime" publicKeyToken="eb42632606e9261f" culture="neutral" /> <bindingRedirect oldVersion="0.0.0.0-3.5.0.2" newVersion="3.5.0.2" /> </dependentAssembly> </assemblyBinding> </runtime> <entityFramework> <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework"> <parameters> <parameter value="v11.0" /> </parameters> </defaultConnectionFactory> <providers> <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" /> </providers> </entityFramework> </configuration>


    viernes, 15 de noviembre de 2019 16:34
  • Bien, para empezar, si tienes los fuentes de la solución completa, simplemente ábrelos en Visual Studio.

    Según el web.config, hay varias dependencias de librerías externas. Pero si fueron añadidas originalmente como paquetes NuGet y la solución incluye el fichero packages.config, entonces podrá descargar esos paquetes automáticamente y tendrás todas las librerías necesarias.

    Un problema adicional en este tipo de aplicaciones suele ser que se necesitan las bases de datos. Pero tu web.config no incluye ninguna cadena de conexión en la sección connectionStrings, cosa que es una buena indicación de que no necesita ninguna base de datos (salvo que tenga las cadenas de conexión escritas dentro del código, esperemos que no). Sí que necesitarás la base de datos para Membership, Roles y Profile, que según el .config usan el proveedor predeterminado. Si no lo has cambiado en el machine.config, este proveedor predeterminado usa un SQL Server Express sobre el equipo local. Suponiendo que tengas instalado el Express en el equipo, los proveedores predeterminados crean la base de datos de forma automática, así que en este sentido no necesitas hacer nada.

    Una vez que abras el fuente en Visual Studio, acude a las Propiedades del Proyecto y fíjate en qué servidor está configurado para el Debug. Si tuviese IIS, necesitarías instalar el IIS y ejecutar Visual Studio como Administrador para que te cree el sitio web. Pero si está configurado para ejecutarse en el IIS Express (y si no lo está puedes cambiarlo), entonces ese servidor debería haberse ya instalado junto con Visual Studio, por lo que todo debería funcionar inmediatamente sin necesidad de configurar nada más.

    viernes, 15 de noviembre de 2019 16:45
  • Me aparece el siguiente error: No se puede iniciar directamente con un tipo de resultado de biblioteca de clase.

    Para depurar este proyecto, agregue a esta solución un proyecto ejecutable que haga referencia al proyecto de biblioteca.Establezca el proyecto ejecutable como proyecto de inicio.

    viernes, 15 de noviembre de 2019 20:38
  • Ese error sale cuando tienes una solución que contiene un proyecto de tipo "librería de clases" y ese proyecto está marcado como "proyecto de inicio". No se puede iniciar desde una librería, solo se puede iniciar un ejecutable o un proyecto web. Fíjate en la Solución y si tiene varios proyectos, haz click-derecho sobre el proyecto de la aplicación web y selecciona "establecer como proyecto de inicio". El proyecto de inicio se ve en negrita dentro de la lista de proyectos de la solución.
    sábado, 16 de noviembre de 2019 10:52
  • Alberto gracias por tu ayuda. Saludos
    lunes, 18 de noviembre de 2019 15:23