none
FailOver de un nodo SQL no mueve el nodo AlwaysOn RRS feed

  • Pregunta

  • Buen día,

    Tengo el siguiente escenario.

    Server A: Windows 2012 Re - SQL Server 2014 SP 2

    Server B: Windows 2012 Re - SQL Server 2014 SP 2

    Ambos están en Cluster y a su vez tenemos otros 2 nodos (C y D) que también están en Cluster y todos forman un solo Cluster para poder tener AlwaysOn entre (A-B) y (C-D)

    Server C: Windows 2012 Re - SQL Server 2014 SP 2

    Server D: Windows 2012 Re - SQL Server 2014 SP 2

    Esta arquitectura es a fin de poder tener Alta Disponibilidad entre en server A y B y a su vez poder tener AlwaysOn al server C (que tiene alta disponibilidad con D)

    En éste escenario, el problema que se nos presenta es que al realizar un failover de A -> B, el servicio de SQL se mueve correctamente pero no realiza el failover del servicio de AlwaysOn quedando cruzados y por ende la DB no queda "Syncronizada".

    Es decir, movemos el Nodo del Servicio SQL y no se lleva consigo el nodo del servicio AlwaysOn

    ERROR:

    Cluster resource 'XXXXXXXXX' of type 'SQL Server Availability Group' in clustered role 'XXXXXXXXXX' failed.

    Based on the failure policies for the resource and role, the cluster service may try to bring the resource online on this node or move the group to another node of the cluster and then restart it.  Check the resource and group state using Failover Cluster Manager or the Get-ClusterResource Windows PowerShell cmdlet.

    This resource does not have all the nodes of the cluster listed as Possible Owners. The clustered role that this resource is a member of will not be able to start on any node that is not listed as a Possible Owner.

    Validating cluster resource IP Address: 172.20.x.xxx.

    Validating cluster resource Name: XXXXXX.

    This resource does not have all the nodes of the cluster listed as Possible Owners. The clustered role that this resource is a member of will not be able to start on any node that is not listed as a Possible Owner.

    Un detalle no menor, es que éste problema comenzó a dar luego de Instalar una KB en el nodo B. Pero el problema sigue pasando por más que la KB ya fue desinstalada.

    Al ser una Arquitectura algo compleja, es difícil de explicar solo con palabras la situación pero si alguno comprende el problema agradecería me brinde alguna alternativa para solucionarlo.

    muchas gracias

    jueves, 30 de agosto de 2018 14:37

Respuestas

  • Hola

    ¿Desea tener un grupo de servidores en ALWAYS ON distribuido?, eso es, tener HA local y DRP en otros nodos y que esos a su vez funcionen como HA...

    Hay una liga de  Microsoft donde se describe su problema

    https://support.microsoft.com/en-us/help/313882/error-messages-occur-if-you-try-to-bring-a-cluster-group-online-after

    jueves, 30 de agosto de 2018 15:53

Todas las respuestas

  • Hola

    ¿Desea tener un grupo de servidores en ALWAYS ON distribuido?, eso es, tener HA local y DRP en otros nodos y que esos a su vez funcionen como HA...

    Hay una liga de  Microsoft donde se describe su problema

    https://support.microsoft.com/en-us/help/313882/error-messages-occur-if-you-try-to-bring-a-cluster-group-online-after

    jueves, 30 de agosto de 2018 15:53
  • Buen día,

    El problema fue solucionado volviendo atrás un cambio que el soporte de Microsoft me había recomendado hacer a nivel de registry.

    Básicamente me pidieron que habilite el Workaround del siguiente link https://support.microsoft.com/es-ar/help/2491214/non-yielding-scheduler-error-and-sql-server-2008-or-sql-server-2008-r2 y al no encontrar el problema volvimos para atrás dicho cambio y AlwaysOn comenzó a funcionar nuevamente.

    De todas formas, muchas gracias por su ayuda.
    Saludos!

    miércoles, 12 de septiembre de 2018 12:18