none
Error: Se produjo una excepción al ejecutar las extensiones especificadas en el archivo de configuración. ---> Se excedió la longitud de solicitud máxima. RRS feed

  • Pregunta

  • Hola, he estado viendo este mismo error y en todos lados proponen la misma solución, modificar/añadir en el web.config la clave httpruntime executiontimeout aumentando los segundos que hay por defecto. Pero no me funciona.

    Tengo un proceso realizado en vs2005 c#, que llama a un web service (vs2005 vb), pasándole gran cantidad de datos. El web service los procesa y devuelve también datos. Las 3 primeras llamadas al ws dentro del proceso, van bien, pero la última se corta, y aunque el webservice sigue ejecutándo la orden, el proceso que lo llama se corta. No debería tardar más de 5 minutos.

    También he probado con la clave maxRequestLength por si fuera problema de la cantidad de datos que le paso al ws, pero tampoco funciona. La clave 'debug' del web.config la tengo a false.

    ¿Alguna idea o camino por donde poder seguir investigando?

    Gracias!


    jueves, 19 de mayo de 2016 10:42

Respuestas

  • Encontré la solución, lo estaba enfocando mal, el problema no estaba en el WS, era en el proceso que consume el WS al que tenía que darle tiempo. Le he indicado lo siguiente:

    Service1 obj = new Service1();
    obj.TimeOut = -1; // infinite time out.

    Lo encontré aqui: https://msdn.microsoft.com/es-es/library/47096yt2.aspx

    Muchísimas gracias por vuestra aportación.

     
    • Marcado como respuesta MARIAJO1 jueves, 19 de mayo de 2016 12:03
    jueves, 19 de mayo de 2016 12:02

Todas las respuestas

  • hola. Puedes mostrarnos la configuracion de tu cliente? El que consume el servicio. Puede que allí este el problema de configuración.

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos

    jueves, 19 de mayo de 2016 10:52
    Moderador
  • Aquí está.

    app.config del que consume:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
    <configSections>
    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
      <section name="ConsultaEstadosSigma.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
      <section name="ConsultaEstadosSigmaVB.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
    </configSections>
    <appSettings>
    <!-- CADENA DE CONEXION (BD PCS_TEST)-->
    <add key="cnnString" value=""></add>
    <!-- DIRECTORIOS -->
    <add key="DirLog" value="C:\PROYECTOS\NET2005\PCS\ConsultaEstadosSigma\Log"/>
    <add key="FileLog" value="Estados_Sigma"/>
    <add key="DirFile" value="C:\PROYECTOS\NET2005\PCS\ConsultaEstadosSigma\File\"/>
    <!-- Si se quiere ampliar la informacion del log (1). Si se quiere poca inf. (0)-->
    <add key="Trazas" value="1"></add>

    <add key="WebService_SIGMA.PCS_SIGMA" value="http://localhost:1517/Ws_pcs_sigma/PCS_SIGMA.asmx?wsdl"/>

    <add key="Proxy_Salida" value="" />
    <add key="Puerto_Salida" value="80" />
    <!--Datos para el servidor de correo-->
    <add key="ServMail" value="" />
    <add key="PtoMail" value="" />
    <add key="UserMail" value="" />
    <add key="PassMail" value="" />
    <!--Para indicar más de un mail, se separan por comas -->
    <add key="Mail" value=""/>
    </appSettings>
     <applicationSettings>
      <ConsultaEstadosSigma.Properties.Settings>
       <setting name="ConsultaEstadosSigma_Call_PCS_SIGMA_Service" serializeAs="String">
        <value>http://localhost:1517/Ws_pcs_sigma/PCS_SIGMA.asmx</value>
       </setting>
      </ConsultaEstadosSigma.Properties.Settings>
     </applicationSettings>
     </configuration>

    web.config de WS:

    <?xml version="1.0"?>
    <configuration>
    <appSettings>
    <add key="cnnString" value="Data Source=SIGMA10;User Id=sigmapru;Password=sigmapru;"/>
    <add key="DirLog" value="Log"/>
    <add key="FileLog" value="PCS_SIGMA"/>
    <!--2011-PCS-17-->
    <add key="FileLogEstados" value="PCS_SIGMA_ESTADOS"/>
    <add key="Proxy" value=""/>
    <add key="Puerto" value="80"/>
    <add key="Trazas" value="1"/>
    <!--Para indicar más de un mail, se separan por comas -->
    <add key="Mail" value=""/>
    </appSettings>
    <system.web>
    <httpRuntime maxRequestLength="102400" executionTimeout="3600"/>
    <compilation debug="false">
    <assemblies>
    <add assembly="System.Data.OracleClient, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    </assemblies>
    </compilation>
    </configuration>

    Gracias.


    jueves, 19 de mayo de 2016 11:02
  • hola

     Se excedió la longitud de solicitud máxima

    es correcto que configures el maxRequestLength

    la pregunta seria que valor has indicado? quizas aun el valor que pones queda corto

    si comparas los datos de las llamadas que funcionan y esta ultima que no lo hace, puedes ver que el mensaje es mas grande?

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    jueves, 19 de mayo de 2016 11:55
  • Encontré la solución, lo estaba enfocando mal, el problema no estaba en el WS, era en el proceso que consume el WS al que tenía que darle tiempo. Le he indicado lo siguiente:

    Service1 obj = new Service1();
    obj.TimeOut = -1; // infinite time out.

    Lo encontré aqui: https://msdn.microsoft.com/es-es/library/47096yt2.aspx

    Muchísimas gracias por vuestra aportación.

     
    • Marcado como respuesta MARIAJO1 jueves, 19 de mayo de 2016 12:03
    jueves, 19 de mayo de 2016 12:02