none
Error el Provedor de Access no esta disponible. RRS feed

  • Pregunta

  • Saludos cordiales a todos.

    Espero puedan ayudarme a solucionar el siguiente problema.

    Tengo Windows 8 y Office 2013. Ambos de 64BITS

    Estoy desarrollando una aplicación Windows Form, pero al ejecutarla y tratar de conectarme a la BDD este me envia el siguente error:  El proveedor 'Microsoft.ACE.Oledb.4.0' no está registrado en el equipo local.

    He leido que debo debo de copilar el proyecto en la plataforma x86 desde configuration manager. Ya lo hice pero aun me sigue enviando el mismo error. Debo descargar algo adicional....?

    La BDD no la tengo integrada al proyecto. Cabe mencionar que la aplicacion la estoy desarrollando para trabajar con Office de 32BITS. Espero puedan ayudarme.

    De antemano gracias.

    Saludos

    DS


    Aprendiz de todos maestro de nadie. Saludos desde Cd. Juarez Chihuahua Mexico. DS.

    domingo, 6 de marzo de 2016 6:18

Respuestas

  • "Dany Solis" escribió:

    > Estoy desarrollando una aplicación Windows Form, pero al ejecutarla y tratar de
    > conectarme a la BDD este me envia el siguente error:  El proveedor
    > 'Microsoft.ACE.Oledb.4.0' no está registrado en el equipo local.

    Hola, Dany:

    Obtienes ese error porque a día de hoy NO EXISTE ningún proveedor de datos con ese nombre.

    Existe el proveedor Microsoft.Jet.OLEDB.4.0, que lo puedes utilizar con bases de datos que tengan formato de Access hasta la versión 2003 (*.mdb), y el proveedor Microsoft.ACE.OLEDB.12.0, para bases de datos con formato Access 2007 o superior (*.accdb), aunque también lo puedes utilizar con archivos de versiones previas de Access.

    Un saludo


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.

    • Marcado como respuesta Dany Solis lunes, 7 de marzo de 2016 19:53
    domingo, 6 de marzo de 2016 7:29
    Moderador

Todas las respuestas

  • "Dany Solis" escribió:

    > Estoy desarrollando una aplicación Windows Form, pero al ejecutarla y tratar de
    > conectarme a la BDD este me envia el siguente error:  El proveedor
    > 'Microsoft.ACE.Oledb.4.0' no está registrado en el equipo local.

    Hola, Dany:

    Obtienes ese error porque a día de hoy NO EXISTE ningún proveedor de datos con ese nombre.

    Existe el proveedor Microsoft.Jet.OLEDB.4.0, que lo puedes utilizar con bases de datos que tengan formato de Access hasta la versión 2003 (*.mdb), y el proveedor Microsoft.ACE.OLEDB.12.0, para bases de datos con formato Access 2007 o superior (*.accdb), aunque también lo puedes utilizar con archivos de versiones previas de Access.

    Un saludo


    Enrique Martínez Montejo
    [MS MVP - Visual Studio y Tecnologías de Desarrollo]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, se inteligente y activa la instrucción
    Option Strict.

    • Marcado como respuesta Dany Solis lunes, 7 de marzo de 2016 19:53
    domingo, 6 de marzo de 2016 7:29
    Moderador
  • Gracias Enrique.

    Ese era el error gracias por la ayuda.

    Saludos

    DS


    Aprendiz de todos maestro de nadie. Saludos desde Cd. Juarez Chihuahua Mexico. DS.

    lunes, 7 de marzo de 2016 19:53