none
configurar la cadena conexión RRS feed

  • Pregunta

  • Hola.

    Estoy haciendo varias pruebas y me sería muy útil tener la cadena de conexión en el archivo de configuración del proyecto, pero me da un error al intentar asignarle la cadena que se encuentra en el setting, no se si es porque no es posible o porque no lo estoy colocando como es debido.

    Tengo la cadena de conexión en My.Settings.BD2ConnectionString2

     

    por lo que me gustaría ponerle dicho parámetro y reemplazar la siguiente constante "cs" para en vez de que tenga la cadena, que tenga la ruta a My.Settings.BD2ConnectionString2.

     

        Public Const cs As String = "Data Source=PCVISTA\SQLEXPRESS;" & _

                         "Initial Catalog=BDatos;" & _

                         "Integrated Security=True"

        Dim conexion As New SqlConnection(cs)

     

    y lo que pretendo hacer es esto:

     Public Const cs As String = My.Settings.BD2ConnectionString2.

        Dim conexion As New SqlConnection(cs)

     

    pero me da un error... ¿alguien sabe como puedo hacerlo?


     


    domingo, 9 de mayo de 2010 19:47

Respuestas

  • hola

    el tema es que estas intentand asignar un valor variable en una constante

    solo quita donce dice Const , y funcionara

     

    Public cs As String = My.Settings.BD2ConnectionString2

    Dim conexion As New SqlConnection(cs)

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta poliems domingo, 9 de mayo de 2010 20:51
    domingo, 9 de mayo de 2010 20:06

Todas las respuestas

  • hola

    el tema es que estas intentand asignar un valor variable en una constante

    solo quita donce dice Const , y funcionara

     

    Public cs As String = My.Settings.BD2ConnectionString2

    Dim conexion As New SqlConnection(cs)

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta poliems domingo, 9 de mayo de 2010 20:51
    domingo, 9 de mayo de 2010 20:06
  • Ups...

     

    Muchas gracias...

    domingo, 9 de mayo de 2010 20:52