none
Problemas cuando mando a imprimir con Crystal Reports RRS feed

  • Pregunta

  •       Dim Adp As New SqlClient.SqlDataAdapter
            Dim Dt As New DataTable
            Dim Cmd As New SqlClient.SqlCommand
            Dim DtBusqueda As New DataTable
            Dim Ssql As String
            Dim Informe As New ReportDocument
            Dim Formula As String
            Dim Dir As String = dirReportes
    
            Try
    
                Ssql = "SELECT elementos.id_elemento, elementos.descripcion, detalle_entrega.cantidad, organismo.Descripcion," _
                   & "entrega.id_entrega FROM ((detalle_entrega INNER JOIN elementos ON detalle_entrega.id_elemento=elementos.id_elemento) " _
                & " INNER JOIN entrega ON detalle_entrega.id_entrega=entrega.id_entrega) INNER JOIN organismo ON entrega.id_organismo=organismo.id_organismo" _
                & " where entrega.impreso=0"
    
    
                Adp = New SqlClient.SqlDataAdapter(Ssql, Conexion)
                Adp.Fill(Dt)
    
                Dir = Dir & "\notaProvision.rpt"
    
    
    
                ' Formula = "{entrega.id_entrega}=" & Dt.Rows(i).Item("id_entrega")
                Informe.Load(Dir, OpenReportMethod.OpenReportByDefault)
                Informe.SetDataSource(Dt)
    
                For i = 0 To Dt.Rows.Count - 1
    
                    Informe.RecordSelectionFormula = "{entrega.id_entrega}=" & Dt.Rows(i).Item("id_entrega")
                    Informe.Refresh()
                    Informe.PrintToPrinter(2, False, 0, 0)
                    Ssql = "update entrega set impreso=1 where id_entrega=" & Dt.Rows(i).Item("id_entrega")
                    Cmd.Connection = Conexion
    
                    Cmd.CommandText = Ssql
                    Cmd.ExecuteNonQuery()
    
                Next

    Estimados.

    Ante todo gracias por su tiempo!.

    Les cuento mi inconveniente, resulta que filtro todo bien y el CR toma el DT correctamente...ahora cuando llega a printToPtinter sale un error que me dice no se puede conectar con el servidor...., no se que puede llegar a estar fallando.

    Tengo en otro lado la misma metodología y funciona muy bien.

    Gracias!!!! 

    • Cambiado Enrique M. Montejo jueves, 21 de agosto de 2014 15:46 Pregunta relacionada con Crystal Reports.
    martes, 19 de agosto de 2014 15:45