none
Cluster SQL 2008 y 2016 sobre Windows Server 2012 RRS feed

  • Pregunta

  • Buenos días

    he conseguido montar un cluster multinstancia de sql serve 2008r2 standard y sql server 2016 standard sobre windows server 2012.

    primero he instalado la instancia de sql server 2008 y el servicio funciona perfectamente. 

    En segundo lugar he instalado sql server 2016 pero el servicio no me arranca. no sé el pro qué. ( en servicios , el servicio de SQL Server Agente se inicia y al minuto se vuelve a parar , lo he ejecutado con distintos usuarios administradores y administradores del dominio así como como con cuentas locales y del sistema y no consigue arrancar...)


    adjunto algunos ids de error


    cuando intento iniciar el rol de  sql server en el administración del clúster de Microsoft, me indica: no se pudo poner en conexión el grupo' sql server <intancia>' código de error 0x800713cf--> no se puede  poner en línea el recurso del clúster, el nodo propietario no puede ejecutar este recurso...

    id 1254:  el rol del clúster `sql server <intancia>' superó el umbral de conmutación por error. ...

    id 1205: el servicio de clúster no pude conectar o desconectar completamente el rol del cluster 'sql server <intancia> puede que uno o más recursos  tenga un estado de error...

    gracias por vuestra ayuda ;)

    edito: he he dado a reparar la instancia, te lo repara, te indica que lo ha reparado pero sigue igual...

    • Editado Juaniki86 viernes, 24 de marzo de 2017 15:35
    • Cambiado Moderador M viernes, 24 de marzo de 2017 16:17 SQL Server related
    viernes, 24 de marzo de 2017 9:07

Respuestas

  • Hola.

    Retomando el tema, un par de preguntas para validar:

    1) Entiendo que instalaste primero SQL Server 2008 y luego SQL Server 2016. ¿Ambas instalaciones las hiciste con la instancia por defecto o alguna de ellas es una instancia nombrada?

    2) Cuándo instalaste SQL Server 2008, ¿validaste que pudiese hacer FAILOVER hacia el otro nodo? De igual manera, hiciste FAILBACK hacia el nodo primario?

    Saludos,


    Guillermo Taylor F.
    MVP Data Platform & IT Pro
    Mi Blog

    martes, 11 de abril de 2017 12:00

Todas las respuestas

  • Hola.

    Por favor compartenos una imagen de como están los servicios de SQL Server, pero vistos desde la aplicación de sistema operativo Cluster Manager.

    Saludos,


    Guillermo Taylor F.
    MVP Data Platform & IT Pro
    Mi Blog

    sábado, 25 de marzo de 2017 21:18
  • Hola.

    Por favor compartenos una imagen de como están los servicios de SQL Server, pero vistos desde la aplicación de sistema operativo Cluster Manager.

    Saludos,


    Guillermo Taylor F.
    MVP Data Platform & IT Pro
    Mi Blog

    Gracias guillermo. no he podido responder antes . no se muy bien a qué se refiere, pero te adjunto mi situación tal y como está ahora:


    los servicios están así:

    y el servicio que no me levanta: sql server agent (sql03) . me inicia y al minuto se para. lo he probado a arranar con cuenta adm local, cuenta adm del dominio...el caso es que con este servicio así, no puedo automatizar tareas

    y esta es mi situación actual.

    el failover funciona perfectamente, todo va bien salvo el servicio agent sql...

    muchas gracias por vuestra ayuda ;)


    • Editado Juaniki86 lunes, 27 de marzo de 2017 13:32
    lunes, 27 de marzo de 2017 7:35
  • Saludos

    Busca el log de error del agente, normalmente este dice mas y porque fallo, básicamente está diciendo que no alcanza a su SQL Server (motor) y por eso se detiene pero necesitamos un poco mas de informacion.

    lunes, 27 de marzo de 2017 14:08
  • Saludos

    Busca el log de error del agente, normalmente este dice mas y porque fallo, básicamente está diciendo que no alcanza a su SQL Server (motor) y por eso se detiene pero necesitamos un poco mas de informacion.

    adjunto log...

    gracias por su ayuda

    lunes, 27 de marzo de 2017 14:22
  • Saludos

    Eso es el event viewer, me refiero al log de sqlagent, este lo debes de encontrar en una carpeta parecida a

    E:\MSSQL13.MSSQLSERVER\MSSQL\Log

    O en Program Files normalmente si lo dejaste por default.

    C:\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\Log

    lunes, 27 de marzo de 2017 14:30
  • Saludos

    Eso es el event viewer, me refiero al log de sqlagent, este lo debes de encontrar en una carpeta parecida a

    E:\MSSQL13.MSSQLSERVER\MSSQL\Log

    O en Program Files normalmente si lo dejaste por default.

    C:\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\Log

    esto es lo último que hay ( desde las 9 de esta mañana.... )


    lunes, 27 de marzo de 2017 14:44
  • Saludos

    Ese es el del engine :P, necesitamos el del agent, dice algo como agentlog o algo asi, no lo recuerdo de buenas a primeras, podrías buscar por favor.

    lunes, 27 de marzo de 2017 14:46
  • Saludos

    Ese es el del engine :P, necesitamos el del agent, dice algo como agentlog o algo asi, no lo recuerdo de buenas a primeras, podrías buscar por favor.

    disculpa jajaja ahi llevas

    

    lunes, 27 de marzo de 2017 14:59
  • Pues básicamente dice lo mismo falla la conexión

    En el nodo que estas esta apuntando el agente a la instancia correcta y al servicio correcto=

    lunes, 27 de marzo de 2017 15:01
  • Pues básicamente dice lo mismo falla la conexión

    En el nodo que estas esta apuntando el agente a la instancia correcta y al servicio correcto=

    gracias. ..

    cómo puedo cambiar que el agente apunte a un servidor u a otro entonces???

    gracias

    lunes, 27 de marzo de 2017 15:05
  • Saludos

    El agent es local y siempre deberia de apuntar... a su servidor local no al cluster name si mal no me acuerdo pero dejame veo

    segun lo que veo en tu considugracion deberia ser nodo2.bes02 pero apunta como bes02\best02 cambiaste en algun momento el nombre de tu servidor?

    lunes, 27 de marzo de 2017 15:15
  • Saludos

    El agent es local y siempre deberia de apuntar... a su servidor local no al cluster name si mal no me acuerdo pero dejame veo

    segun lo que veo en tu considugracion deberia ser nodo2.bes02 pero apunta como bes02\best02 cambiaste en algun momento el nombre de tu servidor?

    no. nunca se cambió el nombre.

    bes02 responde a ping con la ip "de servicio" que se le configuró.

    lunes, 27 de marzo de 2017 15:17
  • Por curiosidad entra al configuration manager del nodo que falla y dame una captura de los servicios. 

    lunes, 27 de marzo de 2017 15:30
  • Por curiosidad entra al configuration manager del nodo que falla y dame una captura de los servicios. 



    • Editado Juaniki86 martes, 28 de marzo de 2017 8:04
    martes, 28 de marzo de 2017 8:03
  • Saludos Juan

    De buenas a primeras no se me ocurre que esta pasando, si esto funciono antes posiblemente abrir un caso con Microsoft, de momento ando un poco ocupado y no puedo prometerte ayuda en tiempo real lo lamento.

    martes, 28 de marzo de 2017 13:34
  • Saludos Juan

    De buenas a primeras no se me ocurre que esta pasando, si esto funciono antes posiblemente abrir un caso con Microsoft, de momento ando un poco ocupado y no puedo prometerte ayuda en tiempo real lo lamento.

    gracias igualmente.

    he encontrado esto:

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/639c81c2-7908-48e9-a0cd-613ff251a93e/sql-2008r2-sp2-spamming-application-log-on-active-node?forum=sqldisasterrecovery

    acabo de encotrar lo siguiente:

    This issue has been fixed in Cumulative update package 3 for SQL Server 2008 R2 Service Pack 2 andCumulative update 3 for SQL Server 2012

    http://support.microsoft.com/kb/2718920

    vooy a probar esto a ver

    martes, 28 de marzo de 2017 13:43
  • Hola Juaniki86,

    Gracias por visitar los foros, según podemos observar en tu ultima entrada realizarías algunas pruebas que quizá te ayudarían a resolver tu consulta, por lo cual preguntarte, ¿Haz podido resolver tu problema?, de ser así sería de gran ayuda para futuros usuarios pudieras comentar la forma en la cual pudiste resolverlo.

    Saludos

    Joyce

    __________________________________________________________________________________________
    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, hace que sea más fácil para los otros visitantes encontrar la solución  más tarde. Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal  cual" y no implica ninguna responsabilidad de parte de Microsoft.

    lunes, 3 de abril de 2017 16:43
    Moderador
  • Hola Juaniki86,

    Gracias por visitar los foros, según podemos observar en tu ultima entrada realizarías algunas pruebas que quizá te ayudarían a resolver tu consulta, por lo cual preguntarte, ¿Haz podido resolver tu problema?, de ser así sería de gran ayuda para futuros usuarios pudieras comentar la forma en la cual pudiste resolverlo.

    Saludos

    Joyce

    __________________________________________________________________________________________
    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, hace que sea más fácil para los otros visitantes encontrar la solución  más tarde. Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal  cual" y no implica ninguna responsabilidad de parte de Microsoft.

    hola Joyce

    nada. aún no ha sido posible. sigo viendo que puedo hacer

    martes, 4 de abril de 2017 7:04
  • Hola.

    Retomando el tema, un par de preguntas para validar:

    1) Entiendo que instalaste primero SQL Server 2008 y luego SQL Server 2016. ¿Ambas instalaciones las hiciste con la instancia por defecto o alguna de ellas es una instancia nombrada?

    2) Cuándo instalaste SQL Server 2008, ¿validaste que pudiese hacer FAILOVER hacia el otro nodo? De igual manera, hiciste FAILBACK hacia el nodo primario?

    Saludos,


    Guillermo Taylor F.
    MVP Data Platform & IT Pro
    Mi Blog

    martes, 11 de abril de 2017 12:00