none
como puedo solucionar este error? RRS feed

  • Pregunta

  • Error del analizador

    Descripción: Error al analizar el recurso requerido para dar servicio a esta solicitud. Revise los detalles de error de análisis específicos y modifique el archivo de código fuente en consecuencia.

    Mensaje de error del analizador: La clase base incluye el campo 'CrystalReportViewer1', pero su tipo (CrystalDecisions.Web.CrystalReportViewer) no es compatible con el tipo de control (CrystalDecisions.Web.CrystalReportViewer).

    Error de código fuente:

    Línea 41:     <br />
    Línea 42:     <br />
    Línea 43:     <CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" 
    Línea 44:       AutoDataBind="True" GroupTreeImagesFolderUrl="" Height="50px" 
    Línea 45:       ReportSourceID="CrystalReportSource1" ToolbarImagesFolderUrl="" 

    Archivo de origen: /REPORTES/r-presentacion.aspx    Línea: 43

    "
    viernes, 21 de enero de 2011 15:11

Respuestas

  • hola, revisa en tu webconfig la version de las librerias, supongo q estas usando la version que se integra con el visualstudio, asi q debes tener en version la numero 13, y en la parte superior de wtu pagina debes tener esto:

    <%@ Register assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" namespace="CrystalDecisions.Web" tagprefix="CR" %>

     

    como ves tmb se hace referencia a la version 13... te lo comento pq cuandop use la beta la version era la 14, y cuando actualize a la version final tuve q cambiar manualmente a la 13


    Julio Avellaneda
    Blog !!

    • Marcado como respuesta divad_82 viernes, 28 de enero de 2011 16:56
    miércoles, 26 de enero de 2011 14:17
  • esto donde sucede en tu pc o cuando haces el deploy al sitio ?

    has validado que el registribuible de Crystal se haya puesto en ese server  yque sea de uan version compatible con el VS que usas ?

     

    Business Objects - Crystal Reports Runtime Packages

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta Eduardo PorteschellerModerator miércoles, 26 de enero de 2011 12:51
    • Desmarcado como respuesta divad_82 viernes, 28 de enero de 2011 16:56
    • Marcado como respuesta divad_82 viernes, 28 de enero de 2011 16:56
    viernes, 21 de enero de 2011 15:16

Todas las respuestas

  • esto donde sucede en tu pc o cuando haces el deploy al sitio ?

    has validado que el registribuible de Crystal se haya puesto en ese server  yque sea de uan version compatible con el VS que usas ?

     

    Business Objects - Crystal Reports Runtime Packages

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta Eduardo PorteschellerModerator miércoles, 26 de enero de 2011 12:51
    • Desmarcado como respuesta divad_82 viernes, 28 de enero de 2011 16:56
    • Marcado como respuesta divad_82 viernes, 28 de enero de 2011 16:56
    viernes, 21 de enero de 2011 15:16
  • hola leandro vas a decir que siempre te molesto pero lo que pasa es que mira tengo el vs 2010 y hasta apenas pude instalarle el cr sale pero no se ni que onda para visualizar los reportes me pordrias ayudar y lo que me aparece es en la maquina donde estoy desarrollando la web pag

     

    lunes, 24 de enero de 2011 14:46
  • sucede en mi pc al compilarlo y la verdad ya me esta hartando este errorpor que es lo unico que me frena para poder probrar el proyecto e intentar continuar con los como 30 reportes que nesesitosi me pudieras echar la mano te lo agradeceria

    miércoles, 26 de enero de 2011 14:12
  • hola, revisa en tu webconfig la version de las librerias, supongo q estas usando la version que se integra con el visualstudio, asi q debes tener en version la numero 13, y en la parte superior de wtu pagina debes tener esto:

    <%@ Register assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" namespace="CrystalDecisions.Web" tagprefix="CR" %>

     

    como ves tmb se hace referencia a la version 13... te lo comento pq cuandop use la beta la version era la 14, y cuando actualize a la version final tuve q cambiar manualmente a la 13


    Julio Avellaneda
    Blog !!

    • Marcado como respuesta divad_82 viernes, 28 de enero de 2011 16:56
    miércoles, 26 de enero de 2011 14:17
  • hola, revisa en tu webconfig la version de las librerias, supongo q estas usando la version que se integra con el visualstudio, asi q debes tener en version la numero 13, y en la parte superior de wtu pagina debes tener esto:

    <%@ Register assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" namespace="CrystalDecisions.Web" tagprefix="CR" %>

     

    como ves tmb se hace referencia a la version 13... te lo comento pq cuandop use la beta la version era la 14, y cuando actualize a la version final tuve q cambiar manualmente a la 13


    Julio Avellaneda
    Blog !!


    les contare mi experiencia por default no puedo correr cReports en V10 asi que me fui al link que me sugiere VS e instale el CR pero me marcaba el mismo error expuesto en la pregunta cheque tu comentario y en mi caso en Version era igual a

    10.5.3700.0 (en la cabecera de mi webform)

     asi que lo que hice fue que me fui al web config, copie la version=13.0.2000.0 y despues me fui al la cabecera de mi pagina web  y lo cambie por 

    13.0.2000.0 y asi corre


    Rafa Gonzalez
    lunes, 21 de noviembre de 2011 22:17
  • muy buena respuesta julito me sirvio de mucho gracias.. voy a seguirte en tu blog..

    saludos desde guatemala.

    viernes, 30 de noviembre de 2012 21:01