none
Aplicación no muestra imágenes en algunos botones RRS feed

  • Pregunta

  • Saludos tengo una aplicación en vb 2008 con unos botones los cuales tiene una imagen,

    con algunos botones me muestra la imagen en modo de diseño pero en modo de ejecución no me las muestras.

    cual creen que pueda ser la solución ya he probado el tip de generar de nuevo el proyecto,  también he ido a la carpeta bin\debug y elimino todo su contenido después ejecuto la aplicación desde el Vs y nada de mostrar las imágenes

    Diseñador

    en tiempo de Ejecución

    los botones tienen la propiedad flatstyle = flat

    Gracias de antemano


    Arismendy Rodríguez

    martes, 6 de mayo de 2014 15:46

Todas las respuestas

  • Hola.

    El problema que indicas parece estar relacionado con la forma que tienes de indicar la ruta de la imagen a mostrar.

    De forma practica, y solo de cara a averiguar cual es el problema, puedes copiar las imágenes a una ruta local absoluta (c:\TEMP) y hacer que esas imágenes que no se te ven se carguen desde esa ruta temporal. (Deberia de funcionarte).

    Una practica habitual, es incluir las imágenes en una biblioteca de recursos (resx) y que todas las imágenes se carguen desde esa librería de recursos.

    Espero te sirva de ayuda.

    Un saludo.

    martes, 13 de mayo de 2014 14:36
  • Bueno lo hago incluyendo las imágenes en una biblioteca de recursos (resx) como es debido, de todas formas hace los mismo, leí en otro hilo por ahi que creando una plantilla del proyecto funcionaria de hecho así lo hice y ya funciona.

    Arismendy Rodríguez

    martes, 13 de mayo de 2014 19:37