none
Conectar cliente sql con servidor SQL 2008 RRS feed

  • Pregunta

  • Hola a todos. He instalado el SQL Server 2008 en una máquina que tiene instalado el windows server 2008 y cuando intento conectar desde otra máquina me lanza un mensaje de que no se ha encontrado el servidor o se ha denegado el acceso. Por ejemplo: mi instancia se llama SQL2008 y desde la pc cliente trato de ingresar usando el analizador de consulta o el administrador del SQL 2008 colocando la dirección server\SQL2008 o por DIR IP 192.168.1.10\SQL2008 pero no logro conectar. Ya habilité las canalizaciones por nombre y por IP en el servidor. También intenté crear un alias desde el cliente pero no funciona al tratar de conectar me sigue saliendo el mismo mensaje. Alguien podría darme una mano e indicarme en que podría estar fallando? Tengo que habilitar algun servicio?
    jueves, 24 de febrero de 2011 18:18

Respuestas

  • Hola,


    Siguiendo lo que indica Alberto, puedes verificar estos puntos:

     

    1. Que tengas habilitado el protocolo TCP/IP, eso lo ves en SQL Server Configuration Manager.

    2. En la computadora local abre el SQL Server Management Studio, ve a las propiedades del servidor, ve al tab de "Connections" y habilita la opción que dice "Allow remote connections to this server"


    3. Agrega el puerto 1433 (por defecto) en las excepciones del Firewall de Windows, también agrega como excepciones del Firewall: sqlservr.exe y sqlbrowser.exe


    4. Si quieres intenta configurando el Alias siguiendo esta guía: IT Learn - Creación de Alias en SQL Server

    5. Verifica que los servicios SQL Server y SQL Server Browser estén iniciados en SQL Server Configuration Manager.

     

    Espero que te sirva.


    Willy Taveras.-
    República Dominicana


    IT Learn - Learning Together

    jueves, 24 de febrero de 2011 20:10
    Moderador
  •  Hola.

     Asegurate que usas para conectarte: Microsoft SQL Server 2008 Management Studio, y no una versión anterior.

     Si has configurado SQL Server, para conectarte por el puerto 1433, desde el equipo cliente realiza un Telnet por el puerto 1433 al servidor de base de datos.

    Desde el CMD:
     Telnet 102.168.1.10 1433
    o
     Telnet  server 1433

    si todo es correcto la ventana del CMD, se quedará en negro, con el cursor parpadenado.

    Configurar Firewall de Windows para permitir el acceso a SQL Server: http://msdn.microsoft.com/es-es/library/cc646023.aspx Ejemplo para el port 1433:

    netsh firewall set portopening protocol = TCP port = 1433 name = SQLInstancedefault mode = ENABLE scope = SUBNET profile = CURRENT


    Verifica en Configuration Tools -> Sql Server Configuration Manager -> SQL Server Network Configuration y habilita el protocolo TCP/IP.

    Verifica en Management Studio -> propiedades sobre la instancia -> Opciones -> permitir las conexiones remotas.


     Norman M. Pardell 

    ||Microsoft Certified IT Professional|| Database Administrator. Database Developer. SQL Server 2008

    jueves, 24 de febrero de 2011 23:01

Todas las respuestas

  • Probablemente el problema esté en el cortafuegos del Windows Server 2008. De forma predeterminada, te cerrará el acceso al puerto de SQL Server. Tendrás que entrar en las herramientas administrativas y configurar el cortafuegos para que permita el acceso desde el exterior al SQL Server.

    Aparte de eso, el propio SQL Server también hay que configurarlo para que admita conexiones desde el exterior, pero por lo que comentas, eso ya lo has hecho.

    Si se llega a conectar con el servidor, pero lo que falla son las credenciales, asegúrate de que son correctas. Si los dos equipos no están en el mismo dominio, habilita la autenticación en modo Mixto (Windows y SQL Server), crea en SQL Server un usuario con su password, y usa esos datos para conectarte desde el cliente.

     

    jueves, 24 de febrero de 2011 19:34
  • Hola,


    Siguiendo lo que indica Alberto, puedes verificar estos puntos:

     

    1. Que tengas habilitado el protocolo TCP/IP, eso lo ves en SQL Server Configuration Manager.

    2. En la computadora local abre el SQL Server Management Studio, ve a las propiedades del servidor, ve al tab de "Connections" y habilita la opción que dice "Allow remote connections to this server"


    3. Agrega el puerto 1433 (por defecto) en las excepciones del Firewall de Windows, también agrega como excepciones del Firewall: sqlservr.exe y sqlbrowser.exe


    4. Si quieres intenta configurando el Alias siguiendo esta guía: IT Learn - Creación de Alias en SQL Server

    5. Verifica que los servicios SQL Server y SQL Server Browser estén iniciados en SQL Server Configuration Manager.

     

    Espero que te sirva.


    Willy Taveras.-
    República Dominicana


    IT Learn - Learning Together

    jueves, 24 de febrero de 2011 20:10
    Moderador
  • Hola Alberto, gracias por la respuesta. Estoy chequeando el Firewall y ya tengo habilitado para que el SQL Server pueda acceder al servidor. Tiene la siguiente configuracion: Perfil = Dominio, Publico; Habilitadio= Si; Accion = Permitir; Invalidar = No; Programa = Cualquiera; Direccion Local = Cualquiera; Dirección Remota = Cualquiera; Protocolo = TCP; Puerto Local = 1433 Puerto Remoto= Cualquiera; Usuarios Permitidos = Cualquiera; Equipos Permitidos= Cualquiera

    Ademas de realizar esto deshabilite el firewall para probar si de esta forma me conecta pero no tuve resultados. La instalación esta heche en modo de autenticación mixta y al intentar conectar utilizo autenticacion de SQL Server.

    jueves, 24 de febrero de 2011 20:19
  •  Hola.

     Asegurate que usas para conectarte: Microsoft SQL Server 2008 Management Studio, y no una versión anterior.

     Si has configurado SQL Server, para conectarte por el puerto 1433, desde el equipo cliente realiza un Telnet por el puerto 1433 al servidor de base de datos.

    Desde el CMD:
     Telnet 102.168.1.10 1433
    o
     Telnet  server 1433

    si todo es correcto la ventana del CMD, se quedará en negro, con el cursor parpadenado.

    Configurar Firewall de Windows para permitir el acceso a SQL Server: http://msdn.microsoft.com/es-es/library/cc646023.aspx Ejemplo para el port 1433:

    netsh firewall set portopening protocol = TCP port = 1433 name = SQLInstancedefault mode = ENABLE scope = SUBNET profile = CURRENT


    Verifica en Configuration Tools -> Sql Server Configuration Manager -> SQL Server Network Configuration y habilita el protocolo TCP/IP.

    Verifica en Management Studio -> propiedades sobre la instancia -> Opciones -> permitir las conexiones remotas.


     Norman M. Pardell 

    ||Microsoft Certified IT Professional|| Database Administrator. Database Developer. SQL Server 2008

    jueves, 24 de febrero de 2011 23:01
  • Hola Willy lo que me estaba faltando era levantar el servicio SQL Server Browser. Luego de habilitarlo conectó finalmente. Gracias por la ayuda y gracias a todos los que me dieron una mano con este problema.

     

    Francisco Carrero

    Asunción-Paraguay

    viernes, 25 de febrero de 2011 15:06